aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-12-04 07:02:35 +0000
committerWill Andrews <will@FreeBSD.org>2001-12-04 07:02:35 +0000
commitc0f7f378784906cf718b1bd491a68180f15ec55e (patch)
tree84815ae415c9737d71ecca2f9e7e7d170806f2c6
parent36e50f698538e4a6dc071f3b5363dcfab9a418cc (diff)
downloadports-c0f7f378784906cf718b1bd491a68180f15ec55e.tar.gz
ports-c0f7f378784906cf718b1bd491a68180f15ec55e.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/kio_fish/Makefile32
-rw-r--r--net/kio_fish/distinfo1
-rw-r--r--net/kio_fish/files/patch-configure.in11
-rw-r--r--net/kio_fish/files/patch-fish::fish.cpp18
-rw-r--r--net/kio_fish/pkg-comment1
-rw-r--r--net/kio_fish/pkg-descr12
-rw-r--r--net/kio_fish/pkg-plist5
8 files changed, 81 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 32a1ffde3ec5..689f42cf8c51 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -183,6 +183,7 @@
SUBDIR += kdetelnet
SUBDIR += kicq
SUBDIR += kinkatta
+ SUBDIR += kio_fish
SUBDIR += kmsn
SUBDIR += kmud
SUBDIR += konverse
diff --git a/net/kio_fish/Makefile b/net/kio_fish/Makefile
new file mode 100644
index 000000000000..ae2bccc28e0e
--- /dev/null
+++ b/net/kio_fish/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: kio_fish
+# Date created: Mon 26 Nov 2001
+# Whom: Lauri Watts <lauri@kde.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kio_fish
+PORTVERSION= 1.0.1
+CATEGORIES?= net kde
+MASTER_SITES= http://ich.bin.kein.hoschi.de/fish/
+DIST_SUBDIR= KDE
+
+MAINTAINER?= kde@FreeBSD.org
+
+USE_KDELIBS_VER=2
+INSTALLS_SHLIB= yes
+USE_AUTOCONF= yes
+USE_GMAKE= yes
+CONFIGURE_ENV+= PATH=$$PATH:${WRKSRC}/auto-bin
+MAKE_ENV+= ${CONFIGURE_ENV}
+
+pre-configure:
+ ${MKDIR} ${WRKSRC}/auto-bin
+.for AC in autoconf autoheader
+ ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
+.endfor
+.for AM in automake aclocal
+ ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/net/kio_fish/distinfo b/net/kio_fish/distinfo
new file mode 100644
index 000000000000..2197da863997
--- /dev/null
+++ b/net/kio_fish/distinfo
@@ -0,0 +1 @@
+MD5 (KDE/kio_fish-1.0.1.tar.gz) = 08154676dc975e7fc91dc2bb61de030b
diff --git a/net/kio_fish/files/patch-configure.in b/net/kio_fish/files/patch-configure.in
new file mode 100644
index 000000000000..b18a9091aba0
--- /dev/null
+++ b/net/kio_fish/files/patch-configure.in
@@ -0,0 +1,11 @@
+--- configure.in Tue Oct 9 20:54:28 2001
++++ configure.in.new Mon Nov 26 22:08:38 2001
+@@ -51,7 +51,7 @@
+ CFLAGS="$CFLAGS -D_GNU_SOURCE"
+ CXXFLAGS="$CXXFLAGS -D_GNU_SOURCE"
+
+-AC_CHECK_HEADERS(termios.h pty.h)
++AC_CHECK_HEADERS(termios.h pty.h libutil.h sys/types.h sys/ioctl.h)
+ AC_CHECK_LIB(util,openpty)
+ AC_CHECK_FUNCS(getpt openpty unlockpt grantpt isastream)
+
diff --git a/net/kio_fish/files/patch-fish::fish.cpp b/net/kio_fish/files/patch-fish::fish.cpp
new file mode 100644
index 000000000000..6eefd094e6e3
--- /dev/null
+++ b/net/kio_fish/files/patch-fish::fish.cpp
@@ -0,0 +1,18 @@
+--- fish/fish.cpp Mon Oct 22 14:52:05 2001
++++ fish/fish.cpp.new Mon Nov 26 22:13:52 2001
+@@ -39,6 +39,15 @@
+ #ifdef HAVE_TERMIOS_H
+ #include <termios.h>
+ #endif
++#ifdef HAVE_SYS_TYPES_H
++#include <sys/types.h>
++#endif
++#ifdef HAVE_SYS_IOCTL_H
++#include <sys/ioctl.h>
++#endif
++#ifdef HAVE_LIBUTIL_H
++#include <libutil.h>
++#endif
+ #include <math.h>
+ #include <unistd.h>
+ #include <sys/socket.h>
diff --git a/net/kio_fish/pkg-comment b/net/kio_fish/pkg-comment
new file mode 100644
index 000000000000..113d05e200ec
--- /dev/null
+++ b/net/kio_fish/pkg-comment
@@ -0,0 +1 @@
+A KIO module that allows you to use sftp or scp from within KDE's Konqueror
diff --git a/net/kio_fish/pkg-descr b/net/kio_fish/pkg-descr
new file mode 100644
index 000000000000..192a00bf736e
--- /dev/null
+++ b/net/kio_fish/pkg-descr
@@ -0,0 +1,12 @@
+kio_fish is a kioslave for KDE 2.0 that lets you view and manipulate
+your remote files using just a simple shell account and some standard
+unix commands on the remote machine. You get full filesystem access
+without setting up a server - no NFS, Samba, ... needed.
+
+Usage is really simple: open up a konqueror window (or use the Alt-F2
+dialog) and type 'fish://user@remote.machi.ne'. kio_fish will ask you
+for the password, if any is needed, and you will start out in your
+home directory. Now you can do everything you do on your local hard
+disk.
+
+WWW: http://ich.bin.kein.hoschi.de/fish/
diff --git a/net/kio_fish/pkg-plist b/net/kio_fish/pkg-plist
new file mode 100644
index 000000000000..30af53b7325f
--- /dev/null
+++ b/net/kio_fish/pkg-plist
@@ -0,0 +1,5 @@
+share/services/fish.protocol
+share/doc/HTML/en/fish/fish.docbook
+lib/kde2/kio_fish.so
+lib/kde2/kio_fish.la
+@dirrm share/doc/HTML/en/fish