aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2002-10-14 17:52:07 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2002-10-14 17:52:07 +0000
commitc4ed92e069fc0ade7cb0c9ae15181c22fd15888c (patch)
treea2c81d9cb0bcec4f75e98bcc12cce46c91e53231
parentad11bca6ab08e270915849180a42694f0310ec20 (diff)
downloadports-c4ed92e069fc0ade7cb0c9ae15181c22fd15888c.tar.gz
ports-c4ed92e069fc0ade7cb0c9ae15181c22fd15888c.zip
Notes
-rw-r--r--security/cyrus-sasl2/Makefile3
-rw-r--r--security/cyrus-sasl2/distinfo2
-rw-r--r--security/cyrus-sasl2/files/patch-lib::Makefile.in13
-rw-r--r--security/cyrus-sasl2/files/staticopen.h174
4 files changed, 15 insertions, 177 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index 16227c9aec42..0ebb29729f8a 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cyrus-sasl
-PORTVERSION= 2.1.8
+PORTVERSION= 2.1.9
#PORTREVISION= 0
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/ \
@@ -123,7 +123,6 @@ post-patch:
@${SED} -e "s;%%PWCHECK_METHOD%%;${PWCHECK_METHOD};g" \
-e "s;%%PREFIX%%;${PREFIX};g" \
${.CURDIR}/pkg-message > ${PKGMESSAGE}
- @${CP} ${FILESDIR}/staticopen.h ${WRKSRC}/lib
# Create Cyrus user and group
pre-install:
diff --git a/security/cyrus-sasl2/distinfo b/security/cyrus-sasl2/distinfo
index 67b2eadc4b4c..e16d45ed9c35 100644
--- a/security/cyrus-sasl2/distinfo
+++ b/security/cyrus-sasl2/distinfo
@@ -1 +1 @@
-MD5 (cyrus-sasl-2.1.8.tar.gz) = 25612a7a0c97a45ecec865edadd667cb
+MD5 (cyrus-sasl-2.1.9.tar.gz) = 19ac851b291a6631b8f8c2a2bebb7843
diff --git a/security/cyrus-sasl2/files/patch-lib::Makefile.in b/security/cyrus-sasl2/files/patch-lib::Makefile.in
new file mode 100644
index 000000000000..b4641ac7b033
--- /dev/null
+++ b/security/cyrus-sasl2/files/patch-lib::Makefile.in
@@ -0,0 +1,13 @@
+Index: lib/Makefile.in
+diff -u lib/Makefile.in.orig lib/Makefile.in
+--- lib/Makefile.in.orig Sat Oct 12 06:19:39 2002
++++ lib/Makefile.in Tue Oct 15 02:28:11 2002
+@@ -436,7 +436,7 @@
+ mostlyclean distclean maintainer-clean
+
+
+-plugin_common.lo: plugin_common.o
++plugin_common.lo:
+ ln -s $(top_builddir)/plugins/plugin_common.lo plugin_common.lo
+
+ plugin_common.o:
diff --git a/security/cyrus-sasl2/files/staticopen.h b/security/cyrus-sasl2/files/staticopen.h
deleted file mode 100644
index f3c6f54e0cac..000000000000
--- a/security/cyrus-sasl2/files/staticopen.h
+++ /dev/null
@@ -1,174 +0,0 @@
-/* staticopen.h
- * Rob Siemborski
- * Howard Chu
- * $Id: staticopen.h,v 1.5 2002/09/10 17:14:45 ken3 Exp $
- */
-/*
- * Copyright (c) 2001 Carnegie Mellon University. All rights reserved.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- *
- * 1. Redistributions of source code must retain the above copyright
- * notice, this list of conditions and the following disclaimer.
- *
- * 2. Redistributions in binary form must reproduce the above copyright
- * notice, this list of conditions and the following disclaimer in
- * the documentation and/or other materials provided with the
- * distribution.
- *
- * 3. The name "Carnegie Mellon University" must not be used to
- * endorse or promote products derived from this software without
- * prior written permission. For permission or any other legal
- * details, please contact
- * Office of Technology Transfer
- * Carnegie Mellon University
- * 5000 Forbes Avenue
- * Pittsburgh, PA 15213-3890
- * (412) 268-4387, fax: (412) 268-7395
- * tech-transfer@andrew.cmu.edu
- *
- * 4. Redistributions of any form whatsoever must retain the following
- * acknowledgment:
- * "This product includes software developed by Computing Services
- * at Carnegie Mellon University (http://www.cmu.edu/computing/)."
- *
- * CARNEGIE MELLON UNIVERSITY DISCLAIMS ALL WARRANTIES WITH REGARD TO
- * THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY
- * AND FITNESS, IN NO EVENT SHALL CARNEGIE MELLON UNIVERSITY BE LIABLE
- * FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
- * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN
- * AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING
- * OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
- */
-
-typedef enum {
- UNKNOWN = 0, SERVER = 1, CLIENT = 2, AUXPROP = 3, CANONUSER = 4
-} _sasl_plug_type;
-
-typedef struct {
- _sasl_plug_type type;
- char *name;
- sasl_client_plug_init_t *plug;
-} _sasl_plug_rec;
-
-/* For static linking */
-#define SPECIFIC_CLIENT_PLUG_INIT_PROTO( x ) \
-sasl_client_plug_init_t x##_client_plug_init
-
-#define SPECIFIC_SERVER_PLUG_INIT_PROTO( x ) \
-sasl_server_plug_init_t x##_server_plug_init
-
-#define SPECIFIC_AUXPROP_PLUG_INIT_PROTO( x ) \
-sasl_auxprop_init_t x##_auxprop_plug_init
-
-#define SPECIFIC_CANONUSER_PLUG_INIT_PROTO( x ) \
-sasl_canonuser_init_t x##_canonuser_plug_init
-
-/* Static Compillation Foo */
-#define SPECIFIC_CLIENT_PLUG_INIT( x, n )\
- { CLIENT, n, x##_client_plug_init }
-#define SPECIFIC_SERVER_PLUG_INIT( x, n )\
- { SERVER, n, (sasl_client_plug_init_t *)x##_server_plug_init }
-#define SPECIFIC_AUXPROP_PLUG_INIT( x, n )\
- { AUXPROP, n, (sasl_client_plug_init_t *)x##_auxprop_plug_init }
-#define SPECIFIC_CANONUSER_PLUG_INIT( x, n )\
- { CANONUSER, n, (sasl_client_plug_init_t *)x##_canonuser_plug_init }
-
-#ifdef STATIC_ANONYMOUS
-extern SPECIFIC_SERVER_PLUG_INIT_PROTO( anonymous );
-extern SPECIFIC_CLIENT_PLUG_INIT_PROTO( anonymous );
-#endif
-#ifdef STATIC_CRAMMD5
-extern SPECIFIC_SERVER_PLUG_INIT_PROTO( crammd5 );
-extern SPECIFIC_CLIENT_PLUG_INIT_PROTO( crammd5 );
-#endif
-#ifdef STATIC_DIGESTMD5
-extern SPECIFIC_SERVER_PLUG_INIT_PROTO( digestmd5 );
-extern SPECIFIC_CLIENT_PLUG_INIT_PROTO( digestmd5 );
-#endif
-#ifdef STATIC_GSSAPIV2
-extern SPECIFIC_SERVER_PLUG_INIT_PROTO( gssapiv2 );
-extern SPECIFIC_CLIENT_PLUG_INIT_PROTO( gssapiv2 );
-#endif
-#ifdef STATIC_KERBEROS4
-extern SPECIFIC_SERVER_PLUG_INIT_PROTO( kerberos4 );
-extern SPECIFIC_CLIENT_PLUG_INIT_PROTO( kerberos4 );
-#endif
-#ifdef STATIC_LOGIN
-extern SPECIFIC_SERVER_PLUG_INIT_PROTO( login );
-extern SPECIFIC_CLIENT_PLUG_INIT_PROTO( login );
-#endif
-#ifdef STATIC_NTLM
-extern SPECIFIC_SERVER_PLUG_INIT_PROTO( ntlm );
-extern SPECIFIC_CLIENT_PLUG_INIT_PROTO( ntlm );
-#endif
-#ifdef STATIC_OTP
-extern SPECIFIC_SERVER_PLUG_INIT_PROTO( otp );
-extern SPECIFIC_CLIENT_PLUG_INIT_PROTO( otp );
-#endif
-#ifdef STATIC_PLAIN
-extern SPECIFIC_SERVER_PLUG_INIT_PROTO( plain );
-extern SPECIFIC_CLIENT_PLUG_INIT_PROTO( plain );
-#endif
-#ifdef STATIC_SRP
-extern SPECIFIC_SERVER_PLUG_INIT_PROTO( srp );
-extern SPECIFIC_CLIENT_PLUG_INIT_PROTO( srp );
-#endif
-#ifdef STATIC_SASLDB
-extern SPECIFIC_AUXPROP_PLUG_INIT_PROTO( sasldb );
-#endif
-#ifdef STATIC_MYSQL
-extern SPECIFIC_AUXPROP_PLUG_INIT_PROTO( mysql );
-#endif
-
-_sasl_plug_rec _sasl_static_plugins[] = {
-#ifdef STATIC_ANONYMOUS
- SPECIFIC_SERVER_PLUG_INIT( anonymous, "ANONYMOUS" ),
- SPECIFIC_CLIENT_PLUG_INIT( anonymous, "ANONYMOUS" ),
-#endif
-#ifdef STATIC_CRAMMD5
- SPECIFIC_SERVER_PLUG_INIT( crammd5, "CRAM-MD5" ),
- SPECIFIC_CLIENT_PLUG_INIT( crammd5, "CRAM-MD5" ),
-#endif
-#ifdef STATIC_DIGESTMD5
- SPECIFIC_SERVER_PLUG_INIT( digestmd5, "DIGEST-MD5" ),
- SPECIFIC_CLIENT_PLUG_INIT( digestmd5, "DIGEST-MD5" ),
-#endif
-#ifdef STATIC_GSSAPIV2
- SPECIFIC_SERVER_PLUG_INIT( gssapiv2, "GSSAPI" ),
- SPECIFIC_CLIENT_PLUG_INIT( gssapiv2, "GSSAPI" ),
-#endif
-#ifdef STATIC_KERBEROS4
- SPECIFIC_SERVER_PLUG_INIT( kerberos4, "KERBEROS_V4" ),
- SPECIFIC_CLIENT_PLUG_INIT( kerberos4, "KERBEROS_V4" ),
-#endif
-#ifdef STATIC_LOGIN
- SPECIFIC_SERVER_PLUG_INIT( login, "LOGIN" ),
- SPECIFIC_CLIENT_PLUG_INIT( login, "LOGIN" ),
-#endif
-#ifdef STATIC_NTLM
- SPECIFIC_SERVER_PLUG_INIT( ntlm, "NTLM" ),
- SPECIFIC_CLIENT_PLUG_INIT( ntlm, "NTLM" ),
-#endif
-#ifdef STATIC_OTP
- SPECIFIC_SERVER_PLUG_INIT( otp, "OTP" ),
- SPECIFIC_CLIENT_PLUG_INIT( otp, "OTP" ),
-#endif
-#ifdef STATIC_PLAIN
- SPECIFIC_SERVER_PLUG_INIT( plain, "PLAIN" ),
- SPECIFIC_CLIENT_PLUG_INIT( plain, "PLAIN" ),
-#endif
-#ifdef STATIC_SRP
- SPECIFIC_SERVER_PLUG_INIT( srp, "SRP" ),
- SPECIFIC_CLIENT_PLUG_INIT( srp, "SRP" ),
-#endif
-#ifdef STATIC_SASLDB
- SPECIFIC_AUXPROP_PLUG_INIT( sasldb, "SASLDB" ),
-#endif
-#ifdef STATIC_MYSQL
- SPECIFIC_AUXPROP_PLUG_INIT( mysql, "MYSQL" ),
-#endif
- { UNKNOWN, NULL, NULL }
-};