aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-02-25 10:22:42 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-02-25 10:22:42 +0000
commitd48c061ea69db10e358a2ac3eea00998ded0b49c (patch)
treef6b8ede252e3681585e52c7145b9297f98371bde
parentcde397995e3dbf7429569b0b2a8611e5c85ce082 (diff)
downloadports-d48c061ea69db10e358a2ac3eea00998ded0b49c.tar.gz
ports-d48c061ea69db10e358a2ac3eea00998ded0b49c.zip
Notes
-rw-r--r--audio/rat/Makefile4
-rw-r--r--editors/mule-common/Makefile4
-rw-r--r--lang/pike72/Makefile4
-rw-r--r--mbone/rat/Makefile4
-rw-r--r--www/openvrml/Makefile8
5 files changed, 23 insertions, 1 deletions
diff --git a/audio/rat/Makefile b/audio/rat/Makefile
index 56e90fc6f5ce..5650b024bab3 100644
--- a/audio/rat/Makefile
+++ b/audio/rat/Makefile
@@ -35,6 +35,10 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
ENABLE_IPv6= --enable-ipv6
.endif
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rat/${RAT} ${PREFIX}/bin/${RAT}
${INSTALL_PROGRAM} ${WRKSRC}/rat/${RAT}-ui ${PREFIX}/bin/${RAT}-ui
diff --git a/editors/mule-common/Makefile b/editors/mule-common/Makefile
index 399647d2079d..bda1b392db88 100644
--- a/editors/mule-common/Makefile
+++ b/editors/mule-common/Makefile
@@ -23,6 +23,10 @@ EMACS_VERSION= 19.34
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
WRKDIRBASE= ${WRKDIRPREFIX}${.CURDIR:S,/editors/mule-common$,,}
.for dir in chinese/mule-freewnn \
diff --git a/lang/pike72/Makefile b/lang/pike72/Makefile
index a72d79c060b7..ad38d9e890be 100644
--- a/lang/pike72/Makefile
+++ b/lang/pike72/Makefile
@@ -67,6 +67,10 @@ CONFIGURE_ARGS+= --without-debug \
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
PLIST_SUB+= PORTVERSION=${PORTVERSION}
# FreeBSD 5.0 Needs to have libgmp port to support gmp.
diff --git a/mbone/rat/Makefile b/mbone/rat/Makefile
index 56e90fc6f5ce..5650b024bab3 100644
--- a/mbone/rat/Makefile
+++ b/mbone/rat/Makefile
@@ -35,6 +35,10 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
ENABLE_IPv6= --enable-ipv6
.endif
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rat/${RAT} ${PREFIX}/bin/${RAT}
${INSTALL_PROGRAM} ${WRKSRC}/rat/${RAT}-ui ${PREFIX}/bin/${RAT}-ui
diff --git a/www/openvrml/Makefile b/www/openvrml/Makefile
index 69f523312895..35458fe27454 100644
--- a/www/openvrml/Makefile
+++ b/www/openvrml/Makefile
@@ -28,7 +28,13 @@ CONFIGURE_ARGS= --without-spidermonkey --without-jdk --without-doxygen
USE_GMAKE= yes
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>