aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2014-03-15 16:54:09 +0000
committerMartin Matuska <mm@FreeBSD.org>2014-03-15 16:54:09 +0000
commitdcb84fde6a23f6f5150713b044c30f20f3bd3998 (patch)
tree69cc36905f8d1a8f18c35b232572b80c952567fa
parenta46a8a7dfaf6db0c55c38f016c54456b320793e0 (diff)
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/proftpd-mod_clamav/Makefile36
-rw-r--r--security/proftpd-mod_clamav/pkg-descr3
3 files changed, 40 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index bd714de4ce74..b081291aaf1a 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -726,6 +726,7 @@
SUBDIR += prelude-lml
SUBDIR += prelude-manager
SUBDIR += prelude-pflogger
+ SUBDIR += proftpd-mod_clamav
SUBDIR += proxycheck
SUBDIR += proxytunnel
SUBDIR += pscan
diff --git a/security/proftpd-mod_clamav/Makefile b/security/proftpd-mod_clamav/Makefile
new file mode 100644
index 000000000000..3e9c40739a2e
--- /dev/null
+++ b/security/proftpd-mod_clamav/Makefile
@@ -0,0 +1,36 @@
+# Created by: Martin Matuska <mm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mod_clamav
+DISTVERSION= 0.13rc2
+PORTREVISION= 0
+CATEGORIES= security ftp
+PKGNAMEPREFIX= proftpd-
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= ClamAV ProFTPD module
+
+LICENSE= GPLv2
+
+DESCR= ${.CURDIR}/pkg-descr
+
+LATEST_LINK= ${PKGNAMEPREFIX}-${PORTNAME}
+MASTERDIR= ${.CURDIR}/../../ftp/proftpd
+
+GH_TAGNAME= v${DISTVERSION}
+GIT_REVISION= 0b524e3
+
+RUN_DEPENDS+= clamd:${PORTSDIR}/security/clamav
+_PROFTPD_MODULE_DISTFILES= mod_clamav-v0.13rc2${EXTRACT_SUFX}:clamav
+_PROFTPD_MODULE_EXTRACT_ONLY= mod_clamav-v0.13rc2${EXTRACT_SUFX}
+_PROFTPD_MODULE_MASTER_SITES= https://codeload.github.com/jbenden/mod_clamav/legacy.tar.gz/${GH_TAGNAME}?dummy=/:clamav
+
+INCLUDEDIRS= ${LOCALBASE}/include
+LIBDIRS= ${LOCALBASE}/lib
+
+_BUILDING_PROFTPD_MODULE= ${PORTNAME}
+
+post-extract:
+ @${CP} ${WRKDIR}/jbenden-mod_clamav-${GIT_REVISION}/mod_clamav.* ${WRKSRC}/contrib
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/proftpd-mod_clamav/pkg-descr b/security/proftpd-mod_clamav/pkg-descr
new file mode 100644
index 000000000000..7ac6d796fb69
--- /dev/null
+++ b/security/proftpd-mod_clamav/pkg-descr
@@ -0,0 +1,3 @@
+ProFTPD module mod_clamav
+
+WWW: https://github.com/jbenden/mod_clamav