aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-23 19:15:05 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-23 19:15:05 +0000
commitea58b3236e75c3aa17d72ddee65e434404d3d51c (patch)
treea526baf718013553882bdcc5576a094f20266475
parent9f3acad11bebb7ea423917b13af637b2e5b7e728 (diff)
downloadports-ea58b3236e75c3aa17d72ddee65e434404d3d51c.tar.gz
ports-ea58b3236e75c3aa17d72ddee65e434404d3d51c.zip
Notes
-rw-r--r--security/pgp6/Makefile5
-rw-r--r--security/pgp6/files/patch-ar14
-rw-r--r--security/pgp6/files/patch-as13
-rw-r--r--security/pgp6/files/patch-at11
-rw-r--r--security/pgp6/files/patch-cc19
5 files changed, 57 insertions, 5 deletions
diff --git a/security/pgp6/Makefile b/security/pgp6/Makefile
index c880f15a5621..dc14d5a0d1a7 100644
--- a/security/pgp6/Makefile
+++ b/security/pgp6/Makefile
@@ -31,11 +31,6 @@ LATEST_LINK= pgp6
.include <bsd.port.pre.mk>
-#.if ${OSVERSION} >= 500113
-#BROKEN= "Does not compile"
-#.endif
-FORBIDDEN= "documented exploits exist; patches will be supplied by maintainer"
-
# the distfile is actually a tar of three compressed tars and their
# signatures
post-extract:
diff --git a/security/pgp6/files/patch-ar b/security/pgp6/files/patch-ar
new file mode 100644
index 000000000000..19ef42b122ae
--- /dev/null
+++ b/security/pgp6/files/patch-ar
@@ -0,0 +1,14 @@
+--- libs/pfl/common/lthread/pgpThreads.h.orig Mon Apr 19 10:59:53 1999
++++ libs/pfl/common/lthread/pgpThreads.h Thu Jan 22 12:34:15 2004
+@@ -138,7 +138,9 @@
+ #endif /* end HAVE_PTHREAD_ATTR_CREATE */
+
+ /* My version of Linux has sem_init in pthreads.so, but *zero* headers ?? */
+-#if HAVE_SEM_INIT && !PGP_UNIX_LINUX
++/* #if HAVE_SEM_INIT && !PGP_UNIX_LINUX
++ commented out for FreeBSD */
++#if 0
+
+ #undef HAVE_SEMGET /* prefer POSIX sem_init over semget */
+ #define HAVE_SEMGET 0
+
diff --git a/security/pgp6/files/patch-as b/security/pgp6/files/patch-as
new file mode 100644
index 000000000000..4463f446b4bf
--- /dev/null
+++ b/security/pgp6/files/patch-as
@@ -0,0 +1,13 @@
+--- libs/pfl/common/lthread/pgpSemaphore.c.old Tue Mar 17 21:08:17 1998
++++ libs/pfl/common/lthread/pgpSemaphore.c Thu Jan 22 13:00:16 2004
+@@ -41,7 +41,9 @@
+ #endif /* end PGP_UNIX_SOLARIS */
+
+ /* Linux has sem_init function but no headers ?? */
+-#if HAVE_SEM_INIT && !PGP_UNIX_LINUX
++/* #if HAVE_SEM_INIT && !PGP_UNIX_LINUX
++ commented out for FreeBSD */
++#if 0
+
+ PGPSemAttr_t PGPSemAttr_def = {0, 0};
+
diff --git a/security/pgp6/files/patch-at b/security/pgp6/files/patch-at
new file mode 100644
index 000000000000..3d3129218f0e
--- /dev/null
+++ b/security/pgp6/files/patch-at
@@ -0,0 +1,11 @@
+--- libs/pgpcdk/priv/networklib/pgpsockets/common/pgpSockets.c.orig Fri Jan 23 19:46:45 2004
++++ libs/pgpcdk/priv/networklib/pgpsockets/common/pgpSockets.c Fri Jan 23 19:47:10 2004
+@@ -41,8 +41,6 @@
+ typedef int SOCKET;
+ #if PGP_UNIX_LINUX || PGP_UNIX_HPUX || PGP_UNIX_AIX
+ int gethostname (char * name, size_t namelen);
+-#else
+-int gethostname (char * name, int namelen);
+ #endif /* PGP_UNIX_LINUX */
+ #endif
+
diff --git a/security/pgp6/files/patch-cc b/security/pgp6/files/patch-cc
new file mode 100644
index 000000000000..9366ea2eafeb
--- /dev/null
+++ b/security/pgp6/files/patch-cc
@@ -0,0 +1,19 @@
+--- clients/pgp/cmdline/doencode.c Thu Sep 30 20:10:21 1999
++++ clients/pgp/cmdline/doencode.c Thu Jan 11 20:50:20 2001
+@@ -283,6 +283,7 @@
+ PGPBoolean batchmode = pgpenvGetInt( env, PGPENV_BATCHMODE, &pri, &err );
+ PGPBoolean verbose = pgpenvGetInt( env, PGPENV_VERBOSE, &pri, &err );
+ PGPBoolean quietmode = pgpenvGetInt( env, PGPENV_NOOUT, &pri, &err);
++ PGPBoolean force = pgpenvGetInt( env, PGPENV_FORCE, &pri, &err);
+ PGPKeySetRef tmpset;
+
+ err = PGPNewEmptyKeySet( toSet, &tmpset );
+@@ -317,7 +318,7 @@
+ if(verbose)
+ pgpShowKeyValidity( filebPtr, key );
+
+- if( validity < kPGPValidity_Marginal ) {
++ if( validity < kPGPValidity_Marginal && !force) {
+ char useridstr[ kPGPMaxUserIDSize ];
+ PGPBoolean answer;
+ err = pgpGetUserIDStringFromKey( key, useridstr );