aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-09 17:48:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-09 17:48:17 +0000
commitf35b39863aef0ecfeaacc983cca41d91ebd53170 (patch)
tree6f081125f44415b8f83738c5be2c62402da3cb57
parent7d0f582779a19e1c98238184e964648d881f5165 (diff)
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/rss2html/Makefile38
-rw-r--r--textproc/rss2html/distinfo3
-rw-r--r--textproc/rss2html/pkg-descr6
4 files changed, 48 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index c63f7dd7118e..656dbeb739d1 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -924,6 +924,7 @@
SUBDIR += romdict
SUBDIR += rot
SUBDIR += rotix
+ SUBDIR += rss2html
SUBDIR += rst.el
SUBDIR += rtf2html
SUBDIR += rtfreader
diff --git a/textproc/rss2html/Makefile b/textproc/rss2html/Makefile
new file mode 100644
index 000000000000..d11177b41ea4
--- /dev/null
+++ b/textproc/rss2html/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: rss2html
+# Date created: 2009-02-01
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rss2html
+PORTVERSION= 0.8.2
+CATEGORIES= textproc
+MASTER_SITES= http://mirror.mcx2.org/ \
+ ftp://ftp.nopcode.org/prj/rss2html/
+
+MAINTAINER= adox@mcx2.org
+COMMENT= RSS to HTML converter
+
+LIB_DEPENDS+= curl.5:${PORTSDIR}/ftp/curl
+
+GNU_CONFIGURE= yes
+CFLAGS+= "-I${LOCALBASE}/include" "-L${LOCALBASE}/lib"
+
+MAN1= rss2html.1
+MANCOMPRESSED= no
+
+PLIST_FILES= bin/rss2html
+PORTDOCS= rss2html.links usage.example rss2html.template
+
+post-patch:
+ @${REINPLACE_CMD} -e '16,20d' ${WRKSRC}/Makefile.acr
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/rss2html/distinfo b/textproc/rss2html/distinfo
new file mode 100644
index 000000000000..42e1d098f580
--- /dev/null
+++ b/textproc/rss2html/distinfo
@@ -0,0 +1,3 @@
+MD5 (rss2html-0.8.2.tar.gz) = ad23d8fe53827f0e069d75c12ee64ae4
+SHA256 (rss2html-0.8.2.tar.gz) = f646ff9629b141a22b8493522cb86e8000dbbd33f9baf9997f2228060493d66b
+SIZE (rss2html-0.8.2.tar.gz) = 26582
diff --git a/textproc/rss2html/pkg-descr b/textproc/rss2html/pkg-descr
new file mode 100644
index 000000000000..b47cb56083ca
--- /dev/null
+++ b/textproc/rss2html/pkg-descr
@@ -0,0 +1,6 @@
+Minimalistic cmdline tool to fetch RSS news from HTTP or local files and
+convert them into plain text, formatted html, or token-separated strings.
+This tool can be easily integrated into shellscripts, cron tasks, motd's,
+etc.
+
+WWW: http://nopcode.org/blog/rss2html.html