aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph S. Atkinson <jsa@FreeBSD.org>2011-01-30 00:04:10 +0000
committerJoseph S. Atkinson <jsa@FreeBSD.org>2011-01-30 00:04:10 +0000
commitff39d21311072702c353712bfb79c7ff4a727c68 (patch)
tree9069a22d6a91fbfcb2141ec77e5574a3de419868
parentf36ad8bc7b956306f8188715a7f2ca5d7ac49840 (diff)
downloadports-ff39d21311072702c353712bfb79c7ff4a727c68.tar.gz
ports-ff39d21311072702c353712bfb79c7ff4a727c68.zip
Notes
-rw-r--r--multimedia/vlc/Makefile21
-rw-r--r--multimedia/vlc/distinfo4
-rw-r--r--multimedia/vlc/files/patch-modules__gui__qt4__util__customwidgets.cpp11
3 files changed, 20 insertions, 16 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 6393fe51917e..a6c561193822 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= vlc
-DISTVERSION= 1.1.5
-PORTREVISION= 2
+DISTVERSION= 1.1.6
PORTEPOCH= 3
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION}/ \
@@ -36,6 +35,7 @@ OPTIONS= A52 "A52 DVD audio decoder" On \
FLAC "Flac audio codec support" On \
FLUID "Enable Fluidsynth MIDI support" Off \
FRIBIDI "FriBidi bidirectional unicode support" Off \
+ GCRYPT "libgcrypt support" On \
GGI "General Graphic Interface support" Off \
GLX "X11 OpenGL rendering (requires XCB)" On \
GNOMEVFS "Gnome VFS support" Off \
@@ -61,6 +61,7 @@ OPTIONS= A52 "A52 DVD audio decoder" On \
PULSE "Pulse Audio support" Off \
QT4 "Qt4 Interface" On \
REALAUDIO "Real Audio(R) support" On \
+ REMOTEOSD "Remote OSD support" On \
RUNROOT "Enable running as root" Off \
SAMBA "SAMBA Access module" On \
SCHROED "Enable Schroedinger decoder" Off \
@@ -263,7 +264,7 @@ CONFIGURE_ARGS+=--enable-dca
.endif
.if defined(WITH_DVBPSI)
-LIB_DEPENDS+= dvbpsi.5:${PORTSDIR}/multimedia/libdvbpsi
+LIB_DEPENDS+= dvbpsi.6:${PORTSDIR}/multimedia/libdvbpsi
CONFIGURE_ARGS+=--enable-dvbpsi \
--with-dvbpsi=${LOCALBASE}
.else
@@ -312,6 +313,13 @@ LIB_DEPENDS+= fribidi.3:${PORTSDIR}/converters/fribidi
CONFIGURE_ARGS+=--enable-fribidi
.endif
+.if defined(WITHOUT_GCRYPT)
+CONFIGURE_ARGS+=--disable-libgcrypt
+.else
+LIB_DEPENDS+= gcrypt.17:${PORTSDIR}/security/libgcrypt
+CONFIGURE_ARGS+=--enable-libgcrypt
+.endif
+
.if defined(WITH_GGI)
LIB_DEPENDS+= ggi.2:${PORTSDIR}/graphics/libggi
CONFIGURE_ARGS+=--enable-ggi
@@ -486,6 +494,12 @@ CONFIGURE_ARGS+=--disable-real --disable-realrtsp
CONFIGURE_ARGS+=--enable-real --enable-realrtsp
.endif
+.if defined(WITHOUT_REMOTEOSD)
+CONFIGURE_ARGS+=--disable-remoteosd
+.else
+CONFIGURE_ARGS+=--enable-remoteosd
+.endif
+
.if defined(WITH_RUNROOT)
CONFIGURE_ARGS+=--enable-run-as-root
.endif
@@ -661,6 +675,7 @@ CONFIGURE_ARGS+=--disable-zvbi
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ -e '\|LIBS|s|-lrt||' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/usr/share/fonts/truetype/freefont/FreeSerifBold.ttf|${WITH_VLC_DEFAULT_FONT}|' \
${WRKSRC}/modules/misc/freetype.c
diff --git a/multimedia/vlc/distinfo b/multimedia/vlc/distinfo
index 02a1cb5a3737..4001087c9654 100644
--- a/multimedia/vlc/distinfo
+++ b/multimedia/vlc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (vlc-1.1.5.tar.bz2) = f8e3af9c317fb2e695ba2b9b7f5ac904e6eda3b078f632b98746ffc277e5ca26
-SIZE (vlc-1.1.5.tar.bz2) = 24111723
+SHA256 (vlc-1.1.6.tar.bz2) = e797f9fe60cbfc9df7c2cb019c27554213e32230a7beb4a3c6abc5287f069cac
+SIZE (vlc-1.1.6.tar.bz2) = 24631857
diff --git a/multimedia/vlc/files/patch-modules__gui__qt4__util__customwidgets.cpp b/multimedia/vlc/files/patch-modules__gui__qt4__util__customwidgets.cpp
deleted file mode 100644
index 7924a7f9a8fc..000000000000
--- a/multimedia/vlc/files/patch-modules__gui__qt4__util__customwidgets.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./modules/gui/qt4/util/customwidgets.cpp.orig 2010-06-22 02:57:13.000000000 -0400
-+++ ./modules/gui/qt4/util/customwidgets.cpp 2010-06-22 02:57:45.000000000 -0400
-@@ -380,7 +380,7 @@
-
- if( qtk <= 0xff )
- /* VLC and X11 use lowercase whereas Qt uses uppercase */
--#if defined( __STDC_ISO_10646__ ) || defined( _WIN32 )
-+#if defined( __STDC_ISO_10646__ ) || defined( _WIN32 ) || defined(__FreeBSD__)
- i_vlck = towlower( qtk );
- #else
- # error FIXME