aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-13 20:57:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-13 20:57:18 +0000
commit2b75f3ce5aa9025f4d43998c3e27f88105edde37 (patch)
treed807fa8f21dbcbb4856446c011e3fb21660c5be1
parentc8096dd738662f9f635e30cfb79ed4dc93b6a143 (diff)
downloadports-2b75f3ce5aa9025f4d43998c3e27f88105edde37.tar.gz
ports-2b75f3ce5aa9025f4d43998c3e27f88105edde37.zip
Notes
-rw-r--r--www/youtube_dl/Makefile3
-rw-r--r--www/youtube_dl/distinfo6
-rw-r--r--www/youtube_dl/files/conv2avi.patch81
3 files changed, 48 insertions, 42 deletions
diff --git a/www/youtube_dl/Makefile b/www/youtube_dl/Makefile
index 9ca11cba506a..6ee7c006ab7e 100644
--- a/www/youtube_dl/Makefile
+++ b/www/youtube_dl/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= youtube_dl
-PORTVERSION= 2008.01.24
-PORTREVISION= 1
+PORTVERSION= 2008.03.08
CATEGORIES= www
MASTER_SITES= http://www.arrakis.es/~rggi3/youtube-dl/
DISTNAME= youtube-dl-${PORTVERSION}
diff --git a/www/youtube_dl/distinfo b/www/youtube_dl/distinfo
index d6f33001b1ee..a88a33a7edff 100644
--- a/www/youtube_dl/distinfo
+++ b/www/youtube_dl/distinfo
@@ -1,3 +1,3 @@
-MD5 (youtube-dl-2008.01.24) = 48a7df743398bbfdf2710962000886cb
-SHA256 (youtube-dl-2008.01.24) = 6e98f3abfa79a038e578d45441bb6675ac6d4880bae4b801d5125e364e60d5c5
-SIZE (youtube-dl-2008.01.24) = 14643
+MD5 (youtube-dl-2008.03.08) = 026eee27b6186b3729f842e2cc10cd0e
+SHA256 (youtube-dl-2008.03.08) = 30b491cece2bae9525e95f26dcb7d238eb0487fa689696faf166b590fd50b707
+SIZE (youtube-dl-2008.03.08) = 15306
diff --git a/www/youtube_dl/files/conv2avi.patch b/www/youtube_dl/files/conv2avi.patch
index 715be2fca095..4e19c7243325 100644
--- a/www/youtube_dl/files/conv2avi.patch
+++ b/www/youtube_dl/files/conv2avi.patch
@@ -1,37 +1,44 @@
---- youtube-dl.orig Wed Jan 30 14:18:50 2008
-+++ youtube-dl Thu Jan 31 21:36:49 2008
-@@ -208,6 +208,7 @@
- cmdl_parser.add_option('-t', '--title', action='store_true', dest='use_title', help='use title in file name')
- cmdl_parser.add_option('-l', '--literal', action='store_true', dest='use_literal', help='use literal title in file name')
- cmdl_parser.add_option('-n', '--netrc', action='store_true', dest='use_netrc', help='use .netrc authentication data')
-+cmdl_parser.add_option('-a', '--avi', action='store_true', dest='use_avi', help='output file in avi format')
- cmdl_parser.add_option('-g', '--get-url', action='store_true', dest='get_url', help='print final video URL only')
- cmdl_parser.add_option('-2', '--title-too', action='store_true', dest='get_title', help='used with -g, print title too')
- (cmdl_opts, cmdl_args) = cmdl_parser.parse_args()
-@@ -382,6 +383,26 @@
-
- except KeyboardInterrupt:
- sys.exit('\n')
-+
-+# Convert to avi if needed
-+if cmdl_opts.use_avi:
-+ if cmdl_opts.outfile is None:
-+ avi_filename = '%s.avi' % video_filename[:-4]
-+ else:
-+ avi_filename = '%s.avi' % video_filename
-+
-+ try:
-+ os.system('%%CONV2AVI_CMD%% "%s" "%s" > %s 2> %s' % (video_filename, avi_filename, os.path.devnull, os.path.devnull))
-+ cond_print('Video file converted to %s\n' % avi_filename)
-+ except OSError:
-+ sys.exit('Error: unable to convert file.\n')
-+ except KeyboardInterrupt:
-+ sys.exit('\n')
-+
-+ try:
-+ os.unlink(video_filename)
-+ except OSError:
-+ sys.exit('Error: unable to remove downloaded file.\n')
-
- # Finish
- sys.exit()
+Index: www/youtube_dl/files/conv2avi.patch
+===================================================================
+RCS file: www/youtube_dl/files/conv2avi.patch
+diff -N www/youtube_dl/files/conv2avi.patch
+--- /dev/null 1 Jan 1970 00:00:00 -0000
++++ www/youtube_dl/files/conv2avi.patch 31 Jan 2008 19:32:45 -0000
+@@ -0,0 +1,37 @@
++--- youtube-dl.orig Wed Jan 30 14:18:50 2008
+++++ youtube-dl Thu Jan 31 21:36:49 2008
++@@ -208,6 +208,7 @@
++ cmdl_parser.add_option('-t', '--title', action='store_true', dest='use_title', help='use title in file name')
++ cmdl_parser.add_option('-l', '--literal', action='store_true', dest='use_literal', help='use literal title in file name')
++ cmdl_parser.add_option('-n', '--netrc', action='store_true', dest='use_netrc', help='use .netrc authentication data')
+++cmdl_parser.add_option('-a', '--avi', action='store_true', dest='use_avi', help='output file in avi format')
++ cmdl_parser.add_option('-g', '--get-url', action='store_true', dest='get_url', help='print final video URL only')
++ cmdl_parser.add_option('-2', '--title-too', action='store_true', dest='get_title', help='used with -g, print title too')
++ (cmdl_opts, cmdl_args) = cmdl_parser.parse_args()
++@@ -382,6 +383,26 @@
++
++ except KeyboardInterrupt:
++ sys.exit('\n')
+++
+++# Convert to avi if needed
+++if cmdl_opts.use_avi:
+++ if cmdl_opts.outfile is None:
+++ avi_filename = '%s.avi' % video_filename[:-4]
+++ else:
+++ avi_filename = '%s.avi' % video_filename
+++
+++ try:
+++ os.system('%%CONV2AVI_CMD%% "%s" "%s" > %s 2> %s' % (video_filename, avi_filename, os.path.devnull, os.path.devnull))
+++ cond_print('Video file converted to %s\n' % avi_filename)
+++ except OSError:
+++ sys.exit('Error: unable to convert file.\n')
+++ except KeyboardInterrupt:
+++ sys.exit('\n')
+++
+++ try:
+++ os.unlink(video_filename)
+++ except OSError:
+++ sys.exit('Error: unable to remove downloaded file.\n')
++
++ # Finish
++ sys.exit()