aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-05-24 09:00:45 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-05-24 09:00:45 +0000
commit321f72267aed977b5158d671305a16adfbd973b5 (patch)
treee11e0fee8eaf26da3aa0e189049cac75257c013b
parent90838e7c6069cc354239fecb752f70386cdf9818 (diff)
downloadports-321f72267aed977b5158d671305a16adfbd973b5.tar.gz
ports-321f72267aed977b5158d671305a16adfbd973b5.zip
MFH: r498996 security/py-pywinrm: Allow builds with Python 3.x
Upstream supports and tests against up to Python 3.6 [1] and declares up to 3.6 in its Trove Classifiers [2]. Fix incorrect Python version support declaration in USES=python accordingly, allowing Python 3.x builds. [3] While I'm here, add TEST_DEPENDS and a test target to help with QA. [1] https://github.com/diyan/pywinrm/blob/master/.travis.yml [2] setup.py: 'Programming Language :: Python :: 3.6' PR: 237178 [3] Reported by: <timp87 gmail com> [3] Approved by: portmgr (blanket: bug fix, framework compliance) Approved by: ports-secteam (blanket: bugfix)
Notes
Notes: svn path=/branches/2019Q2/; revision=502431
-rw-r--r--security/py-pywinrm/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/security/py-pywinrm/Makefile b/security/py-pywinrm/Makefile
index 01e1fd8b0695..c2ba77204391 100644
--- a/security/py-pywinrm/Makefile
+++ b/security/py-pywinrm/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pywinrm
PORTVERSION= 0.3.0
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,8 +19,16 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xmltodict>0:devel/py-xmltodict@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}requests-kerberos>=0.10.0:security/py-requests-kerberos@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests-credssp>=0.0.1:security/py-requests-credssp@${PY_FLAVOR}
-NO_ARCH= yes
-USES= python:2.7
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
+
+# Actually 2.6-2.7,3.3-3.6
+USES= python
USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v winrm/tests/
+
.include <bsd.port.mk>