aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-16 10:58:05 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-16 10:58:05 +0000
commit325c9808b65cadd4e0b1d106839a1094c90ee91b (patch)
tree75dadc0cce8409aa9d1b6143c2fcc2b63a1bd9df
parent9dabce496beb89a305dcfd8964f5849be3d7bd89 (diff)
downloadports-325c9808b65cadd4e0b1d106839a1094c90ee91b.tar.gz
ports-325c9808b65cadd4e0b1d106839a1094c90ee91b.zip
Notes
-rw-r--r--converters/wkhtmltopdf/Makefile5
-rw-r--r--devel/gearmand-devel/Makefile5
-rw-r--r--devel/gitolite/Makefile2
-rw-r--r--devel/kdesdk4/Makefile4
-rw-r--r--devel/make++/Makefile2
-rw-r--r--devel/p5-ExtUtils-ParseXS/Makefile3
-rw-r--r--devel/p5-MooseX-Types-Perl/Makefile3
-rw-r--r--devel/p5-Object-Pluggable/Makefile3
-rw-r--r--devel/p5-Reflex/Makefile3
-rw-r--r--devel/p5-SNMP-Persist/Makefile3
-rw-r--r--devel/p5-Test-MockObject/Makefile3
-rw-r--r--devel/p5-threads-shared/Makefile3
-rw-r--r--devel/ruby-langscan/Makefile3
-rw-r--r--japanese/p5-Encode-JP-Emoji/Makefile3
-rw-r--r--japanese/p5-PDFJ/Makefile3
-rw-r--r--science/abinit/Makefile4
-rw-r--r--science/clhep/Makefile4
-rw-r--r--science/mpqc/Makefile3
-rw-r--r--science/vmd/Makefile4
19 files changed, 34 insertions, 29 deletions
diff --git a/converters/wkhtmltopdf/Makefile b/converters/wkhtmltopdf/Makefile
index ff9fbb978bf5..48f50a3825bf 100644
--- a/converters/wkhtmltopdf/Makefile
+++ b/converters/wkhtmltopdf/Makefile
@@ -20,11 +20,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-qt
INSTALL_WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
WKQTVERSION= 6053b687
-USES= pkgconfig
+USES= pkgconfig gmake perl5
USE_XORG= x11 xext xrender
-USE_PERL5_BUILD= yes
+USE_PERL5= build
USE_LDCONFIG= yes
-USE_GMAKE= yes
HAS_CONFIGURE= yes
OPTIONS_DEFINE= BUNDLED_LIBS
diff --git a/devel/gearmand-devel/Makefile b/devel/gearmand-devel/Makefile
index 70ac7f3f15f5..632159a88f17 100644
--- a/devel/gearmand-devel/Makefile
+++ b/devel/gearmand-devel/Makefile
@@ -32,10 +32,9 @@ USERS= gearmand
GROUPS= gearmand
FETCH_ARGS= -pRr
-USE_PERL5_BUILD=yes
+USE_PERL5= build
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USES= pathfix
+USES= pathfix perl5 gmake
USE_LDCONFIG= yes
USE_PYTHON_BUILD=yes
USE_RC_SUBR= gearmand
diff --git a/devel/gitolite/Makefile b/devel/gitolite/Makefile
index 28925d457f9b..89f20a07c8a9 100644
--- a/devel/gitolite/Makefile
+++ b/devel/gitolite/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= git>=0:${PORTSDIR}/devel/git
CONFLICTS= gitolite-[^3]*
-USE_PERL5= yes
+USES= perl5
SUB_FILES= pkg-message
diff --git a/devel/kdesdk4/Makefile b/devel/kdesdk4/Makefile
index 108d4ec16dca..ad26e1eb1043 100644
--- a/devel/kdesdk4/Makefile
+++ b/devel/kdesdk4/Makefile
@@ -26,12 +26,10 @@ USE_XZ= yes
USE_GNOME= libxml2 libxslt
USE_KDE4= kdehier kdelibs kdeprefix libkonq pimlibs sharedmime \
akonadi automoc4 qimageblitz_build strigi
-USES= cmake:outsource
-USE_PERL5= yes
+USES= cmake:outsource perl5 gmake
USE_QT4= corelib dbus declarative designer gui qt3support \
script scripttools sql xml \
qmake_build moc_build rcc_build uic_build uic3_build
-USE_GMAKE= yes
USE_LDCONFIG= yes
CMAKE_ARGS+= -DCMAKE_REQUIRED_INCLUDES:STRING="${LOCALBASE}/include"
diff --git a/devel/make++/Makefile b/devel/make++/Makefile
index 01818f3b3b5b..2b0e76dc3c20 100644
--- a/devel/make++/Makefile
+++ b/devel/make++/Makefile
@@ -19,8 +19,8 @@ COMMENT= A drop-in replacement for GNU make
LICENSE= ART10 GPLv1 GPLv2 GPLv3
LICENSE_COMB= dual
+USES= perl5
USE_XZ= yes
-USE_PERL5= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MANPREFIX}/man
diff --git a/devel/p5-ExtUtils-ParseXS/Makefile b/devel/p5-ExtUtils-ParseXS/Makefile
index baf320ed379c..a9f9d46ff379 100644
--- a/devel/p5-ExtUtils-ParseXS/Makefile
+++ b/devel/p5-ExtUtils-ParseXS/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= Converts Perl XS code into C code
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERl5= configure
MAN3= ExtUtils::ParseXS.3 \
ExtUtils::ParseXS::Constants.3 \
diff --git a/devel/p5-MooseX-Types-Perl/Makefile b/devel/p5-MooseX-Types-Perl/Makefile
index 65a86c3b4c05..c455456fe6c2 100644
--- a/devel/p5-MooseX-Types-Perl/Makefile
+++ b/devel/p5-MooseX-Types-Perl/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-MooseX-Types>=0:${PORTSDIR}/devel/p5-MooseX-Types \
p5-Params-Util>=0:${PORTSDIR}/devel/p5-Params-Util
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MooseX::Types::Perl.3
diff --git a/devel/p5-Object-Pluggable/Makefile b/devel/p5-Object-Pluggable/Makefile
index f3f638772fce..bfa2952f67ab 100644
--- a/devel/p5-Object-Pluggable/Makefile
+++ b/devel/p5-Object-Pluggable/Makefile
@@ -21,7 +21,8 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Object::Pluggable.3 \
Object::Pluggable::Constants.3 \
diff --git a/devel/p5-Reflex/Makefile b/devel/p5-Reflex/Makefile
index d548b971f9f0..e5832da57e46 100644
--- a/devel/p5-Reflex/Makefile
+++ b/devel/p5-Reflex/Makefile
@@ -23,7 +23,8 @@ BUILD_DEPENDS= p5-POE>=1.294:${PORTSDIR}/devel/p5-POE \
p5-MooseX-Role-Parameterized>=0.23:${PORTSDIR}/devel/p5-MooseX-Role-Parameterized
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/devel/p5-SNMP-Persist/Makefile b/devel/p5-SNMP-Persist/Makefile
index bc158d859d15..aa37e14a644f 100644
--- a/devel/p5-SNMP-Persist/Makefile
+++ b/devel/p5-SNMP-Persist/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jadawin@FreeBSD.org
COMMENT= The module is a backend for pass_persist feature of net-snmp
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SNMP::Persist.3
diff --git a/devel/p5-Test-MockObject/Makefile b/devel/p5-Test-MockObject/Makefile
index fc2a3a1c997a..db5c26f16790 100644
--- a/devel/p5-Test-MockObject/Makefile
+++ b/devel/p5-Test-MockObject/Makefile
@@ -22,7 +22,8 @@ RUN_DEPENDS= p5-UNIVERSAL-can>=1.20110617:${PORTSDIR}/devel/p5-UNIVERSAL-can \
TEST_DEPENDS= p5-Test-Exception>=0.31:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-Warn>=0.23:${PORTSDIR}/devel/p5-Test-Warn
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
INSTALL_TARGET= pure_install
MAN3= Test::MockObject.3 Test::MockObject::Extends.3
diff --git a/devel/p5-threads-shared/Makefile b/devel/p5-threads-shared/Makefile
index c85283191b39..4926ac6ca8d3 100644
--- a/devel/p5-threads-shared/Makefile
+++ b/devel/p5-threads-shared/Makefile
@@ -14,7 +14,8 @@ COMMENT= Perl extension for sharing data structures between threads
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= threads::shared.3
diff --git a/devel/ruby-langscan/Makefile b/devel/ruby-langscan/Makefile
index 8a170f70ed18..c0fb1e9efdc2 100644
--- a/devel/ruby-langscan/Makefile
+++ b/devel/ruby-langscan/Makefile
@@ -17,9 +17,10 @@ LICENSE= GPLv2
RUN_DEPENDS= p5-PPI>=0:${PORTSDIR}/textproc/p5-PPI
BUILD_DEPENDS= flex>=2.5.31:${PORTSDIR}/textproc/flex
+USES= perl5
USE_AUTOTOOLS= aclocal:env automake:env autoconf:env
USE_RUBY= yes
-USE_PERL5_RUN= yes
+USE_PERL5= run
USE_OCAML= yes
NO_OCAML_RUNDEPENDS= yes
HAS_CONFIGURE= yes
diff --git a/japanese/p5-Encode-JP-Emoji/Makefile b/japanese/p5-Encode-JP-Emoji/Makefile
index 3a21df379ffa..4cab80aaf901 100644
--- a/japanese/p5-Encode-JP-Emoji/Makefile
+++ b/japanese/p5-Encode-JP-Emoji/Makefile
@@ -13,7 +13,8 @@ MASTER_SITES= CPAN
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension for Emoji encodings and cross-mapping tables
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Encode::JP::Emoji.3 \
Encode::JP::Emoji::Encoding.3 \
diff --git a/japanese/p5-PDFJ/Makefile b/japanese/p5-PDFJ/Makefile
index 688b4285612e..a90af7577eae 100644
--- a/japanese/p5-PDFJ/Makefile
+++ b/japanese/p5-PDFJ/Makefile
@@ -14,8 +14,9 @@ MASTER_SITES= http://hp1.jonex.ne.jp/%7Enakajima.yasushi/archives/
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= PDFJ module provides methods to generate Japanese PDF file
+USES= perl5
USE_ZIP= YES
-PERL_CONFIGURE= YES
+USE_PERL5= configure
WRKSRC= ${WRKDIR}
EXTRACT_BEFORE_ARGS= -qo -a
diff --git a/science/abinit/Makefile b/science/abinit/Makefile
index 03d83a55927a..1eb365ecfa7f 100644
--- a/science/abinit/Makefile
+++ b/science/abinit/Makefile
@@ -18,10 +18,10 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numarray/__init__.py:${PORTSDIR}/math/py-num
LIB_DEPENDS= netcdff.4:${PORTSDIR}/science/netcdf3-ftn \
gsl:${PORTSDIR}/math/gsl
+USES= gmake perl5
USE_FORTRAN= yes
-USE_GMAKE= yes
USE_PYTHON= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
USE_AUTOTOOLS= autoconf automake
CONFIGURE_ENV= WGET=${TRUE}
CONFIGURE_ARGS= --disable-wannier90 --disable-bigdft --disable-etsf-io \
diff --git a/science/clhep/Makefile b/science/clhep/Makefile
index f2d8c00820a3..9906978ef187 100644
--- a/science/clhep/Makefile
+++ b/science/clhep/Makefile
@@ -16,8 +16,8 @@ COMMENT= Object-oriented toolkit for particle physics applications by CERN
WRKSRC= ${WRKDIR}/${PORTVERSION}/${PORTNAME:U}
-USE_PERL5_BUILD= yes
-USE_GMAKE= yes
+USES= gmake perl5
+USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gmake
USE_LDCONFIG= yes
diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile
index eef11f0ffcea..58730589402b 100644
--- a/science/mpqc/Makefile
+++ b/science/mpqc/Makefile
@@ -14,8 +14,7 @@ MASTER_SITES= SF
MAINTAINER= maho@FreeBSD.org
COMMENT= The massively parallel quantum computing library and program
-USE_PERL5= yes
-USE_GMAKE= yes
+USES= perl5 gmake
USE_BZIP2= yes
USE_LDCONFIG= yes
diff --git a/science/vmd/Makefile b/science/vmd/Makefile
index b9171f40e747..59c3beec42b5 100644
--- a/science/vmd/Makefile
+++ b/science/vmd/Makefile
@@ -22,8 +22,8 @@ LIB_DEPENDS= tcl85:${PORTSDIR}/lang/tcl85 \
netcdf:${PORTSDIR}/science/netcdf
RUN_DEPENDS= ${PYNUMERIC}
-USE_PERL5_BUILD= yes
-USE_GMAKE= yes
+USES= gmake perl5
+USE_PERL5= build
USE_GL= glu
USE_PYTHON= yes