aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-07-01 07:08:36 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-07-01 07:08:36 +0000
commit5cdf5cd6258982e642ea60d726a57cdc33660267 (patch)
treeb0a4003e52b8bab0b8d079e13e6abd1416486479
parent24a93a5bd86d37e8c8ef88c64232b55a61cb6e73 (diff)
downloadports-5cdf5cd6258982e642ea60d726a57cdc33660267.tar.gz
ports-5cdf5cd6258982e642ea60d726a57cdc33660267.zip
MFH: r505210 lang/python35: Use -std=c99
Python 3.5 is currently failing to build the pickle module on GCC-based architectures, with the following (several) errors: error: 'for' loop initial declaration used outside C99 mode This causes packaging to fail, as the pickle module filename changes on failure to build, so the plist ends up incorrect Python 3.6+ switched to using -std=c99 [1][2], but the changes were not backported to 3.5 [1] https://bugs.python.org/issue28017 [2] https://hg.python.org/cpython/rev/b5b2bb56d303 [3] https://hg.python.org/cpython/rev/91017e2202ae PR: 238821 Reviewed by: koobs (python) Approved by: koobs (python), mat (mentor) Differential Revision: https://reviews.freebsd.org/D20778 Approved by: ports-secteam (blanket: build fix)
Notes
Notes: svn path=/branches/2019Q2/; revision=505546
-rw-r--r--lang/python35/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/python35/Makefile b/lang/python35/Makefile
index f43f2643cf43..06432c67e6b4 100644
--- a/lang/python35/Makefile
+++ b/lang/python35/Makefile
@@ -16,6 +16,7 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
USES= cpe ncurses pathfix pkgconfig readline:port shebangfix ssl tar:xz
+USE_CSTD= c99
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes