aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-03-22 17:04:43 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-03-22 17:04:43 +0000
commit63db2630dc03d797bcf04c652282445a51e48649 (patch)
tree258b7356e6d6bd130ea4ee3e363bf592ec054957
parenta37ee9ecdb272b1d2710f2d2b709e4f0845ee3c6 (diff)
downloadports-63db2630dc03d797bcf04c652282445a51e48649.tar.gz
ports-63db2630dc03d797bcf04c652282445a51e48649.zip
Notes
-rw-r--r--x11/kdelibs3/Makefile2
-rw-r--r--x11/kdelibs3/files/patch-kdecore-kcharsets.cpp36
-rw-r--r--x11/kdelibs4/Makefile2
-rw-r--r--x11/kdelibs4/files/patch-kdecore-kcharsets.cpp36
4 files changed, 74 insertions, 2 deletions
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index f996c1cd6231..a7639bcba687 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
diff --git a/x11/kdelibs3/files/patch-kdecore-kcharsets.cpp b/x11/kdelibs3/files/patch-kdecore-kcharsets.cpp
new file mode 100644
index 000000000000..231f234b211f
--- /dev/null
+++ b/x11/kdelibs3/files/patch-kdecore-kcharsets.cpp
@@ -0,0 +1,36 @@
+--- kdecore/kcharsets.cpp 2003/09/06 19:06:29 1.144
++++ kdecore/kcharsets.cpp 2004/03/12 09:18:03 1.144.2.1
+@@ -1,6 +1,6 @@
+ /* This file is part of the KDE libraries
+ Copyright (C) 1999 Lars Knoll (knoll@kde.org)
+- $Id: kcharsets.cpp,v 1.144 2003/09/06 19:06:29 binner Exp $
++ $Id: kcharsets.cpp,v 1.144.2.1 2004/03/12 09:18:03 kalass Exp $
+
+ This library is free software; you can redistribute it and/or
+ modify it under the terms of the GNU Library General Public
+@@ -497,19 +497,19 @@ QString KCharsets::languageForEncoding(
+
+ QString KCharsets::encodingForName( const QString &descriptiveName )
+ {
+- const int left = descriptiveName.find( '(' );
++ const int left = descriptiveName.findRev( '(' );
+
+ if (left<0) // No parenthesis, so assume it is a normal encoding name
+- return descriptiveName;
++ return descriptiveName.stripWhiteSpace();
+
+- QString name(descriptiveName.mid(left+2));
++ QString name(descriptiveName.mid(left+1));
+
+- const int right = name.find( ')' );
++ const int right = name.findRev( ')' );
+
+ if (right<0)
+ return name;
+-
+- return name.left(right-1);
++
++ return name.left(right).stripWhiteSpace();
+ }
+
+ QStringList KCharsets::descriptiveEncodingNames() \ No newline at end of file
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index f996c1cd6231..a7639bcba687 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
diff --git a/x11/kdelibs4/files/patch-kdecore-kcharsets.cpp b/x11/kdelibs4/files/patch-kdecore-kcharsets.cpp
new file mode 100644
index 000000000000..231f234b211f
--- /dev/null
+++ b/x11/kdelibs4/files/patch-kdecore-kcharsets.cpp
@@ -0,0 +1,36 @@
+--- kdecore/kcharsets.cpp 2003/09/06 19:06:29 1.144
++++ kdecore/kcharsets.cpp 2004/03/12 09:18:03 1.144.2.1
+@@ -1,6 +1,6 @@
+ /* This file is part of the KDE libraries
+ Copyright (C) 1999 Lars Knoll (knoll@kde.org)
+- $Id: kcharsets.cpp,v 1.144 2003/09/06 19:06:29 binner Exp $
++ $Id: kcharsets.cpp,v 1.144.2.1 2004/03/12 09:18:03 kalass Exp $
+
+ This library is free software; you can redistribute it and/or
+ modify it under the terms of the GNU Library General Public
+@@ -497,19 +497,19 @@ QString KCharsets::languageForEncoding(
+
+ QString KCharsets::encodingForName( const QString &descriptiveName )
+ {
+- const int left = descriptiveName.find( '(' );
++ const int left = descriptiveName.findRev( '(' );
+
+ if (left<0) // No parenthesis, so assume it is a normal encoding name
+- return descriptiveName;
++ return descriptiveName.stripWhiteSpace();
+
+- QString name(descriptiveName.mid(left+2));
++ QString name(descriptiveName.mid(left+1));
+
+- const int right = name.find( ')' );
++ const int right = name.findRev( ')' );
+
+ if (right<0)
+ return name;
+-
+- return name.left(right-1);
++
++ return name.left(right).stripWhiteSpace();
+ }
+
+ QStringList KCharsets::descriptiveEncodingNames() \ No newline at end of file