aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-07-01 06:19:57 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-07-01 06:19:57 +0000
commit6433b765674d223adfcbd1a4654bbbade6c097b5 (patch)
tree8c70464b7eb53954f1e26e03e1cf20df2af4d6ae
parent7d1526bbbac1e8765bf30227419763c216e0af1b (diff)
downloadports-6433b765674d223adfcbd1a4654bbbade6c097b5.tar.gz
ports-6433b765674d223adfcbd1a4654bbbade6c097b5.zip
MFH: r503168 security/py-fail2ban: Fix rc script
The rc.d script evaluates fail2ban_pidfile before rc.conf is read. This change moves those evaluations to the corect place allowing users to override the values via /etc/rc.conf as expected. PR: 236017 Reported by: <epopen gmail com>, Dmitry Wagin <dmitry.wagin ya ru> Submitted by: <theis gmx at> (maintainer) Approved by: ports-secteam (blanket: bugfix)
Notes
Notes: svn path=/branches/2019Q2/; revision=505539
-rw-r--r--security/py-fail2ban/Makefile1
-rw-r--r--security/py-fail2ban/files/fail2ban.in12
2 files changed, 9 insertions, 4 deletions
diff --git a/security/py-fail2ban/Makefile b/security/py-fail2ban/Makefile
index 06dd4eec3dff..d5fcd545aad4 100644
--- a/security/py-fail2ban/Makefile
+++ b/security/py-fail2ban/Makefile
@@ -2,6 +2,7 @@
PORTNAME= fail2ban
PORTVERSION= 0.10.4
+PORTREVISION= 1
CATEGORIES= security python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/security/py-fail2ban/files/fail2ban.in b/security/py-fail2ban/files/fail2ban.in
index ebaa0f8dd7bf..954d391fc0c2 100644
--- a/security/py-fail2ban/files/fail2ban.in
+++ b/security/py-fail2ban/files/fail2ban.in
@@ -8,14 +8,10 @@
# fail2ban_enable="YES"
# fail2ban_flags="<set as needed>"
-fail2ban_enable=${fail2ban_enable-"NO"}
-fail2ban_pidfile=${fail2ban_pidfile-"/var/run/fail2ban/fail2ban.pid"}
-
. /etc/rc.subr
name="fail2ban"
rcvar=fail2ban_enable
-pidfile="${fail2ban_pidfile}"
command="%%PREFIX%%/bin/fail2ban-server"
command_interpreter="%%PYTHON_CMD%%"
@@ -25,6 +21,14 @@ extra_commands="reload jailstatus"
load_rc_config ${name}
+#
+# DO NOT CHANGE THESE DEFAULT VALUES HERE
+# SET THEM IN THE /etc/rc.conf FILE
+#
+
+fail2ban_enable=${fail2ban_enable-"NO"}
+pidfile=${fail2ban_pidfile-"/var/run/fail2ban/fail2ban.pid"}
+
start_cmd="${client} ${fail2ban_flags} start"
stop_cmd="${client} ${fail2ban_flags} stop"
reload_cmd="${client} ${fail2ban_flags} reload"