aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2007-05-25 23:05:08 +0000
committerKris Kennaway <kris@FreeBSD.org>2007-05-25 23:05:08 +0000
commit71b36ac46930076196cdfd6a9313c36003da6260 (patch)
tree929b82f8a19080f9e96ed6865266659b3d97d0fd
parent55abac1679dcc04d780ac2877f1f60a4c446b3b0 (diff)
downloadports-71b36ac46930076196cdfd6a9313c36003da6260.tar.gz
ports-71b36ac46930076196cdfd6a9313c36003da6260.zip
Notes
-rw-r--r--audio/alienwah/Makefile8
-rw-r--r--irc/bopm/Makefile8
-rw-r--r--misc/alevt/Makefile4
-rw-r--r--misc/asbutton/Makefile8
-rw-r--r--net-mgmt/arts++/Makefile8
-rw-r--r--security/audit/Makefile4
-rw-r--r--www/bk_edit/Makefile8
-rw-r--r--x11-themes/buffy/Makefile8
-rw-r--r--x11-wm/amaterus/Makefile8
-rw-r--r--x11/buttonbox/Makefile8
10 files changed, 64 insertions, 8 deletions
diff --git a/audio/alienwah/Makefile b/audio/alienwah/Makefile
index 403a4021f43f..5ef877a6aef3 100644
--- a/audio/alienwah/Makefile
+++ b/audio/alienwah/Makefile
@@ -21,7 +21,13 @@ USE_LDCONFIG= yes
PLIST_FILES= lib/ladspa/aw.so
MAKE_ARGS= CPP="${CXX}" CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include -fPIC"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
do-install:
@${INSTALL_DATA} ${WRKSRC}/aw.so ${LOCALBASE}/lib/ladspa
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/irc/bopm/Makefile b/irc/bopm/Makefile
index 0f25b474e7ff..dee5e836f9ec 100644
--- a/irc/bopm/Makefile
+++ b/irc/bopm/Makefile
@@ -29,6 +29,12 @@ SUB_FILES= pkg-message pkg-install pkg-deinstall
PLIST_SUB= LOGDIR=${LOGDIR}
SUB_LIST= LOGDIR=${LOGDIR}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
pre-su-install:
@${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@@ -50,4 +56,4 @@ post-install:
@${CHMOD} 640 ${PREFIX}/etc/bopm.conf.sample
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/misc/alevt/Makefile b/misc/alevt/Makefile
index 9216db6eb181..c67e7b9ee971 100644
--- a/misc/alevt/Makefile
+++ b/misc/alevt/Makefile
@@ -22,6 +22,10 @@ MAN1= alevt.1x alevt-date.1 alevt-cap.1
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
.if defined(WITH_PNG)
LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
MAKE_ARGS+= -DWITH_PNG
diff --git a/misc/asbutton/Makefile b/misc/asbutton/Makefile
index fa29fac73c65..4a3ce1370954 100644
--- a/misc/asbutton/Makefile
+++ b/misc/asbutton/Makefile
@@ -21,6 +21,12 @@ MAKE_ARGS= INCLUDES="-I${X11BASE}/include/X11 -I${X11BASE}/include" \
LIBINC="-L${X11BASE}/lib" LIBS="-lm -lX11 -lXpm -lXext" \
CCFLAGS="${CFLAGS}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's:gcc :${CC} :' ${WRKSRC}/Makefile
@@ -37,4 +43,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/.asbuttonrc ${PREFIX}/share/examples/asbutton/asbuttonrc && ${CHMOD} u+rw ${PREFIX}/share/examples/asbutton/asbuttonrc
@${ECHO} "===> Use 'asbutton -h' for help."
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/arts++/Makefile b/net-mgmt/arts++/Makefile
index 9e3dea9fa2ab..938e87c4b383 100644
--- a/net-mgmt/arts++/Makefile
+++ b/net-mgmt/arts++/Makefile
@@ -24,6 +24,12 @@ MANL= artsportagg.l artsports.l artsprotos.l artsnets.l artsdump.l \
artsasagg.l artsportms.l artsportmagg.l artsintfms.l \
artsintfmagg.l artsnexthops.l artsnexthopagg.l artstos.l
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig
@@ -41,4 +47,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/audit/Makefile b/security/audit/Makefile
index 32c7a600884a..68b8978b9e12 100644
--- a/security/audit/Makefile
+++ b/security/audit/Makefile
@@ -61,6 +61,10 @@ LIBVERSION= 1
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
${REINPLACE_CMD} -e "s@Linux@FreeBSD@g" ${WRKSRC}/configure
(${FIND} ${WRKSRC}/src/modules -name Makefile.in -exec \
diff --git a/www/bk_edit/Makefile b/www/bk_edit/Makefile
index 17971b3c9d5a..30972487eb0d 100644
--- a/www/bk_edit/Makefile
+++ b/www/bk_edit/Makefile
@@ -21,6 +21,12 @@ USE_GETOPT_LONG= yes
HAS_CONFIGURE= yes
MAKE_ENV= LD="${CC}" LDFLAGS="${LDFLAGS}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "*Makefile*" | ${XARGS} ${REINPLACE_CMD} -e \
's|^CC .*=|CC ?=|g ; \
@@ -34,4 +40,4 @@ do-install:
@${MKDIR} ${PREFIX}/lib/bkedit
${INSTALL_DATA} ${WRKSRC}/src/plugins/*.so ${PREFIX}/lib/bkedit
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-themes/buffy/Makefile b/x11-themes/buffy/Makefile
index 22bb7171a548..3fc0a30d3a67 100644
--- a/x11-themes/buffy/Makefile
+++ b/x11-themes/buffy/Makefile
@@ -22,9 +22,15 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GNOME= gtk12
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-wm/amaterus/Makefile b/x11-wm/amaterus/Makefile
index 0ec444140e66..cd8955d315c7 100644
--- a/x11-wm/amaterus/Makefile
+++ b/x11-wm/amaterus/Makefile
@@ -22,4 +22,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11/buttonbox/Makefile b/x11/buttonbox/Makefile
index 3dac8044c74a..eabe9a3f95d0 100644
--- a/x11/buttonbox/Makefile
+++ b/x11/buttonbox/Makefile
@@ -22,6 +22,12 @@ PLIST= ${WRKDIR}/pkg-plist
USE_X_PREFIX= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} -o buttonbox -L${X11BASE}/lib \
-I${X11BASE}/include -lX11 -lXext button.c configuration.c \
@@ -47,4 +53,4 @@ do-install:
done
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>