aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2019-05-28 14:08:12 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2019-05-28 14:08:12 +0000
commit7afee3754dea3bbbf690c0d1789de56b9628121f (patch)
treea853cf8b7058b394e052076ebaf6add3db264e55
parent769715a36deeaded0ba3ef67756fb2185dd8afc2 (diff)
downloadports-7afee3754dea3bbbf690c0d1789de56b9628121f.tar.gz
ports-7afee3754dea3bbbf690c0d1789de56b9628121f.zip
MFH: r500370 r502895
Approved by: portmgr (with hat) Update neovim to 0.3.5 Maintenance release to fix issues found in v0.3.4. options: properly reset directories on 'autochdir' Remove MSVC optimization workaround for SHM_ALL Make SHM_ALL to a variable instead of a compound literal #define doc: mention "pynvim" module rename screen: don't crash when drawing popupmenu with 'rightleft' option look-behind match may use the wrong line number :terminal : set topline based on window height :recover : Fix crash on non-existent *.swp Disable LuaJIT on non-x86 architectures The version of LuaJIT in port doesn't work well (or at all) for neovim on non-x86 architectures. Plus, some users (at least the submitter, who made a good argument for it) may not want LuaJIT at all. So, make LuaJIT an OPTION. Enable it by default, and exclude it from all the archs that LuaJIT+neovim doesn't work on. Fall back instead on normal Lua. PR: 238079 Submitted by: Greg V
Notes
Notes: svn path=/branches/2019Q2/; revision=502897
-rw-r--r--editors/neovim/Makefile21
-rw-r--r--editors/neovim/distinfo6
2 files changed, 19 insertions, 8 deletions
diff --git a/editors/neovim/Makefile b/editors/neovim/Makefile
index 8d2c14ac1d08..c1c69f824ba3 100644
--- a/editors/neovim/Makefile
+++ b/editors/neovim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= neovim
DISTVERSIONPREFIX= v
-DISTVERSION= 0.3.4
+DISTVERSION= 0.3.5
PORTREVISION= 1
CATEGORIES= editors
@@ -15,8 +15,7 @@ LICENSE= APACHE20
BUILD_DEPENDS= gperf:devel/gperf \
${LUA_MODLIBDIR}/bit.so:devel/lua-bitop \
${LUA_MODLIBDIR}/lpeg.so:devel/lua-lpeg
-LIB_DEPENDS= libluajit-5.1.so:lang/luajit \
- libmsgpackc.so:devel/msgpack \
+LIB_DEPENDS= libmsgpackc.so:devel/msgpack \
libtermkey.so:devel/libtermkey \
libunibilium.so:devel/unibilium \
libuv.so:devel/libuv \
@@ -26,7 +25,7 @@ TEST_DEPENDS= autoconf>=0:devel/autoconf \
gmake:devel/gmake \
libtool:devel/libtool
-USES= cmake iconv lua:build pathfix pkgconfig
+USES= cmake iconv pathfix pkgconfig
USE_GITHUB= yes
GH_TUPLE= libmpack:libmpack:1.0.5:libmpack \
libmpack:libmpack-lua:1.0.7:libmpack_lua
@@ -35,8 +34,20 @@ CMAKE_ARGS= -DLUA_PRG:FILEPATH="${LUA_CMD}" \
-DCMAKE_INSTALL_MANDIR:PATH="${MANPREFIX}/man" \
-DDEPS_PREFIX:PATH="${LOCALBASE}"
-OPTIONS_DEFINE= NLS PYNVIM
+OPTIONS_DEFINE= LUAJIT NLS PYNVIM
+OPTIONS_DEFAULT=LUAJIT
+OPTIONS_EXCLUDE_aarch64=LUAJIT
+OPTIONS_EXCLUDE_mips64= LUAJIT
+OPTIONS_EXCLUDE_powerpc64= LUAJIT
+OPTIONS_EXCLUDE_riscv= LUAJIT
+OPTIONS_EXCLUDE_sparc64=LUAJIT
OPTIONS_SUB= yes
+
+LUAJIT_DESC= Use LuaJIT for faster Lua code
+LUAJIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit
+LUAJIT_USES= lua:build
+LUAJIT_CMAKE_OFF= -DPREFER_LUA:BOOL="ON"
+LUAJIT_USES_OFF= lua:52
NLS_CMAKE_BOOL= ENABLE_LIBINTL
NLS_USES= gettext
PYNVIM_DESC= Enable support for plugins written in python
diff --git a/editors/neovim/distinfo b/editors/neovim/distinfo
index f58337519916..0ab5f3c106bb 100644
--- a/editors/neovim/distinfo
+++ b/editors/neovim/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1547390550
-SHA256 (neovim-neovim-v0.3.4_GH0.tar.gz) = a641108bdebfaf319844ed46b1bf35d6f7c30ef5aeadeb29ba06e19c3274bc0e
-SIZE (neovim-neovim-v0.3.4_GH0.tar.gz) = 9231575
+TIMESTAMP = 1556484851
+SHA256 (neovim-neovim-v0.3.5_GH0.tar.gz) = b8b30043963133214f78901cb6361189c8f94e9f5f1b2493a7cedb4c323236d6
+SIZE (neovim-neovim-v0.3.5_GH0.tar.gz) = 9232168
SHA256 (libmpack-libmpack-1.0.5_GH0.tar.gz) = 4ce91395d81ccea97d3ad4cb962f8540d166e59d3e2ddce8a22979b49f108956
SIZE (libmpack-libmpack-1.0.5_GH0.tar.gz) = 32966
SHA256 (libmpack-libmpack-lua-1.0.7_GH0.tar.gz) = 2ebe9c8972c378040c9b8505f5fb40a0c64d990cd68be6a62989362b18294d0a