aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2019-06-10 17:08:16 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2019-06-10 17:08:16 +0000
commit7ff71f7d57f3f29187296f16f0c7d33254a4d8da (patch)
treeed9722555c2f6dc56e8e35d9b6b0b8b32d123c13
parent64a47d110e1d20db47065f2464d2c9f248c6bc7c (diff)
downloadports-7ff71f7d57f3f29187296f16f0c7d33254a4d8da.tar.gz
ports-7ff71f7d57f3f29187296f16f0c7d33254a4d8da.zip
MFH: r503784 r503787
Bumped seahub version for init script to fix gunicorn binary name Fix checksum due to retagged version Change currently unused init var seahub_host so there is no breakage for current users of seahub. Change hard coded 0.0.0.0 for gunicorn start to seahub_host. PR: 237366 237367 Approved by: ports-secteam (joneum)
Notes
Notes: svn path=/branches/2019Q2/; revision=503918
-rw-r--r--net-mgmt/seafile-server/Makefile.include3
-rw-r--r--www/seahub/Makefile1
-rw-r--r--www/seahub/distinfo6
-rw-r--r--www/seahub/files/seahub.in8
4 files changed, 10 insertions, 8 deletions
diff --git a/net-mgmt/seafile-server/Makefile.include b/net-mgmt/seafile-server/Makefile.include
index dfe6b8b6e3b8..f56e33b5656d 100644
--- a/net-mgmt/seafile-server/Makefile.include
+++ b/net-mgmt/seafile-server/Makefile.include
@@ -27,4 +27,5 @@ SUB_LIST+= USERS=${USERS} \
GROUPS=${GROUPS} \
SEAFILE_SERVER=${SEAFILE_SERVER} \
HAIWENDIR=${HAIWENDIR} \
- PYTHON=${PYTHON_VERSION}
+ PYTHON=${PYTHON_VERSION} \
+ PYTHON_VER=${PYTHON_VER}
diff --git a/www/seahub/Makefile b/www/seahub/Makefile
index 1b405f4f0745..3aefc46439fe 100644
--- a/www/seahub/Makefile
+++ b/www/seahub/Makefile
@@ -4,6 +4,7 @@ PORTNAME= seahub
DISTVERSIONPREFIX= v
DISTVERSION= ${SEAHUB_VER}
DISTVERSIONSUFFIX= -pro
+PORTREVISION= 2
CATEGORIES= www
MAINTAINER= ultima@FreeBSD.org
diff --git a/www/seahub/distinfo b/www/seahub/distinfo
index 11e957bdcef5..66b9e1755e05 100644
--- a/www/seahub/distinfo
+++ b/www/seahub/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1552690870
-SHA256 (haiwen-seahub-v6.3.13-pro_GH0.tar.gz) = 189e8a1b73db2ec164ff505e4bb52efe0401f8a01bae415667bedea4ade84e25
-SIZE (haiwen-seahub-v6.3.13-pro_GH0.tar.gz) = 26059355
+TIMESTAMP = 1560056509
+SHA256 (haiwen-seahub-v6.3.13-pro_GH0.tar.gz) = ed5aea17d7b727a094b9702c222842aafd2e7a9fd019469fa7b167df3048c26d
+SIZE (haiwen-seahub-v6.3.13-pro_GH0.tar.gz) = 26060069
diff --git a/www/seahub/files/seahub.in b/www/seahub/files/seahub.in
index 1df1364c272d..50e6bccf3bcd 100644
--- a/www/seahub/files/seahub.in
+++ b/www/seahub/files/seahub.in
@@ -29,7 +29,7 @@
# seafile_logdir (str): Set to "" by default will use the path
# %%PREFIX%%/%%HAIWENDIR%%/logs.
# Set it to a different path.
-# seahub_host (int): Default is 127.0.0.1.
+# seahub_host (int): Default is 0.0.0.0.
# seahub_port (int): Default is 8000.
. /etc/rc.subr
@@ -53,11 +53,11 @@ clearsessions_cmd="seahub_clearsessions"
: ${seafile_conf:="%%PREFIX%%/%%HAIWENDIR%%/conf"}
: ${seafile_datadir:="`cat ${seafile_ccnet}/seafile.ini 2>/dev/null`"}
: ${seafile_logdir:="%%PREFIX%%/%%HAIWENDIR%%/logs"}
-: ${seahub_host:="127.0.0.1"}
+: ${seahub_host:="0.0.0.0"}
: ${seahub_port:="8000"}
manage_py=${seafile_path}/seahub/manage.py
-gunicorn_exe=%%PREFIX%%/bin/gunicorn
+gunicorn_exe=%%PREFIX%%/bin/gunicorn-%%PYTHON_VER%%
gunicorn_conf=${seafile_conf}/gunicorn.conf
pidfile=%%PREFIX%%/%%HAIWENDIR%%/pids/seahub.pid
@@ -123,7 +123,7 @@ seahub_start()
check_required_before;
before_start;
echo "Starting seahub at port ${seahub_port} ..."
- su -m "${seafile_user}" -c "$command \"${gunicorn_exe}\" seahub.wsgi:application -c \"${gunicorn_conf}\" -b \"0.0.0.0:${seahub_port}\" --preload --chdir \"$seafile_path/seahub\""
+ su -m "${seafile_user}" -c "$command \"${gunicorn_exe}\" seahub.wsgi:application -c \"${gunicorn_conf}\" -b \"${seahub_host}:${seahub_port}\" --preload --chdir \"$seafile_path/seahub\""
# Ensure seahub is started successfully
sleep 5