aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-11-06 17:43:11 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-11-06 17:43:11 +0000
commit8fbcab85d9ace37305253f5145e936118101448c (patch)
treecb6e626ffd47af169d8e7698cf5cd88392959be4
parent0e4aaea53687b782547527ccff1586b1ae9e6453 (diff)
downloadports-8fbcab85d9ace37305253f5145e936118101448c.tar.gz
ports-8fbcab85d9ace37305253f5145e936118101448c.zip
Notes
-rw-r--r--Mk/bsd.php.mk6
-rw-r--r--databases/php5-dba/files/patch-config.m433
-rw-r--r--lang/php5-extensions/Makefile3
-rw-r--r--lang/php5/Makefile6
-rw-r--r--lang/php5/Makefile.ext4
-rw-r--r--lang/php5/distinfo12
-rw-r--r--lang/php5/files/patch-ext_standard_dir.c20
-rw-r--r--lang/php5/files/patch-main_main.c11
-rw-r--r--lang/php5/files/patch-main_php_open_temporary_file.c43
-rw-r--r--lang/php53/Makefile6
-rw-r--r--lang/php53/Makefile.ext4
-rw-r--r--lang/php53/distinfo12
-rw-r--r--lang/php53/files/patch-ext_standard_dir.c20
-rw-r--r--lang/php53/files/patch-main_main.c11
-rw-r--r--lang/php53/files/patch-main_php_open_temporary_file.c43
-rw-r--r--net/php5-soap/files/patch-soap.c43
16 files changed, 78 insertions, 199 deletions
diff --git a/Mk/bsd.php.mk b/Mk/bsd.php.mk
index db276baf195e..ce03002852cf 100644
--- a/Mk/bsd.php.mk
+++ b/Mk/bsd.php.mk
@@ -43,7 +43,7 @@ PHP_VER?= ${DEFAULT_PHP_VER}
.if ${PHP_VER} == 4
PHP_EXT_DIR= 20020429
.else
-PHP_EXT_DIR= 20050922
+PHP_EXT_DIR= 20060613
.endif
HTTPD?= ${LOCALBASE}/sbin/httpd
@@ -228,7 +228,7 @@ php-ini:
.if ${USE_PHP:L} != "yes"
# non-version specific components
_USE_PHP_ALL= bcmath bz2 calendar ctype curl dba dbase \
- exif fileinfo filepro fribidi ftp gd gettext gmp \
+ exif fileinfo fribidi ftp gd gettext gmp \
hash iconv imap interbase ldap mbstring mcrypt \
mhash ming mssql mysql ncurses odbc \
openssl panda pcntl pcre pdf pgsql posix \
@@ -236,7 +236,7 @@ _USE_PHP_ALL= bcmath bz2 calendar ctype curl dba dbase \
sockets sybase_ct sysvmsg sysvsem sysvshm \
tokenizer wddx xml xmlrpc yaz zip zlib
# version specific components
-_USE_PHP_VER4= ${_USE_PHP_ALL} crack dbx dio domxml mcal mcve \
+_USE_PHP_VER4= ${_USE_PHP_ALL} crack dbx dio domxml filepro mcal mcve \
mnogosearch oracle overload pfpro xslt yp
_USE_PHP_VER5= ${_USE_PHP_ALL} dom mysqli pdo simplexml soap sqlite \
tidy xmlreader xmlwriter xsl
diff --git a/databases/php5-dba/files/patch-config.m4 b/databases/php5-dba/files/patch-config.m4
index cc37f14f5373..d90ca7178bd1 100644
--- a/databases/php5-dba/files/patch-config.m4
+++ b/databases/php5-dba/files/patch-config.m4
@@ -1,6 +1,6 @@
---- config.m4.orig Mon Aug 22 21:59:36 2005
-+++ config.m4 Thu Sep 8 10:48:31 2005
-@@ -240,6 +240,18 @@
+--- config.m4.orig Mon Aug 7 09:57:12 2006
++++ config.m4 Sat Nov 4 11:18:16 2006
+@@ -244,6 +244,18 @@
THIS_PREFIX=$i
THIS_INCLUDE=$i/db4/db.h
break
@@ -19,3 +19,30 @@
elif test -f "$i/include/db4/db.h"; then
THIS_PREFIX=$i
THIS_INCLUDE=$i/include/db4/db.h
+@@ -493,7 +505,7 @@
+ PHP_DBA_STD_ATTACH
+ fi
+ ],[
+- if test "$PHP_DBA" != "no" && test "$HAVE_DBA" = "1"; then
++ if test "$PHP_DBA" != "no" || test "$HAVE_DBA" = "1"; then
+ PHP_DBA_BUILTIN_CDB
+ fi
+ ])
+@@ -511,7 +523,7 @@
+ PHP_DBA_BUILTIN_INI
+ fi
+ ],[
+- if test "$PHP_DBA" != "no" && test "$HAVE_DBA" = "1"; then
++ if test "$PHP_DBA" != "no" || test "$HAVE_DBA" = "1"; then
+ PHP_DBA_BUILTIN_INI
+ fi
+ ])
+@@ -532,7 +544,7 @@
+ PHP_DBA_BUILTIN_FLATFILE
+ fi
+ ],[
+- if test "$PHP_DBA" != "no" && test "$HAVE_DBA" = "1"; then
++ if test "$PHP_DBA" != "no" || test "$HAVE_DBA" = "1"; then
+ PHP_DBA_BUILTIN_FLATFILE
+ fi
+ ])
diff --git a/lang/php5-extensions/Makefile b/lang/php5-extensions/Makefile
index fada407dc17c..4b9fdfc301fd 100644
--- a/lang/php5-extensions/Makefile
+++ b/lang/php5-extensions/Makefile
@@ -47,7 +47,6 @@ OPTIONS= BCMATH "bc style precision math functions" off \
DOM "DOM support" on \
EXIF "EXIF support" off \
FILEINFO "fileinfo support" off \
- FILEPRO "filePro support" off \
FRIBIDI "FriBidi support" off \
FTP "FTP support" off \
GD "GD library support" off \
@@ -110,7 +109,7 @@ OPTIONSFILE?= ${PORT_DBDIR}/${LATEST_LINK}/options
.endif
ALL_OPTIONS= BCMATH BZ2 CALENDAR CTYPE CURL DBA DBASE \
- DOM EXIF FILEINFO FILEPRO FRIBIDI FTP GD GETTEXT \
+ DOM EXIF FILEINFO FRIBIDI FTP GD GETTEXT \
GMP ICONV IMAP INTERBASE LDAP MBSTRING MCRYPT \
MHASH MIME_MAGIC MING MSSQL MYSQL MYSQLI \
NCURSES ODBC OPENSSL PANDA PCNTL PCRE PDF PDO PGSQL POSIX \
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 7b29ab733548..b5968b0cd653 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= php5
-PORTVERSION= 5.1.6
-PORTREVISION?= 3
+PORTVERSION= 5.2.0
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
http://downloads.php.net/ilia/:rc \
@@ -58,7 +58,7 @@ MAN1= php-config.1 phpize.1
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_SUHOSIN)
-PATCHFILES= suhosin-patch-${PORTVERSION}-0.9.6.patch.gz
+PATCHFILES= suhosin-patch-${PORTVERSION}-0.9.6.1.patch.gz
PATCH_SITES= http://www.hardened-php.net/suhosin/_media/
PATCH_DIST_STRIP= -p1
PLIST_SUB+= SUHOSIN=""
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 41148c443970..cbc91b754f16 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -71,10 +71,6 @@ USE_GNOME= libxml2
CONFIGURE_ARGS+=--enable-exif
.endif
-.if ${PHP_MODNAME} == "filepro"
-CONFIGURE_ARGS+=--enable-filepro
-.endif
-
.if ${PHP_MODNAME} == "ftp"
CONFIGURE_ARGS+=--enable-ftp \
--with-openssl-dir=${OPENSSLBASE}
diff --git a/lang/php5/distinfo b/lang/php5/distinfo
index ed2a21921bdd..58b47d10c447 100644
--- a/lang/php5/distinfo
+++ b/lang/php5/distinfo
@@ -1,6 +1,6 @@
-MD5 (php-5.1.6.tar.bz2) = 08e423aa314369d4392a36b3f7246afc
-SHA256 (php-5.1.6.tar.bz2) = 3e9510ce715f28b7e6b803fcdadb73b37c83792c0b5e1e9bcb066ab972649996
-SIZE (php-5.1.6.tar.bz2) = 6454408
-MD5 (suhosin-patch-5.1.6-0.9.6.patch.gz) = 40533ea76767dacbcc8e67522db8ef50
-SHA256 (suhosin-patch-5.1.6-0.9.6.patch.gz) = 4fb2d60f903e765b182f3f72ac9fdb7f0912d94f5f7fb0b144d18ffdc6188118
-SIZE (suhosin-patch-5.1.6-0.9.6.patch.gz) = 23160
+MD5 (php-5.2.0.tar.bz2) = e6029fafcee029edcfa2ceed7a005333
+SHA256 (php-5.2.0.tar.bz2) = e105b6aad55589aecf20ae70ab7aa81eb202296fc52531f62e546af23077cca1
+SIZE (php-5.2.0.tar.bz2) = 6789838
+MD5 (suhosin-patch-5.2.0-0.9.6.1.patch.gz) = 37af5f50d10b7994a5747b88af3d6a54
+SHA256 (suhosin-patch-5.2.0-0.9.6.1.patch.gz) = fb8be454ad11e5c33dd315b4fc1f8f7a6ab10fb59a021cc1dee1a681f0c6483a
+SIZE (suhosin-patch-5.2.0-0.9.6.1.patch.gz) = 23082
diff --git a/lang/php5/files/patch-ext_standard_dir.c b/lang/php5/files/patch-ext_standard_dir.c
deleted file mode 100644
index 58a6bccb9cfe..000000000000
--- a/lang/php5/files/patch-ext_standard_dir.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- ext/standard/dir.c.orig Mon Oct 16 07:08:36 2006
-+++ ext/standard/dir.c Mon Oct 16 07:08:40 2006
-@@ -16,7 +16,7 @@
- +----------------------------------------------------------------------+
- */
-
--/* $Id: dir.c,v 1.147.2.3 2006/02/26 10:49:50 helly Exp $ */
-+/* $Id: dir.c,v 1.147.2.3.2.1 2006/10/04 23:19:25 iliaa Exp $ */
-
- /* {{{ includes/startup/misc */
-
-@@ -286,7 +286,7 @@
- RETURN_FALSE;
- }
-
-- if (PG(safe_mode) && !php_checkuid(str, NULL, CHECKUID_CHECK_FILE_AND_DIR)) {
-+ if ((PG(safe_mode) && !php_checkuid(str, NULL, CHECKUID_CHECK_FILE_AND_DIR)) || php_check_open_basedir(str TSRMLS_CC)) {
- RETURN_FALSE;
- }
- ret = VCWD_CHDIR(str);
diff --git a/lang/php5/files/patch-main_main.c b/lang/php5/files/patch-main_main.c
deleted file mode 100644
index fdab9447de1d..000000000000
--- a/lang/php5/files/patch-main_main.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- main/main.c.orig Sat Dec 10 09:36:39 2005
-+++ main/main.c Sat Dec 10 09:37:37 2005
-@@ -311,7 +311,7 @@
- PHP_INI_ENTRY("smtp_port", "25", PHP_INI_ALL, NULL)
- PHP_INI_ENTRY("browscap", NULL, PHP_INI_SYSTEM, NULL)
- #if MEMORY_LIMIT
-- PHP_INI_ENTRY("memory_limit", "8M", PHP_INI_ALL, OnChangeMemoryLimit)
-+ PHP_INI_ENTRY("memory_limit", "12M", PHP_INI_ALL, OnChangeMemoryLimit)
- #endif
- PHP_INI_ENTRY("precision", "14", PHP_INI_ALL, OnSetPrecision)
- PHP_INI_ENTRY("sendmail_from", NULL, PHP_INI_ALL, NULL)
diff --git a/lang/php5/files/patch-main_php_open_temporary_file.c b/lang/php5/files/patch-main_php_open_temporary_file.c
deleted file mode 100644
index 85f7c51ab47d..000000000000
--- a/lang/php5/files/patch-main_php_open_temporary_file.c
+++ /dev/null
@@ -1,43 +0,0 @@
---- main/php_open_temporary_file.c.orig Mon Oct 16 07:21:14 2006
-+++ main/php_open_temporary_file.c Mon Oct 16 07:22:00 2006
-@@ -16,7 +16,7 @@
- +----------------------------------------------------------------------+
- */
-
--/* $Id: php_open_temporary_file.c,v 1.34.2.2 2006/05/23 23:22:26 iliaa Exp $ */
-+/* $Id: php_open_temporary_file.c,v 1.34.2.1.2.4 2006/10/13 01:11:30 iliaa Exp $ */
-
- #include "php.h"
-
-@@ -206,6 +206,7 @@
- PHPAPI int php_open_temporary_fd(const char *dir, const char *pfx, char **opened_path_p TSRMLS_DC)
- {
- int fd;
-+ const char *temp_dir;
-
- if (!pfx) {
- pfx = "tmp.";
-@@ -214,11 +215,22 @@
- *opened_path_p = NULL;
- }
-
-+ if (!dir || *dir == '\0') {
-+def_tmp:
-+ temp_dir = php_get_temporary_directory();
-+
-+ if (temp_dir && *temp_dir != '\0' && !php_check_open_basedir(temp_dir TSRMLS_CC)) {
-+ return php_do_open_temporary_file(temp_dir, pfx, opened_path_p TSRMLS_CC);
-+ } else {
-+ return -1;
-+ }
-+ }
-+
- /* Try the directory given as parameter. */
- fd = php_do_open_temporary_file(dir, pfx, opened_path_p TSRMLS_CC);
- if (fd == -1) {
- /* Use default temporary directory. */
-- fd = php_do_open_temporary_file(php_get_temporary_directory(), pfx, opened_path_p TSRMLS_CC);
-+ goto def_tmp;
- }
- return fd;
- }
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 7b29ab733548..b5968b0cd653 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= php5
-PORTVERSION= 5.1.6
-PORTREVISION?= 3
+PORTVERSION= 5.2.0
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
http://downloads.php.net/ilia/:rc \
@@ -58,7 +58,7 @@ MAN1= php-config.1 phpize.1
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_SUHOSIN)
-PATCHFILES= suhosin-patch-${PORTVERSION}-0.9.6.patch.gz
+PATCHFILES= suhosin-patch-${PORTVERSION}-0.9.6.1.patch.gz
PATCH_SITES= http://www.hardened-php.net/suhosin/_media/
PATCH_DIST_STRIP= -p1
PLIST_SUB+= SUHOSIN=""
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 41148c443970..cbc91b754f16 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -71,10 +71,6 @@ USE_GNOME= libxml2
CONFIGURE_ARGS+=--enable-exif
.endif
-.if ${PHP_MODNAME} == "filepro"
-CONFIGURE_ARGS+=--enable-filepro
-.endif
-
.if ${PHP_MODNAME} == "ftp"
CONFIGURE_ARGS+=--enable-ftp \
--with-openssl-dir=${OPENSSLBASE}
diff --git a/lang/php53/distinfo b/lang/php53/distinfo
index ed2a21921bdd..58b47d10c447 100644
--- a/lang/php53/distinfo
+++ b/lang/php53/distinfo
@@ -1,6 +1,6 @@
-MD5 (php-5.1.6.tar.bz2) = 08e423aa314369d4392a36b3f7246afc
-SHA256 (php-5.1.6.tar.bz2) = 3e9510ce715f28b7e6b803fcdadb73b37c83792c0b5e1e9bcb066ab972649996
-SIZE (php-5.1.6.tar.bz2) = 6454408
-MD5 (suhosin-patch-5.1.6-0.9.6.patch.gz) = 40533ea76767dacbcc8e67522db8ef50
-SHA256 (suhosin-patch-5.1.6-0.9.6.patch.gz) = 4fb2d60f903e765b182f3f72ac9fdb7f0912d94f5f7fb0b144d18ffdc6188118
-SIZE (suhosin-patch-5.1.6-0.9.6.patch.gz) = 23160
+MD5 (php-5.2.0.tar.bz2) = e6029fafcee029edcfa2ceed7a005333
+SHA256 (php-5.2.0.tar.bz2) = e105b6aad55589aecf20ae70ab7aa81eb202296fc52531f62e546af23077cca1
+SIZE (php-5.2.0.tar.bz2) = 6789838
+MD5 (suhosin-patch-5.2.0-0.9.6.1.patch.gz) = 37af5f50d10b7994a5747b88af3d6a54
+SHA256 (suhosin-patch-5.2.0-0.9.6.1.patch.gz) = fb8be454ad11e5c33dd315b4fc1f8f7a6ab10fb59a021cc1dee1a681f0c6483a
+SIZE (suhosin-patch-5.2.0-0.9.6.1.patch.gz) = 23082
diff --git a/lang/php53/files/patch-ext_standard_dir.c b/lang/php53/files/patch-ext_standard_dir.c
deleted file mode 100644
index 58a6bccb9cfe..000000000000
--- a/lang/php53/files/patch-ext_standard_dir.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- ext/standard/dir.c.orig Mon Oct 16 07:08:36 2006
-+++ ext/standard/dir.c Mon Oct 16 07:08:40 2006
-@@ -16,7 +16,7 @@
- +----------------------------------------------------------------------+
- */
-
--/* $Id: dir.c,v 1.147.2.3 2006/02/26 10:49:50 helly Exp $ */
-+/* $Id: dir.c,v 1.147.2.3.2.1 2006/10/04 23:19:25 iliaa Exp $ */
-
- /* {{{ includes/startup/misc */
-
-@@ -286,7 +286,7 @@
- RETURN_FALSE;
- }
-
-- if (PG(safe_mode) && !php_checkuid(str, NULL, CHECKUID_CHECK_FILE_AND_DIR)) {
-+ if ((PG(safe_mode) && !php_checkuid(str, NULL, CHECKUID_CHECK_FILE_AND_DIR)) || php_check_open_basedir(str TSRMLS_CC)) {
- RETURN_FALSE;
- }
- ret = VCWD_CHDIR(str);
diff --git a/lang/php53/files/patch-main_main.c b/lang/php53/files/patch-main_main.c
deleted file mode 100644
index fdab9447de1d..000000000000
--- a/lang/php53/files/patch-main_main.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- main/main.c.orig Sat Dec 10 09:36:39 2005
-+++ main/main.c Sat Dec 10 09:37:37 2005
-@@ -311,7 +311,7 @@
- PHP_INI_ENTRY("smtp_port", "25", PHP_INI_ALL, NULL)
- PHP_INI_ENTRY("browscap", NULL, PHP_INI_SYSTEM, NULL)
- #if MEMORY_LIMIT
-- PHP_INI_ENTRY("memory_limit", "8M", PHP_INI_ALL, OnChangeMemoryLimit)
-+ PHP_INI_ENTRY("memory_limit", "12M", PHP_INI_ALL, OnChangeMemoryLimit)
- #endif
- PHP_INI_ENTRY("precision", "14", PHP_INI_ALL, OnSetPrecision)
- PHP_INI_ENTRY("sendmail_from", NULL, PHP_INI_ALL, NULL)
diff --git a/lang/php53/files/patch-main_php_open_temporary_file.c b/lang/php53/files/patch-main_php_open_temporary_file.c
deleted file mode 100644
index 85f7c51ab47d..000000000000
--- a/lang/php53/files/patch-main_php_open_temporary_file.c
+++ /dev/null
@@ -1,43 +0,0 @@
---- main/php_open_temporary_file.c.orig Mon Oct 16 07:21:14 2006
-+++ main/php_open_temporary_file.c Mon Oct 16 07:22:00 2006
-@@ -16,7 +16,7 @@
- +----------------------------------------------------------------------+
- */
-
--/* $Id: php_open_temporary_file.c,v 1.34.2.2 2006/05/23 23:22:26 iliaa Exp $ */
-+/* $Id: php_open_temporary_file.c,v 1.34.2.1.2.4 2006/10/13 01:11:30 iliaa Exp $ */
-
- #include "php.h"
-
-@@ -206,6 +206,7 @@
- PHPAPI int php_open_temporary_fd(const char *dir, const char *pfx, char **opened_path_p TSRMLS_DC)
- {
- int fd;
-+ const char *temp_dir;
-
- if (!pfx) {
- pfx = "tmp.";
-@@ -214,11 +215,22 @@
- *opened_path_p = NULL;
- }
-
-+ if (!dir || *dir == '\0') {
-+def_tmp:
-+ temp_dir = php_get_temporary_directory();
-+
-+ if (temp_dir && *temp_dir != '\0' && !php_check_open_basedir(temp_dir TSRMLS_CC)) {
-+ return php_do_open_temporary_file(temp_dir, pfx, opened_path_p TSRMLS_CC);
-+ } else {
-+ return -1;
-+ }
-+ }
-+
- /* Try the directory given as parameter. */
- fd = php_do_open_temporary_file(dir, pfx, opened_path_p TSRMLS_CC);
- if (fd == -1) {
- /* Use default temporary directory. */
-- fd = php_do_open_temporary_file(php_get_temporary_directory(), pfx, opened_path_p TSRMLS_CC);
-+ goto def_tmp;
- }
- return fd;
- }
diff --git a/net/php5-soap/files/patch-soap.c b/net/php5-soap/files/patch-soap.c
index 8fcdd7ddbc42..70b84d3a60e9 100644
--- a/net/php5-soap/files/patch-soap.c
+++ b/net/php5-soap/files/patch-soap.c
@@ -1,5 +1,5 @@
---- soap.c.orig Fri Mar 24 09:45:54 2006
-+++ soap.c Sat May 6 10:28:32 2006
+--- soap.c.orig Tue Oct 3 21:51:01 2006
++++ soap.c Sat Nov 4 11:38:29 2006
@@ -23,7 +23,7 @@
#include "config.h"
#endif
@@ -9,16 +9,16 @@
#include "ext/session/php_session.h"
#endif
#ifdef ZEND_ENGINE_2
-@@ -1523,7 +1523,7 @@
-
- soap_obj = NULL;
- if (service->type == SOAP_CLASS) {
+@@ -1577,7 +1577,7 @@
+ soap_obj = service->soap_object;
+ function_table = &((Z_OBJCE_P(soap_obj))->function_table);
+ } else if (service->type == SOAP_CLASS) {
-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
+#if HAVE_PHP_SESSION
/* If persistent then set soap_obj from from the previous created session (if available) */
if (service->soap_class.persistance == SOAP_PERSISTENCE_SESSION) {
zval **tmp_soap;
-@@ -1610,7 +1610,7 @@
+@@ -1664,7 +1664,7 @@
}
efree(class_name);
}
@@ -27,21 +27,30 @@
/* If session then update session hash with new object */
if (service->soap_class.persistance == SOAP_PERSISTENCE_SESSION) {
zval **tmp_soap_pp;
-@@ -1706,7 +1706,7 @@
- zend_hash_exists(function_table, ZEND_CALL_FUNC_NAME, sizeof(ZEND_CALL_FUNC_NAME)))) {
- if (service->type == SOAP_CLASS) {
+@@ -1762,7 +1762,7 @@
+ if (service->type == SOAP_CLASS || service->type == SOAP_OBJECT) {
call_status = call_user_function(NULL, &soap_obj, &function_name, &retval, num_params, params TSRMLS_CC);
+ if (service->type == SOAP_CLASS) {
-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
+#if HAVE_PHP_SESSION
- if (service->soap_class.persistance != SOAP_PERSISTENCE_SESSION) {
- zval_ptr_dtor(&soap_obj);
- }
-@@ -1728,7 +1728,7 @@
- instanceof_function(Z_OBJCE_P(EG(exception)), soap_fault_class_entry TSRMLS_CC)) {
+ if (service->soap_class.persistance != SOAP_PERSISTENCE_SESSION) {
+ zval_ptr_dtor(&soap_obj);
+ soap_obj = NULL;
+@@ -1788,7 +1788,7 @@
soap_server_fault_ex(function, EG(exception), NULL TSRMLS_CC);
}
+ if (service->type == SOAP_CLASS) {
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ if (soap_obj && service->soap_class.persistance != SOAP_PERSISTENCE_SESSION) {
+ #else
+ if (soap_obj) {
+@@ -1830,7 +1830,7 @@
+ soap_server_fault_ex(function, EG(exception), NULL TSRMLS_CC);
+ }
+ if (service->type == SOAP_CLASS) {
-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
+#if HAVE_PHP_SESSION
- if (soap_obj && service->soap_class.persistance != SOAP_PERSISTENCE_SESSION) {
+ if (soap_obj && service->soap_class.persistance != SOAP_PERSISTENCE_SESSION) {
#else
- if (soap_obj) {
+ if (soap_obj) {