aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2018-10-20 11:33:29 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2018-10-20 11:33:29 +0000
commit9b238fe9cd99162374fd80d76d0fd10b13aea53b (patch)
tree1221e1769c7cab3b81a0460b48ddbe865063c2e0
parentcff152c810596d52fffed6a73cf13c61df5be6a1 (diff)
downloadports-9b238fe9cd99162374fd80d76d0fd10b13aea53b.tar.gz
ports-9b238fe9cd99162374fd80d76d0fd10b13aea53b.zip
Notes
-rw-r--r--www/suphp/Makefile8
-rw-r--r--www/suphp/files/patch-configure.ac6
-rw-r--r--www/suphp/files/patch-doc_suphp.conf-example (renamed from www/suphp/files/patch-doc__suphp.conf-example)6
-rw-r--r--www/suphp/files/patch-src_SmartPtr.hpp6
-rw-r--r--www/suphp/pkg-plist4
5 files changed, 15 insertions, 15 deletions
diff --git a/www/suphp/Makefile b/www/suphp/Makefile
index 1f0e182c9330..350b4f61e7bb 100644
--- a/www/suphp/Makefile
+++ b/www/suphp/Makefile
@@ -8,12 +8,15 @@ CATEGORIES= www
MASTER_SITES= http://www.suphp.org/download/ \
LOCAL/bdrewery/${PORTNAME}/ \
http://mirror.shatow.net/freebsd/${PORTNAME}/
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
-MAINTAINER= bdrewery@FreeBSD.org
+MAINTAINER= freebsd-ports@dan.me.uk
COMMENT= Securely execute PHP scripts under Apache
+LICENSE= GPLv2
+
GNU_CONFIGURE= yes
-USES= apache:2.2+ autoreconf libtool php:cgi
+USES= apache:2.2+ autoreconf libtool php:cgi,flavors
SUB_FILES= pkg-message
CFLAGS+= -I${LOCALBASE}/include
@@ -45,6 +48,7 @@ CONFIGURE_ARGS+= --with-apr=${LOCALBASE}
post-install:
.if !defined(WITH_DEBUG)
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/suphp
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/mod_suphp.so
.endif
${INSTALL_DATA} ${WRKSRC}/doc/suphp.conf-example \
${STAGEDIR}${PREFIX}/etc/suphp.conf-example
diff --git a/www/suphp/files/patch-configure.ac b/www/suphp/files/patch-configure.ac
index fd901e09bd2e..49930cd18541 100644
--- a/www/suphp/files/patch-configure.ac
+++ b/www/suphp/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac.orig 2014-08-31 10:39:02.982846403 +0100
-+++ configure.ac 2014-08-31 10:39:31.763844267 +0100
-@@ -15343,7 +15343,7 @@
+--- configure.ac.orig 2013-05-20 16:26:56 UTC
++++ configure.ac
+@@ -66,7 +66,7 @@ if test -n "$APXS"; then
| cut -f2 -d"/" \
| cut -f1 -d" "`
major_version=`echo $APACHE_VERSION|cut -f1,2 -d.`
diff --git a/www/suphp/files/patch-doc__suphp.conf-example b/www/suphp/files/patch-doc_suphp.conf-example
index d359454dc109..5fdbf4a43ec3 100644
--- a/www/suphp/files/patch-doc__suphp.conf-example
+++ b/www/suphp/files/patch-doc_suphp.conf-example
@@ -1,6 +1,6 @@
---- doc/suphp.conf-example.orig
+--- doc/suphp.conf-example.orig 2011-03-13 17:52:24 UTC
+++ doc/suphp.conf-example
-@@ -6,10 +6,10 @@
+@@ -6,10 +6,10 @@ logfile=/var/log/suphp.log
loglevel=info
;User Apache is running as
@@ -13,7 +13,7 @@
;Path to chroot() to before executing script
;chroot=/mychroot
-@@ -33,15 +33,15 @@
+@@ -33,15 +33,15 @@ env_path="/bin:/usr/bin"
umask=0077
; Minimum UID
diff --git a/www/suphp/files/patch-src_SmartPtr.hpp b/www/suphp/files/patch-src_SmartPtr.hpp
index ce0bae544f89..bf4d310e853d 100644
--- a/www/suphp/files/patch-src_SmartPtr.hpp
+++ b/www/suphp/files/patch-src_SmartPtr.hpp
@@ -1,8 +1,4 @@
-$NetBSD: patch-src_SmartPtr.hpp,v 1.1 2011/09/21 12:54:16 adam Exp $
-
-Fix C++ syntax
-
---- src/SmartPtr.hpp.orig 2011-09-21 12:48:02.000000000 +0000
+--- src/SmartPtr.hpp.orig 2007-03-13 14:17:02 UTC
+++ src/SmartPtr.hpp
@@ -150,7 +150,7 @@ namespace suPHP {
template<class T>
diff --git a/www/suphp/pkg-plist b/www/suphp/pkg-plist
index ff713b64c4f6..eb436216d8de 100644
--- a/www/suphp/pkg-plist
+++ b/www/suphp/pkg-plist
@@ -1,8 +1,8 @@
sbin/suphp
etc/suphp.conf-example
%%APACHEMODDIR%%/mod_suphp.so
-@exec %D/sbin/apxs -e -a -n suphp %D/%f
-@unexec %D/sbin/apxs -e -A -n suphp %D/%f
+@postexec %D/sbin/apxs -e -a -n suphp %D/%f
+@preunexec %D/sbin/apxs -e -A -n suphp %D/%f
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/README