aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2004-11-25 14:40:47 +0000
committerHerve Quiroz <hq@FreeBSD.org>2004-11-25 14:40:47 +0000
commitaee7cdc684dfa60d548c01cd81994ce5c90684d8 (patch)
tree9e8ad34fdcae8e33c147943a03360fbef4165273
parent74bd1b92daa2ff081af81029fa10b9108313c40e (diff)
downloadports-aee7cdc684dfa60d548c01cd81994ce5c90684d8.tar.gz
ports-aee7cdc684dfa60d548c01cd81994ce5c90684d8.zip
Notes
-rw-r--r--textproc/xmlenc/Makefile37
-rw-r--r--textproc/xmlenc/distinfo4
-rw-r--r--textproc/xmlenc/pkg-plist54
3 files changed, 18 insertions, 77 deletions
diff --git a/textproc/xmlenc/Makefile b/textproc/xmlenc/Makefile
index 560f670acbea..852e25b8f45f 100644
--- a/textproc/xmlenc/Makefile
+++ b/textproc/xmlenc/Makefile
@@ -6,42 +6,37 @@
#
PORTNAME= xmlenc
-PORTVERSION= 0.43
+PORTVERSION= 0.44
CATEGORIES= textproc java
MASTER_SITES= http://${PORTNAME}.sourceforge.net/
MAINTAINER= znerd@FreeBSD.org
COMMENT= Light-weight XML encoding library for Java
-BUILD_DEPENDS= ${ANT}:${PORTSDIR}/devel/apache-ant
+USE_JAVA= yes
+USE_ANT= yes
-USE_JAVA= 1.1+
-
-PLIST_SUB+= T=${TARGET_DIR:S/^${PREFIX}\///}
-TARGET_DIR?= ${PREFIX}/share/java/${PORTNAME}-${PORTVERSION}
-ANT?= ${LOCALBASE}/bin/ant
.if defined(NOPORTDOCS)
-ANT_TARGET= jar
+ALL_TARGET= jar
.else
-ANT_TARGET= jar javadoc
+ALL_TARGET= jar javadoc
+PORTDOCS= *
.endif
-JAVASHAREDIR= ${PREFIX}/share/java
-JARDIR= ${JAVASHAREDIR}/classes
JARFILE= ${PORTNAME}.jar
-
-do-build:
- @cd ${WRKSRC} && ${ANT} ${ANT_TARGET}
+PLIST_FILES= %%JAVAJARDIR%%/${JARFILE}
do-install:
- @${ECHO} -n ">> Installing JAR as ${JARDIR}/${JARFILE}..."
- @${CP} ${WRKSRC}/build/${JARFILE} ${JARDIR}/
- @${ECHO} " [ DONE ]"
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${JARFILE}..."
+ @${MKDIR} ${JAVAJARDIR}
+ @${INSTALL_DATA} ${WRKSRC}/build/${JARFILE} ${JAVAJARDIR}/
+ @${ECHO_MSG} " [ DONE ]"
.if !defined(NOPORTDOCS)
- @${ECHO} -n ">> Installing documentation in ${DOCSDIR}..."
- @${MKDIR} ${DOCSDIR}
- @${CP} -r ${WRKSRC}/build/javadoc/* ${DOCSDIR}
- @${ECHO} " [ DONE ]"
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}/..."
+ @cd ${WRKSRC}/build/javadoc/ \
+ && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ @${ECHO_MSG} " [ DONE ]"
.endif
.include <bsd.port.mk>
diff --git a/textproc/xmlenc/distinfo b/textproc/xmlenc/distinfo
index be0c421fb380..80db15a4eacd 100644
--- a/textproc/xmlenc/distinfo
+++ b/textproc/xmlenc/distinfo
@@ -1,2 +1,2 @@
-MD5 (xmlenc-0.43.tar.gz) = 5a63c3b656f0a385f2caef2546568e5d
-SIZE (xmlenc-0.43.tar.gz) = 92522
+MD5 (xmlenc-0.44.tar.gz) = 93679b7712c05dc7074e1d424be5f277
+SIZE (xmlenc-0.44.tar.gz) = 92607
diff --git a/textproc/xmlenc/pkg-plist b/textproc/xmlenc/pkg-plist
deleted file mode 100644
index 86ab8e7a897e..000000000000
--- a/textproc/xmlenc/pkg-plist
+++ /dev/null
@@ -1,54 +0,0 @@
-share/doc/xmlenc/org/znerd/xmlenc/sax/class-use/SAXEventReceiver.html
-share/doc/xmlenc/org/znerd/xmlenc/sax/SAXEventReceiver.html
-share/doc/xmlenc/org/znerd/xmlenc/sax/package-frame.html
-share/doc/xmlenc/org/znerd/xmlenc/sax/package-summary.html
-share/doc/xmlenc/org/znerd/xmlenc/sax/package-tree.html
-share/doc/xmlenc/org/znerd/xmlenc/sax/package-use.html
-share/doc/xmlenc/org/znerd/xmlenc/class-use/XMLOutputter.html
-share/doc/xmlenc/org/znerd/xmlenc/class-use/Library.html
-share/doc/xmlenc/org/znerd/xmlenc/class-use/LineBreak.html
-share/doc/xmlenc/org/znerd/xmlenc/class-use/StatefulXMLEventListener.html
-share/doc/xmlenc/org/znerd/xmlenc/class-use/XMLChecker.html
-share/doc/xmlenc/org/znerd/xmlenc/class-use/XMLEncoder.html
-share/doc/xmlenc/org/znerd/xmlenc/class-use/XMLEventListener.html
-share/doc/xmlenc/org/znerd/xmlenc/class-use/XMLEventListenerState.html
-share/doc/xmlenc/org/znerd/xmlenc/class-use/XMLEventListenerStates.html
-share/doc/xmlenc/org/znerd/xmlenc/class-use/InvalidXMLException.html
-share/doc/xmlenc/org/znerd/xmlenc/Library.html
-share/doc/xmlenc/org/znerd/xmlenc/LineBreak.html
-share/doc/xmlenc/org/znerd/xmlenc/StatefulXMLEventListener.html
-share/doc/xmlenc/org/znerd/xmlenc/XMLChecker.html
-share/doc/xmlenc/org/znerd/xmlenc/XMLEncoder.html
-share/doc/xmlenc/org/znerd/xmlenc/XMLEventListener.html
-share/doc/xmlenc/org/znerd/xmlenc/XMLEventListenerState.html
-share/doc/xmlenc/org/znerd/xmlenc/XMLEventListenerStates.html
-share/doc/xmlenc/org/znerd/xmlenc/XMLOutputter.html
-share/doc/xmlenc/org/znerd/xmlenc/package-frame.html
-share/doc/xmlenc/org/znerd/xmlenc/package-summary.html
-share/doc/xmlenc/org/znerd/xmlenc/package-tree.html
-share/doc/xmlenc/org/znerd/xmlenc/package-use.html
-share/doc/xmlenc/org/znerd/xmlenc/InvalidXMLException.html
-share/doc/xmlenc/resources/inherit.gif
-share/doc/xmlenc/packages.html
-share/doc/xmlenc/package-list
-share/doc/xmlenc/overview-tree.html
-share/doc/xmlenc/overview-summary.html
-share/doc/xmlenc/overview-frame.html
-share/doc/xmlenc/index.html
-share/doc/xmlenc/index-all.html
-share/doc/xmlenc/help-doc.html
-share/doc/xmlenc/deprecated-list.html
-share/doc/xmlenc/constant-values.html
-share/doc/xmlenc/allclasses-noframe.html
-share/doc/xmlenc/stylesheet.css
-share/doc/xmlenc/allclasses-frame.html
-share/doc/xmlenc/serialized-form.html
-share/java/classes/xmlenc.jar
-@dirrm share/doc/xmlenc/org/znerd/xmlenc/sax/class-use
-@dirrm share/doc/xmlenc/org/znerd/xmlenc/sax
-@dirrm share/doc/xmlenc/org/znerd/xmlenc/class-use
-@dirrm share/doc/xmlenc/org/znerd/xmlenc
-@dirrm share/doc/xmlenc/org/znerd
-@dirrm share/doc/xmlenc/org
-@dirrm share/doc/xmlenc/resources
-@dirrm share/doc/xmlenc