aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-06-10 00:27:04 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-06-10 00:27:04 +0000
commitcf3a68e7ee5386f27fb5400a415dd80965fe517f (patch)
treed21570790748a82f2100c9083d7c694d70df2236
parenta6cae37a4ae2a606f3f25263dc790c91f0757f7c (diff)
downloadports-cf3a68e7ee5386f27fb5400a415dd80965fe517f.tar.gz
ports-cf3a68e7ee5386f27fb5400a415dd80965fe517f.zip
MFH: r503861
www/firefox: switch to rc2 Changes: https://hg.mozilla.org/releases/mozilla-release/pushloghtml?startdate=2019-06-07&enddate=2019-06-09 PR: 236651 Approved by: ports-secteam blanket
Notes
Notes: svn path=/branches/2019Q2/; revision=503864
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/distinfo6
-rw-r--r--www/firefox/files/patch-bug155474430
3 files changed, 4 insertions, 34 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index f833ca2bdaf5..b9873a2662e8 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -6,7 +6,7 @@ DISTVERSION= 67.0.2
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
- MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
+ MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build2/source
DISTFILES= ${DISTNAME}.source${EXTRACT_SUFX}
MAINTAINER= gecko@FreeBSD.org
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index ab94461a419c..504753271e54 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1559821319
-SHA256 (firefox-67.0.2.source.tar.xz) = 059de341d3c988e8a9b8c41a953307225fcce225d156bb35d907bf9fb0393a64
-SIZE (firefox-67.0.2.source.tar.xz) = 282906788
+TIMESTAMP = 1560068206
+SHA256 (firefox-67.0.2.source.tar.xz) = 6a0dd9a838c9532b143bb0322f73d03afd272f6afba92af5be5845061f0deb47
+SIZE (firefox-67.0.2.source.tar.xz) = 283090748
diff --git a/www/firefox/files/patch-bug1554744 b/www/firefox/files/patch-bug1554744
deleted file mode 100644
index 17ba5460ca39..000000000000
--- a/www/firefox/files/patch-bug1554744
+++ /dev/null
@@ -1,30 +0,0 @@
-commit f8d21e08c1e4
-Author: Gijs Kruitbosch <gijskruitbosch@gmail.com>
-Date: Fri May 31 13:55:56 2019 +0000
-
- Bug 1554744 - make button state in browser language dialog correct when there's no available languages, r=johannh
-
- Differential Revision: https://phabricator.services.mozilla.com/D33273
-
- --HG--
- extra : moz-landing-system : lando
----
- browser/components/preferences/browserLanguages.js | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git browser/components/preferences/browserLanguages.js browser/components/preferences/browserLanguages.js
-index f8bae44b52c9..4c39f55fdafd 100644
---- browser/components/preferences/browserLanguages.js
-+++ browser/components/preferences/browserLanguages.js
-@@ -78,9 +78,9 @@ class OrderedListBox {
- setButtonState() {
- let {upButton, downButton, removeButton} = this;
- let {selectedIndex, itemCount} = this.richlistbox;
-- upButton.disabled = selectedIndex == 0;
-+ upButton.disabled = selectedIndex <= 0;
- downButton.disabled = selectedIndex == itemCount - 1;
-- removeButton.disabled = itemCount == 1 || !this.selectedItem.canRemove;
-+ removeButton.disabled = itemCount <= 1 || !this.selectedItem.canRemove;
- }
-
- moveUp() {