aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2019-06-30 14:44:14 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2019-06-30 14:44:14 +0000
commitd8c722c41aaafc9addeca244e871d9feaf2cfd12 (patch)
tree461aa7f37a5b2046a8987e8edac96036396310e5
parent2cdb6801fbcc60e38186f9aad99df6f703e8e01d (diff)
downloadports-d8c722c41aaafc9addeca244e871d9feaf2cfd12.tar.gz
ports-d8c722c41aaafc9addeca244e871d9feaf2cfd12.zip
MFH r502589:
www/h2o*: Remove nop CMAKE_VERBOSE MFH r505423: h2o{,-devel}: Improve rc.d/h2o, freshen h2o.conf rc.d/h2o: - Add a configtest target - Fix a bug that could prevent the script from locating the PIDfile path h2o.conf: - Remove entries that are defaults PR: 238888 Approved by: maintainer (dch) Approved by: portmgr (with hat)
Notes
Notes: svn path=/branches/2019Q2/; revision=505424
-rw-r--r--www/h2o-devel/Makefile3
-rw-r--r--www/h2o-devel/files/h2o.conf.sample.in7
-rw-r--r--www/h2o-devel/files/h2o.in10
-rw-r--r--www/h2o/Makefile3
-rw-r--r--www/h2o/files/h2o.conf.sample.in7
-rw-r--r--www/h2o/files/h2o.in10
6 files changed, 16 insertions, 24 deletions
diff --git a/www/h2o-devel/Makefile b/www/h2o-devel/Makefile
index 943f4b715504..b1ad91284477 100644
--- a/www/h2o-devel/Makefile
+++ b/www/h2o-devel/Makefile
@@ -4,7 +4,7 @@
PORTNAME= h2o
DISTVERSIONPREFIX= v
DISTVERSION= 2.3.0-beta1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
PKGNAMESUFFIX= -devel
@@ -54,7 +54,6 @@ OPTIONS_SUB= yes
MRUBY_DESC= Build with embedded mruby handler support
CMAKE_ARGS+= -DBUILD_SHARED_LIBS=ON -DWITH_BUNDLED_SSL=OFF
-CMAKE_VERBOSE= yes
MRUBY_CMAKE_BOOL= WITH_MRUBY
MRUBY_USES= bison
diff --git a/www/h2o-devel/files/h2o.conf.sample.in b/www/h2o-devel/files/h2o.conf.sample.in
index c434dc498264..d8d61f6de9e4 100644
--- a/www/h2o-devel/files/h2o.conf.sample.in
+++ b/www/h2o-devel/files/h2o.conf.sample.in
@@ -39,20 +39,13 @@ header.add: "Content-Security-Policy: default-src https:"
# 6 months HSTS pinning
header.add: "Strict-Transport-Security: max-age=16000000"
-# no patience for slow users
-http1-request-timeout: 10
-http2-idle-timeout: 10
# limit POST bodies
limit-request-body: 10485760 # 10MiB
-max-connections: 1024
file.mime.addtypes:
- image/svg+xml: .svg
text/plain: .log
text/css: .css
application/atom+xml: .xml
- application/zip: .zip
- application/json: .json
"text/html; charset=utf-8": .html
# per-host configurations
diff --git a/www/h2o-devel/files/h2o.in b/www/h2o-devel/files/h2o.in
index 1e9bc0661287..bf52d7c610f2 100644
--- a/www/h2o-devel/files/h2o.in
+++ b/www/h2o-devel/files/h2o.in
@@ -24,19 +24,23 @@ desc="An HTTP/2 high-performance webserver"
load_rc_config $name
+extra_commands="configtest reload"
+configtest_cmd="h2o_configtest"
+
# defaults
: ${h2o_enable:=NO}
: ${h2o_config:=%%PREFIX%%/etc/${name}/${name}.conf}
: ${h2o_perl:=%%LOCALBASE%%/bin/perl}
# daemon
-pidfile=`grep pid-file ${h2o_config} | cut -d' ' -f2`
+pidfile=`grep pid-file ${h2o_config} | awk '{print $2}'`
h2o_env="H2O_PERL=${h2o_perl}"
command="%%PREFIX%%/bin/${name}"
command_args="-m daemon -c ${h2o_config}"
procname="%%LOCALBASE%%/bin/perl"
-# support SIGHUP to reload configuration file
-extra_commands=reload
+h2o_configtest() {
+ "${command}" -c "${h2o_config}" -t
+}
run_rc_command "$1"
diff --git a/www/h2o/Makefile b/www/h2o/Makefile
index 49d4fadc65a3..29c23535a4bd 100644
--- a/www/h2o/Makefile
+++ b/www/h2o/Makefile
@@ -4,7 +4,7 @@
PORTNAME= h2o
DISTVERSIONPREFIX= v
DISTVERSION= 2.2.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MAINTAINER= dch@FreeBSD.org
@@ -54,7 +54,6 @@ OPTIONS_SUB= yes
MRUBY_DESC= Build with embedded mruby handler support
CMAKE_ARGS+= -DBUILD_SHARED_LIBS=ON -DWITH_BUNDLED_SSL=OFF
-CMAKE_VERBOSE= yes
MRUBY_CMAKE_BOOL= WITH_MRUBY
MRUBY_USES= bison
diff --git a/www/h2o/files/h2o.conf.sample.in b/www/h2o/files/h2o.conf.sample.in
index c434dc498264..d8d61f6de9e4 100644
--- a/www/h2o/files/h2o.conf.sample.in
+++ b/www/h2o/files/h2o.conf.sample.in
@@ -39,20 +39,13 @@ header.add: "Content-Security-Policy: default-src https:"
# 6 months HSTS pinning
header.add: "Strict-Transport-Security: max-age=16000000"
-# no patience for slow users
-http1-request-timeout: 10
-http2-idle-timeout: 10
# limit POST bodies
limit-request-body: 10485760 # 10MiB
-max-connections: 1024
file.mime.addtypes:
- image/svg+xml: .svg
text/plain: .log
text/css: .css
application/atom+xml: .xml
- application/zip: .zip
- application/json: .json
"text/html; charset=utf-8": .html
# per-host configurations
diff --git a/www/h2o/files/h2o.in b/www/h2o/files/h2o.in
index 1e9bc0661287..bf52d7c610f2 100644
--- a/www/h2o/files/h2o.in
+++ b/www/h2o/files/h2o.in
@@ -24,19 +24,23 @@ desc="An HTTP/2 high-performance webserver"
load_rc_config $name
+extra_commands="configtest reload"
+configtest_cmd="h2o_configtest"
+
# defaults
: ${h2o_enable:=NO}
: ${h2o_config:=%%PREFIX%%/etc/${name}/${name}.conf}
: ${h2o_perl:=%%LOCALBASE%%/bin/perl}
# daemon
-pidfile=`grep pid-file ${h2o_config} | cut -d' ' -f2`
+pidfile=`grep pid-file ${h2o_config} | awk '{print $2}'`
h2o_env="H2O_PERL=${h2o_perl}"
command="%%PREFIX%%/bin/${name}"
command_args="-m daemon -c ${h2o_config}"
procname="%%LOCALBASE%%/bin/perl"
-# support SIGHUP to reload configuration file
-extra_commands=reload
+h2o_configtest() {
+ "${command}" -c "${h2o_config}" -t
+}
run_rc_command "$1"