aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-11 10:03:33 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-11 10:03:33 +0000
commit037281d66e93469b2b0f6e355259f29176cd1f54 (patch)
treee7cdf38c8b6231db3a96703e7fdb501c53353f8d
parentc36c607e27a4de025f61c1b99b594cbae1cab37e (diff)
downloadports-037281d66e93469b2b0f6e355259f29176cd1f54.tar.gz
ports-037281d66e93469b2b0f6e355259f29176cd1f54.zip
Notes
-rw-r--r--editors/nano/Makefile9
-rw-r--r--editors/nano/pkg-plist48
-rw-r--r--editors/zoinks/Makefile9
-rw-r--r--editors/zoinks/pkg-plist2
4 files changed, 41 insertions, 27 deletions
diff --git a/editors/nano/Makefile b/editors/nano/Makefile
index 0bd27dbbbdc3..6e3155cd0eba 100644
--- a/editors/nano/Makefile
+++ b/editors/nano/Makefile
@@ -18,9 +18,16 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-all
-USE_GETTEXT= yes
USE_REINPLACE= yes
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
INFO= nano
MAN1= nano.1
MAN5= nanorc.5
diff --git a/editors/nano/pkg-plist b/editors/nano/pkg-plist
index 0e3bb09433ee..c0c9948a0878 100644
--- a/editors/nano/pkg-plist
+++ b/editors/nano/pkg-plist
@@ -1,28 +1,28 @@
@comment $FreeBSD$
bin/nano
-share/locale/ca/LC_MESSAGES/nano.mo
-share/locale/cs/LC_MESSAGES/nano.mo
-share/locale/da/LC_MESSAGES/nano.mo
-share/locale/de/LC_MESSAGES/nano.mo
-share/locale/es/LC_MESSAGES/nano.mo
-share/locale/eu/LC_MESSAGES/nano.mo
-share/locale/fi/LC_MESSAGES/nano.mo
-share/locale/fr/LC_MESSAGES/nano.mo
-share/locale/gl/LC_MESSAGES/nano.mo
-share/locale/hu/LC_MESSAGES/nano.mo
-share/locale/id/LC_MESSAGES/nano.mo
-share/locale/it/LC_MESSAGES/nano.mo
-share/locale/ms/LC_MESSAGES/nano.mo
-share/locale/nb/LC_MESSAGES/nano.mo
-share/locale/nl/LC_MESSAGES/nano.mo
-share/locale/nn/LC_MESSAGES/nano.mo
-share/locale/pl/LC_MESSAGES/nano.mo
-share/locale/pt_BR/LC_MESSAGES/nano.mo
-share/locale/ro/LC_MESSAGES/nano.mo
-share/locale/ru/LC_MESSAGES/nano.mo
-share/locale/sr/LC_MESSAGES/nano.mo
-share/locale/sv/LC_MESSAGES/nano.mo
-share/locale/tr/LC_MESSAGES/nano.mo
-share/locale/uk/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/da/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/de/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/es/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/id/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/it/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/nano.mo
%%EXAMPLESDIR%%/nanorc.sample
@dirrm %%EXAMPLESDIR%%
diff --git a/editors/zoinks/Makefile b/editors/zoinks/Makefile
index 3491373ecbc2..187efd105d68 100644
--- a/editors/zoinks/Makefile
+++ b/editors/zoinks/Makefile
@@ -15,7 +15,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= mike@mikelockwood.com
COMMENT= An X11 programmer's editor and development environment
-USE_GETTEXT= yes
.if defined(WITH_IMLIB)
USE_GNOME= imlib
CONFIGURE_ARGS+= --enable-imlib
@@ -23,6 +22,14 @@ CONFIGURE_ARGS+= --enable-imlib
CONFIGURE_ARGS+= --disable-imlib
.endif
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
USE_XPM= yes
GNU_CONFIGURE= yes
diff --git a/editors/zoinks/pkg-plist b/editors/zoinks/pkg-plist
index 00e5a5dcdf19..07f2c04e3eff 100644
--- a/editors/zoinks/pkg-plist
+++ b/editors/zoinks/pkg-plist
@@ -1,2 +1,2 @@
bin/zoinks
-share/locale/ja/LC_MESSAGES/zoinks.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/zoinks.mo