aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-28 17:22:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-28 17:22:50 +0000
commit17b366381b24f03fa11e84fe6d6b1ce4f97b06ee (patch)
tree8076909677ee99003f4285e0fd33b2148f89009c
parent95f60e53b11e95b1f2be8de43678b8c366f3d321 (diff)
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/vnstati/Makefile48
-rw-r--r--net/vnstati/distinfo3
-rw-r--r--net/vnstati/pkg-descr10
4 files changed, 62 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 7765ed0587d1..945996f77295 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1005,6 +1005,7 @@
SUBDIR += vnc2swf
SUBDIR += vncreflector
SUBDIR += vnstat
+ SUBDIR += vnstati
SUBDIR += vomit
SUBDIR += vserver
SUBDIR += vtun
diff --git a/net/vnstati/Makefile b/net/vnstati/Makefile
new file mode 100644
index 000000000000..a69b3f037fad
--- /dev/null
+++ b/net/vnstati/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: vnstati
+# Date created: 28 Dez 2008
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vnstati
+DISTVERSION= beta3
+CATEGORIES= net
+MASTER_SITES= http://humdi.net/vnstat/ \
+ http://mirror.mcx2.org/
+
+MAINTAINER= adox@mcx2.org
+COMMENT= PNG image output support for vnStat
+
+LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
+RUN_DEPENDS+= vnstat:${PORTSDIR}/net/vnstat
+
+ALL_TARGET= vnstati
+MAKE_ARGS= LIBRARY_PATH="${PREFIX}/lib" \
+ CPATH="${PREFIX}/include"
+
+USE_GMAKE= yes
+MAN1= vnstati.1
+MANCOMPRESSED= yes
+
+PLIST_FILES= bin/${PORTNAME}
+
+PORTDOCS= README
+PORTEXAMPLES= vnstat.cgi
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(DESTDIR)/usr/bin|$${PREFIX}/bin|g' \
+ -e 's|$$(DESTDIR)/usr/share/man|$${PREFIX}/man|g' ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+.endif
+
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/examples/vnstat.cgi ${EXAMPLESDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/vnstati/distinfo b/net/vnstati/distinfo
new file mode 100644
index 000000000000..a6cbf291e605
--- /dev/null
+++ b/net/vnstati/distinfo
@@ -0,0 +1,3 @@
+MD5 (vnstati-beta3.tar.gz) = 5652b955e16716cec48da464b083c76f
+SHA256 (vnstati-beta3.tar.gz) = 16a02930df0ab7eab44f1d63b655a64b63a7dee5ef70201fad395afcfafbf3a3
+SIZE (vnstati-beta3.tar.gz) = 31695
diff --git a/net/vnstati/pkg-descr b/net/vnstati/pkg-descr
new file mode 100644
index 000000000000..07a300602342
--- /dev/null
+++ b/net/vnstati/pkg-descr
@@ -0,0 +1,10 @@
+The purpose of vnstati is to provide image output support for
+statistics collected using vnstat(1). However, the image file
+format is limited to png. All basic outputs of vnStat are
+supported excluding live traffic features. The image can be
+outputted either to a file or to standard output.
+
+vnstati is the image output command for vnstat(1). It provides
+png image file output from database files created using vnStat.
+
+WWW: http://humdi.net/vnstat/