aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-14 16:51:04 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-14 16:51:04 +0000
commit1ab48ca1a142b8f88acead0cba2d105f27a09e3c (patch)
treeaf78f98266471bb736540e2c596b85b9a2666f42
parent9512476be47682f14d8db0c407c00df09a5343ae (diff)
downloadports-1ab48ca1a142b8f88acead0cba2d105f27a09e3c.tar.gz
ports-1ab48ca1a142b8f88acead0cba2d105f27a09e3c.zip
Notes
-rw-r--r--databases/gigabase/Makefile16
-rw-r--r--databases/gigabase/distinfo6
-rw-r--r--databases/gigabase/files/patch-Makefile.in24
-rw-r--r--databases/gigabase/files/patch-configure10
-rw-r--r--databases/gigabase/pkg-plist1
5 files changed, 35 insertions, 22 deletions
diff --git a/databases/gigabase/Makefile b/databases/gigabase/Makefile
index 1db23a7abf5a..b7b0234f7115 100644
--- a/databases/gigabase/Makefile
+++ b/databases/gigabase/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gigabase
-PORTVERSION= 3.58
+PORTVERSION= 3.61
CATEGORIES= databases
MASTER_SITES= SF
@@ -15,12 +15,18 @@ COMMENT= Object-Relational Database Management System
WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GNOME= gnometarget
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS?=--prefix=${LOCALBASE}
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
USE_LDCONFIG= yes
-USE_GETTEXT= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${OSVERSION} < 601103
+ @${REINPLACE_CMD} -e \
+ '/GETHOSTBYNAME_R/s|^#define|// #define|g' ${WRKSRC}/config.h
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/gigabase/distinfo b/databases/gigabase/distinfo
index b22aa2777eea..d5550177c785 100644
--- a/databases/gigabase/distinfo
+++ b/databases/gigabase/distinfo
@@ -1,3 +1,3 @@
-MD5 (gigabase-3.58.tar.gz) = ccc5218018fec4fe2a6b1c3722c5c26b
-SHA256 (gigabase-3.58.tar.gz) = 19d0fe6354285f3085b51a8a180c1381320da3deb1bc61e833829bb3bda9c2e0
-SIZE (gigabase-3.58.tar.gz) = 1421459
+MD5 (gigabase-3.61.tar.gz) = 9bc3d8b2cb00ea827d745d9adedf5948
+SHA256 (gigabase-3.61.tar.gz) = 29cccea5da9d50bf98b59b295da8df01718864dcadd5931b7d3e261f0e4bd101
+SIZE (gigabase-3.61.tar.gz) = 1434011
diff --git a/databases/gigabase/files/patch-Makefile.in b/databases/gigabase/files/patch-Makefile.in
index b8e098711ecb..ebbd45673eb1 100644
--- a/databases/gigabase/files/patch-Makefile.in
+++ b/databases/gigabase/files/patch-Makefile.in
@@ -1,11 +1,11 @@
---- Makefile.in.orig Wed Jun 15 12:21:14 2005
-+++ Makefile.in Wed Jun 15 12:23:48 2005
+--- Makefile.in.orig Fri May 4 23:46:57 2007
++++ Makefile.in Sun Oct 21 03:00:51 2007
@@ -5,8 +5,10 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
VPATH = @srcdir@
-LIBTOOL = ./libtool
-+LIBTOOL? = ./libtool
++LIBTOOL = @LIBTOOL@
INSTALL = @INSTALL@
+INSTALL_PROGRAM = @INSTALL_PROGRAM@
+INSTALL_DATA = @INSTALL_DATA@
@@ -30,6 +30,24 @@
CXXFLAGS = @CXXFLAGS@ $(DEFS)
CFLAGS = @CFLAGS@ $(DEFS)
LD = $(CXX)
+@@ -70,7 +72,7 @@
+
+ $(GB_LIB): $(OBJS)
+ # Coment this for AIX/xlC 5.0
+- $(LIBTOOL) --mode=link $(CXX) -o $@ $(OBJS) $(LDFLAGS) @LTHREADSLIB@ -rpath $(libdir) -version-info $(VERSION)
++ $(LIBTOOL) --mode=link $(CXX) -o $@ $(OBJS) $(LDFLAGS) -rpath $(libdir) -version-info $(VERSION)
+ # Uncoment this for AIX/xlC 5.0
+ # mkdir .libs
+ # xlC_r -qmkshrobj=-10 -o .libs/gigabase.so $(OBJS)
+@@ -80,7 +82,7 @@
+
+ $(CLI_LIB): $(CLI_OBJS)
+ # Coment this for AIX/xlC 5.0
+- $(LIBTOOL) --mode=link $(CXX) -o $@ $(CLI_OBJS) $(LDFLAGS) @LTHREADSLIB@ -rpath $(libdir) -version-info $(VERSION)
++ $(LIBTOOL) --mode=link $(CXX) -o $@ $(CLI_OBJS) $(LDFLAGS) -rpath $(libdir) -version-info $(VERSION)
+ # Uncoment this for AIX/xlC 5.0
+ # xlC_r -qmkshrobj=-10 -o .libs/cli.so $(CLI_OBJS)
+ # ar rv .libs/libcli_r.a .libs/cli.so
@@ -146,14 +148,14 @@
install: subsql $(GB_LIB) $(CLI_LIB)
diff --git a/databases/gigabase/files/patch-configure b/databases/gigabase/files/patch-configure
deleted file mode 100644
index bb9f2026648b..000000000000
--- a/databases/gigabase/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Sat Sep 28 01:31:38 2002
-+++ configure Sun Nov 3 09:18:40 2002
-@@ -12910,6 +12910,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/databases/gigabase/pkg-plist b/databases/gigabase/pkg-plist
index 50f695f3a3e3..af75059de2cb 100644
--- a/databases/gigabase/pkg-plist
+++ b/databases/gigabase/pkg-plist
@@ -4,7 +4,6 @@ include/gigabase/blob.h
include/gigabase/btree.h
include/gigabase/class.h
include/gigabase/cli.h
-include/gigabase/confdefs.h
include/gigabase/config.h
include/gigabase/container.h
include/gigabase/cursor.h