aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-29 20:20:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-29 20:20:32 +0000
commit2039e6e3b9e216b1a6b14d3a9330191b1a37283b (patch)
tree4afb280e616eab10a8dd5b7969b8c8f69feb0d1e
parent2d93ec971c3a76fd3203483c2d635e486c8d8175 (diff)
downloadports-2039e6e3b9e216b1a6b14d3a9330191b1a37283b.tar.gz
ports-2039e6e3b9e216b1a6b14d3a9330191b1a37283b.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/mugshot/Makefile54
-rw-r--r--net/mugshot/distinfo3
-rw-r--r--net/mugshot/files/patch-firefox-update.sh30
-rw-r--r--net/mugshot/pkg-descr9
-rw-r--r--net/mugshot/pkg-install13
-rw-r--r--net/mugshot/pkg-plist49
7 files changed, 159 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f5b829a0f835..75d3146e90fc 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -314,6 +314,7 @@
SUBDIR += msntp
SUBDIR += mtr
SUBDIR += mudix
+ SUBDIR += mugshot
SUBDIR += nakenchat
SUBDIR += nam
SUBDIR += nast
diff --git a/net/mugshot/Makefile b/net/mugshot/Makefile
new file mode 100644
index 000000000000..c060557e313e
--- /dev/null
+++ b/net/mugshot/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: mugshot
+# Date Created: 24 December 2006
+# Whom: wahjava
+#
+# $FreeBSD$
+#
+
+PORTNAME= mugshot
+PORTVERSION= 1.1.30
+CATEGORIES= net
+MASTER_SITES= http://download.mugshot.org/client/sources/linux/
+
+MAINTAINER= wahjava@gmail.com
+COMMENT= The official client for Mugshot network
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg:install \
+ Xss.1:${PORTSDIR}/x11/xorg-libraries:install
+BUILD_DEPENDS= ${PKGCONFIG_LOCAL_BASE}/dbus-1.pc:${PORTSDIR}/devel/dbus:install \
+ ${PKGCONFIG_LOCAL_BASE}/dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib:install \
+ ${PKGCONFIG_LOCAL_BASE}/loudmouth-1.0.pc:${PORTSDIR}/net-im/loudmouth:install \
+ ${PKGCONFIG_LOCAL_BASE}/cairo.pc:${PORTSDIR}/graphics/cairo:install \
+ ${PKGCONFIG_LOCAL_BASE}/libcurl.pc:${PORTSDIR}/ftp/curl:install \
+ ${LOCALBASE}/include/firefox/caps/nsIScriptSecurityManager.h:${PORTSDIR}/www/firefox:install \
+ ${LOCALBASE}/lib/firefox/xpidl:${PORTSDIR}/www/firefox:install \
+ ${X11BASE}/include/X11/extensions/scrnsaver.h:${PORTSDIR}/x11/xorg-libraries:install
+
+USE_GNOME= gnomehack gconf2 glib20 gtk20 pango
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+GCONF_SCHEMAS= mugshot-uri-handler.schemas
+INSTALLS_ICONS= yes
+
+USE_LDCONFIG= yes
+LDCONFIG_DIRS= %%PREFIX%%/lib/mugshot/firefox/components
+
+PKGCONFIG_LOCAL_BASE= ${LOCALBASE}/libdata/pkgconfig
+PKGCONFIG_X11_BASE= ${X11BASE}/libdata/pkgconfig
+
+.include <bsd.port.pre.mk>
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= "--with-gecko-idl=${FIREFOX_IDL_PATH}" \
+ "--with-gecko-headers=${LOCALBASE}/include/firefox" \
+ "--with-xpidl=${LOCALBASE}/lib/firefox/xpidl"
+
+FIREFOX_IDL_PATH!=${SH} -c 'for i in ${LOCALBASE}/share/idl/firefox-*; do [ -f $$i/nsIURI.idl ] && ${ECHO} $$i && break; done; exit 0;'
+BUILD_DEPENDS+=${FIREFOX_IDL_PATH}/nsIURI.idl:${PORTSDIR}/www/firefox:install
+
+post-install:
+ @${SED} -i "" -e "s|%%PREFIX%%|${PREFIX}|" ${PREFIX}/share/mugshot/firefox-update.sh
+ @${PREFIX}/share/mugshot/firefox-update.sh ${INSTALL_foobaa}
+
+.include <bsd.port.post.mk>
diff --git a/net/mugshot/distinfo b/net/mugshot/distinfo
new file mode 100644
index 000000000000..3f861c49e44e
--- /dev/null
+++ b/net/mugshot/distinfo
@@ -0,0 +1,3 @@
+MD5 (mugshot-1.1.30.tar.gz) = 282102620ec24371baa69011eb3d4e9a
+SHA256 (mugshot-1.1.30.tar.gz) = 8faafba70464046e765661f09ef3759a996154d9e6f8ba59c90545262f009398
+SIZE (mugshot-1.1.30.tar.gz) = 738440
diff --git a/net/mugshot/files/patch-firefox-update.sh b/net/mugshot/files/patch-firefox-update.sh
new file mode 100644
index 000000000000..d3ac0796443c
--- /dev/null
+++ b/net/mugshot/files/patch-firefox-update.sh
@@ -0,0 +1,30 @@
+--- firefox-update.sh.orig Sun Dec 24 22:31:37 2006
++++ firefox-update.sh Sun Dec 24 22:34:38 2006
+@@ -6,7 +6,7 @@
+ # Firefox is installed into versioned directories in /usr/lib[64]/firefox
+ #
+ if [ "$1" = "install" ] ; then
+- for libdir in /usr/lib /usr/lib64 ; do
++ libdir=%%PREFIX%%/lib
+ # Add symlinks to any firefox directory that looks like it is part of a
+ # currently installed package
+ for d in $libdir/firefox* ; do
+@@ -19,9 +19,8 @@
+ ln -s $target $link
+ fi
+ done
+- done
+ elif [ "$1" = "remove" ] ; then
+- for libdir in /usr/lib /usr/lib64 ; do
++ libdir=%%PREFIX%%/lib
+ # Remove any symlinks we've created into any firefox directory
+ for d in $libdir/firefox* ; do
+ if [ d = "$libdir/firefox*" ] ; then
+@@ -32,7 +31,6 @@
+ rm $link
+ fi
+ done
+- done
+ else
+ echo "Usage firefox-update.sh [install/remove]"
+ fi
diff --git a/net/mugshot/pkg-descr b/net/mugshot/pkg-descr
new file mode 100644
index 000000000000..332807ac8826
--- /dev/null
+++ b/net/mugshot/pkg-descr
@@ -0,0 +1,9 @@
+This is the port of mugshot, an official client for
+Mugshot network. Mugshot makes it easy to show off
+what you're doing online and keep track of what
+your friends are up to.
+
+WWW: http://www.mugshot.org/
+
+- Ashish Shukla
+wahjava@gmail.com
diff --git a/net/mugshot/pkg-install b/net/mugshot/pkg-install
new file mode 100644
index 000000000000..5233c87bfd60
--- /dev/null
+++ b/net/mugshot/pkg-install
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+FFUPDATE=${PKG_PREFIX}/share/mugshot/firefox-update.sh
+
+case $2 in
+POST-INSTALL)
+ ${FFUPDATE} install
+ ;;
+PRE-DEINSTALL)
+ killall mugshot
+ ${FFUPDATE} remove
+ ;;
+esac
diff --git a/net/mugshot/pkg-plist b/net/mugshot/pkg-plist
new file mode 100644
index 000000000000..4faa87ae8387
--- /dev/null
+++ b/net/mugshot/pkg-plist
@@ -0,0 +1,49 @@
+@unexec killall mugshot 2>/dev/null >/dev/null || exit 0
+bin/mugshot
+bin/mugshot-uri-handler
+lib/mugshot/firefox/components/hippoIExtension.xpt
+lib/mugshot/firefox/components/hippoIControl.xpt
+lib/mugshot/firefox/components/hippoIControlListener.xpt
+lib/mugshot/firefox/components/libhippofirefox.so
+lib/mugshot/firefox/components/libhippofirefox.la
+lib/mugshot/firefox/components/libhippofirefox.a
+lib/mugshot/firefox/chrome/content/overlay.js
+lib/mugshot/firefox/chrome/content/overlay.xul
+lib/mugshot/firefox/chrome/locale/en-US/overlay.dtd
+lib/mugshot/firefox/chrome/skin/linkswarm16x16.png
+lib/mugshot/firefox/chrome/skin/linkswarm24x24.png
+lib/mugshot/firefox/chrome/skin/mugshot32x32.png
+lib/mugshot/firefox/chrome/skin/toolbar.css
+lib/mugshot/firefox/chrome.manifest
+lib/mugshot/firefox/install.rdf
+lib/mugshot/firefox/defaults/preferences/prefs.js
+share/autostart/mugshot.desktop
+@unexec %%PREFIX%%/share/mugshot/firefox-update.sh remove
+%%DATADIR%%/firefox-update.sh
+%%DATADIR%%/version
+share/icons/hicolor/128x128/apps/mugshot.png
+share/icons/hicolor/32x32/apps/mugshot.gif
+share/icons/hicolor/48x48/apps/mugshot.gif
+share/icons/hicolor/16x16/apps/mugshot.png
+share/icons/hicolor/16x16/apps/mugshot_note_on.png
+share/icons/hicolor/16x16/apps/mugshot_note_off.png
+share/icons/hicolor/22x22/apps/mugshot_notification.png
+share/icons/hicolor/22x22/apps/mugshot_notification_disabled.png
+share/icons/hicolor/22x22/apps/mugshot_swarm_1.png
+share/icons/hicolor/22x22/apps/mugshot_swarm_2.png
+share/icons/hicolor/22x22/apps/mugshot_swarm_3.png
+share/icons/hicolor/22x22/apps/mugshot_swarm_4.png
+share/icons/hicolor/22x22/apps/mugshot_swarm_5.png
+share/icons/hicolor/24x24/apps/mugshot.gif
+@dirrm lib/mugshot/firefox/components
+@dirrm lib/mugshot/firefox/chrome/content
+@dirrm lib/mugshot/firefox/chrome/locale/en-US
+@dirrm lib/mugshot/firefox/chrome/locale
+@dirrm lib/mugshot/firefox/chrome/skin
+@dirrm lib/mugshot/firefox/chrome
+@dirrm lib/mugshot/firefox/defaults/preferences
+@dirrm lib/mugshot/firefox/defaults
+@dirrm lib/mugshot/firefox
+@dirrm lib/mugshot
+@dirrm share/autostart
+@dirrm share/mugshot