aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 10:51:39 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 10:51:39 +0000
commit26b2bed6ddc55f37f034dd7a23fbf90286abd170 (patch)
treeb7027bcdc4a1913fd67b019c4731cb8dfa4167dc
parent737bed69235f6656811e04b0cec49ae13226eb72 (diff)
downloadports-26b2bed6ddc55f37f034dd7a23fbf90286abd170.tar.gz
ports-26b2bed6ddc55f37f034dd7a23fbf90286abd170.zip
Notes
-rw-r--r--irc/bitlbee/Makefile2
-rw-r--r--irc/irssi-dcc_send_limiter/Makefile2
-rw-r--r--irc/irssi-devel/Makefile2
-rw-r--r--irc/irssi-otr/Makefile9
-rw-r--r--irc/irssi/Makefile4
-rw-r--r--irc/ratbox-services/Makefile2
-rw-r--r--irc/smartirc4net/Makefile9
-rw-r--r--irc/weechat-devel/Makefile2
-rw-r--r--irc/znc/Makefile2
9 files changed, 11 insertions, 23 deletions
diff --git a/irc/bitlbee/Makefile b/irc/bitlbee/Makefile
index 793801549bd6..2a00d48ba94d 100644
--- a/irc/bitlbee/Makefile
+++ b/irc/bitlbee/Makefile
@@ -20,9 +20,9 @@ PORTDOCS= AUTHORS CHANGES CREDITS FAQ README
PORTEXAMPLES= bitlbee.conf motd.txt
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_GMAKE= yes
USE_GNOME= glib20
-USE_PKGCONFIG= build
USE_RC_SUBR= bitlbee
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/irc/irssi-dcc_send_limiter/Makefile b/irc/irssi-dcc_send_limiter/Makefile
index 72369717f3d0..e33aec4cc28b 100644
--- a/irc/irssi-dcc_send_limiter/Makefile
+++ b/irc/irssi-dcc_send_limiter/Makefile
@@ -20,8 +20,8 @@ COMMENT= Irssi plugin to limit the transmit speed of DCC sends
BUILD_DEPENDS= irssi:${PORTSDIR}/irc/irssi
RUN_DEPENDS= irssi:${PORTSDIR}/irc/irssi
+USES= pkgconfig
USE_GNOME= glib20
-USE_PKGCONFIG= build
NO_WRKSUBDIR= yes
PLIST_FILES= lib/irssi/modules/lib/${DISTNAME}.so
diff --git a/irc/irssi-devel/Makefile b/irc/irssi-devel/Makefile
index 71cbba4d5e8d..97c25bd82930 100644
--- a/irc/irssi-devel/Makefile
+++ b/irc/irssi-devel/Makefile
@@ -16,8 +16,8 @@ LIB_DEPENDS= glib-2.0:${PORTSDIR}/devel/glib20
CONFLICTS= irssi-0.8*
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_GMAKE= yes
-USE_PKGCONFIG= build
WANT_PERL= yes
MAKE_JOBS_SAFE= yes
diff --git a/irc/irssi-otr/Makefile b/irc/irssi-otr/Makefile
index 14274ec789b5..54945e4b7dd6 100644
--- a/irc/irssi-otr/Makefile
+++ b/irc/irssi-otr/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: irssi-otr
-# Date created: 2008-08-16
-# Whom: Ashish Shukla <wahjava@gmail.com>
-#
+# Created by: Ashish Shukla <wahjava@gmail.com>
# $FreeBSD$
-#
PORTNAME= irssi-otr
PORTVERSION= 0.3
@@ -24,10 +20,9 @@ RUN_DEPENDS= irssi:${PORTSDIR}/irc/irssi
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake
+USES= cmake pkgconfig
USE_LDCONFIG= yes
USE_GNOME= glib20
-USE_PKGCONFIG= build
PLIST_FILES= lib/irssi/modules/libotr.so \
%%DOCSDIR%%/LICENSE %%DOCSDIR%%/README
diff --git a/irc/irssi/Makefile b/irc/irssi/Makefile
index 1fd15a909fd6..59f2671f9531 100644
--- a/irc/irssi/Makefile
+++ b/irc/irssi/Makefile
@@ -1,6 +1,4 @@
-#
# $FreeBSD$
-#
PORTNAME= irssi
PORTVERSION= 0.8.15
@@ -15,9 +13,9 @@ LIB_DEPENDS= glib-2:${PORTSDIR}/devel/glib20
CONFLICTS= irssi-devel-[0-9]* zh-irssi-[0-9]*
+USES= pkgconfig
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_PKGCONFIG= build
USE_GMAKE= yes
USE_NCURSES= yes
WANT_PERL= yes
diff --git a/irc/ratbox-services/Makefile b/irc/ratbox-services/Makefile
index 112395e330be..6ed396050922 100644
--- a/irc/ratbox-services/Makefile
+++ b/irc/ratbox-services/Makefile
@@ -21,7 +21,7 @@ LOGDIR?= /var/log
RUNDIR?= /var/run
DBDIR?= /var/db/${PORTNAME}
PERL?= ${LOCALBASE}/bin/perl
-USE_PKGCONFIG= build
+USES= pkgconfig
SUB_FILES= pkg-message pkg-install
PLIST_SUB= LOGDIR=${LOGDIR} RUNDIR=${RUNDIR} DBDIR=${DBDIR} PERL=${PERL}
SUB_LIST= LOGDIR=${LOGDIR} RUNDIR=${RUNDIR} DBDIR=${DBDIR} PERL=${PERL}
diff --git a/irc/smartirc4net/Makefile b/irc/smartirc4net/Makefile
index 2c0d0beaad5e..f33a76b0a41c 100644
--- a/irc/smartirc4net/Makefile
+++ b/irc/smartirc4net/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: smartirc4net
-# Date created: 2009-08-25
-# Whom: Romain Tartiere <romain@blogreen.org>
-#
+# Created by: Romain Tartiere <romain@blogreen.org>
# $FreeBSD$
-#
PORTNAME= smartirc4net
PORTVERSION= 0.4.5.1
@@ -17,8 +13,7 @@ BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
RUN_DEPENDS:= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
-USE_PKGCONFIG= build
USE_GMAKE= yes
-USES= pathfix
+USES= pathfix pkgconfig
.include <bsd.port.mk>
diff --git a/irc/weechat-devel/Makefile b/irc/weechat-devel/Makefile
index e82733de45a4..aeec455f963c 100644
--- a/irc/weechat-devel/Makefile
+++ b/irc/weechat-devel/Makefile
@@ -95,7 +95,7 @@ PLIST_SUB+= RUBY="@comment "
.endif
.if ${PORT_OPTIONS:MGNUTLS}
-USE_PKGCONFIG= yes
+USES+= pkgconfig
LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
.else
CMAKE_ARGS+= -DENABLE_GNUTLS=no
diff --git a/irc/znc/Makefile b/irc/znc/Makefile
index 4d5fb8a36639..d58dc1bbc9d3 100644
--- a/irc/znc/Makefile
+++ b/irc/znc/Makefile
@@ -13,8 +13,8 @@ LICENSE= GPLv2
FETCH_ARGS= -Fpr
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_GMAKE= yes
-USE_PKGCONFIG= build
USE_ICONV= yes
WANT_PERL= yes