aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-06-30 05:16:13 +0000
committerAndrej Zverev <az@FreeBSD.org>2012-06-30 05:16:13 +0000
commit332b64b050c99e13c55bc8b3cf96b52727c5cf63 (patch)
tree9c597d6e500729ed5084eb97a4799d7271d59dc8
parent7e74ee47cde8b53a8ff45dbe3b014664a25f6079 (diff)
downloadports-332b64b050c99e13c55bc8b3cf96b52727c5cf63.tar.gz
ports-332b64b050c99e13c55bc8b3cf96b52727c5cf63.zip
Notes
-rw-r--r--devel/p5-Class-Unload/Makefile2
-rw-r--r--devel/p5-Class-XSAccessor-Array/Makefile2
-rw-r--r--devel/p5-Devel-Dumpvar/Makefile2
-rw-r--r--devel/p5-File-ShareDir-PAR/Makefile8
-rw-r--r--devel/p5-Module-Extract/Makefile2
-rw-r--r--devel/p5-Module-Inspector/Makefile18
-rw-r--r--devel/p5-Module-Manifest/Makefile4
-rw-r--r--devel/p5-Module-Math-Depends/Makefile4
-rw-r--r--devel/p5-Parse-ErrorString-Perl/Makefile6
-rw-r--r--editors/p5-Padre/Makefile10
-rw-r--r--textproc/p5-Pod-Abstract/Makefile4
-rw-r--r--x11-toolkits/p5-Alien-wxWidgets/Makefile4
12 files changed, 33 insertions, 33 deletions
diff --git a/devel/p5-Class-Unload/Makefile b/devel/p5-Class-Unload/Makefile
index 5f840a7f8f25..243a682575d7 100644
--- a/devel/p5-Class-Unload/Makefile
+++ b/devel/p5-Class-Unload/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= cm@therek.net
COMMENT= Perl5 module for unloading classes
-BUILD_DEPENDS= ${SITE_PERL}/Class/Inspector.pm:${PORTSDIR}/devel/p5-Class-Inspector
+BUILD_DEPENDS= p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/devel/p5-Class-XSAccessor-Array/Makefile b/devel/p5-Class-XSAccessor-Array/Makefile
index 32e3bdbf63a0..b29429a77c44 100644
--- a/devel/p5-Class-XSAccessor-Array/Makefile
+++ b/devel/p5-Class-XSAccessor-Array/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= cm@therek.net
COMMENT= Perl5 module for unloading classes
-BUILD_DEPENDS= ${SITE_PERL}/AutoXS/Header.pm:${PORTSDIR}/devel/p5-AutoXS-Header
+BUILD_DEPENDS= p5-AutoXS-Header>=0:${PORTSDIR}/devel/p5-AutoXS-Header
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/devel/p5-Devel-Dumpvar/Makefile b/devel/p5-Devel-Dumpvar/Makefile
index 071812e342ab..275db968ab91 100644
--- a/devel/p5-Devel-Dumpvar/Makefile
+++ b/devel/p5-Devel-Dumpvar/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= cm@therek.net
COMMENT= A pure-OO reimplementation of dumpvar.pl
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+BUILD_DEPENDS= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/devel/p5-File-ShareDir-PAR/Makefile b/devel/p5-File-ShareDir-PAR/Makefile
index 82e6323cc655..04e901127ee0 100644
--- a/devel/p5-File-ShareDir-PAR/Makefile
+++ b/devel/p5-File-ShareDir-PAR/Makefile
@@ -14,10 +14,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= cm@therek.net
COMMENT= Perl5 File::ShareDir module with PAR support
-BUILD_DEPENDS= ${SITE_PERL}/Class/Inspector.pm:${PORTSDIR}/devel/p5-Class-Inspector \
- ${SITE_PERL}/File/ShareDir.pm:${PORTSDIR}/devel/p5-File-ShareDir \
- ${SITE_PERL}/PAR.pm:${PORTSDIR}/devel/p5-PAR \
- ${SITE_PERL}/${PERL_ARCH}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util
+BUILD_DEPENDS= p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector \
+ p5-File-ShareDir>=0:${PORTSDIR}/devel/p5-File-ShareDir \
+ p5-PAR>=0:${PORTSDIR}/devel/p5-PAR \
+ p5-Params-Util>=0:${PORTSDIR}/devel/p5-Params-Util
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/devel/p5-Module-Extract/Makefile b/devel/p5-Module-Extract/Makefile
index 939664595452..d23f630ae435 100644
--- a/devel/p5-Module-Extract/Makefile
+++ b/devel/p5-Module-Extract/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= cm@therek.net
COMMENT= Base class for working with Perl distributions
-BUILD_DEPENDS= ${SITE_PERL}/Archive/Extract.pm:${PORTSDIR}/archivers/p5-Archive-Extract
+BUILD_DEPENDS= p5-Archive-Extract>=0:${PORTSDIR}/archivers/p5-Archive-Extract
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/devel/p5-Module-Inspector/Makefile b/devel/p5-Module-Inspector/Makefile
index 6c90d79cb2f5..9e1d1ac49acb 100644
--- a/devel/p5-Module-Inspector/Makefile
+++ b/devel/p5-Module-Inspector/Makefile
@@ -14,15 +14,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= cm@therek.net
COMMENT= An integrated API for inspecting Perl distributions
-BUILD_DEPENDS= ${SITE_PERL}/File/Find/Rule/VCS.pm:${PORTSDIR}/devel/p5-File-Find-Rule-VCS \
- ${SITE_PERL}/File/Find/Rule/Perl.pm:${PORTSDIR}/devel/p5-File-Find-Rule-Perl \
- ${SITE_PERL}/Module/Extract.pm:${PORTSDIR}/devel/p5-Module-Extract \
- ${SITE_PERL}/Module/Manifest.pm:${PORTSDIR}/devel/p5-Module-Manifest \
- ${SITE_PERL}/Module/Math/Depends.pm:${PORTSDIR}/devel/p5-Module-Math-Depends \
- ${SITE_PERL}/PPI.pm:${PORTSDIR}/textproc/p5-PPI \
- ${SITE_PERL}/YAML/Tiny.pm:${PORTSDIR}/textproc/p5-YAML-Tiny \
- ${SITE_PERL}/${PERL_ARCH}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util \
- ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version
+BUILD_DEPENDS= p5-File-Find-Rule-VCS>=0:${PORTSDIR}/devel/p5-File-Find-Rule-VCS \
+ p5-File-Find-Rule-Perl>=0:${PORTSDIR}/devel/p5-File-Find-Rule-Perl \
+ p5-Module-Extract>=0:${PORTSDIR}/devel/p5-Module-Extract \
+ p5-Module-Manifest>=0:${PORTSDIR}/devel/p5-Module-Manifest \
+ p5-Module-Math-Depends>=0:${PORTSDIR}/devel/p5-Module-Math-Depends \
+ p5-PPI>=0:${PORTSDIR}/textproc/p5-PPI \
+ p5-YAML-Tiny>=0:${PORTSDIR}/textproc/p5-YAML-Tiny \
+ p5-Params-Util>=0:${PORTSDIR}/devel/p5-Params-Util \
+ p5-version>=0:${PORTSDIR}/devel/p5-version
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/devel/p5-Module-Manifest/Makefile b/devel/p5-Module-Manifest/Makefile
index 18546eff5631..8d31ae29156f 100644
--- a/devel/p5-Module-Manifest/Makefile
+++ b/devel/p5-Module-Manifest/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= cm@therek.net
COMMENT= Parse and examine a Perl distribution MANIFEST file
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util \
- ${SITE_PERL}/Test/Warn.pm:${PORTSDIR}/devel/p5-Test-Warn
+BUILD_DEPENDS= p5-Params-Util>=0:${PORTSDIR}/devel/p5-Params-Util \
+ p5-Test-Warn>=0:${PORTSDIR}/devel/p5-Test-Warn
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
diff --git a/devel/p5-Module-Math-Depends/Makefile b/devel/p5-Module-Math-Depends/Makefile
index e486f6e0a2df..dab0b2b3a586 100644
--- a/devel/p5-Module-Math-Depends/Makefile
+++ b/devel/p5-Module-Math-Depends/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= cm@therek.net
COMMENT= Convenience object for manipulating module dependencies
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util \
- ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version
+BUILD_DEPENDS= p5-Params-Util>=0:${PORTSDIR}/devel/p5-Params-Util \
+ p5-version>=0:${PORTSDIR}/devel/p5-version
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/devel/p5-Parse-ErrorString-Perl/Makefile b/devel/p5-Parse-ErrorString-Perl/Makefile
index f9d3499a215a..9bd3f835894d 100644
--- a/devel/p5-Parse-ErrorString-Perl/Makefile
+++ b/devel/p5-Parse-ErrorString-Perl/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= cm@therek.net
COMMENT= Parse error messages from the Perl interpreter
-BUILD_DEPENDS= ${SITE_PERL}/Pod/POM.pm:${PORTSDIR}/textproc/p5-Pod-POM \
- ${SITE_PERL}/Test/Differences.pm:${PORTSDIR}/devel/p5-Test-Differences \
- ${SITE_PERL}/${PERL_ARCH}/Class/XSAccessor.pm:${PORTSDIR}/devel/p5-Class-XSAccessor
+BUILD_DEPENDS= p5-Pod-POM>=0:${PORTSDIR}/textproc/p5-Pod-POM \
+ p5-Test-Differences>=0:${PORTSDIR}/devel/p5-Test-Differences \
+ p5-Class-XSAccessor>=0:${PORTSDIR}/devel/p5-Class-XSAccessor
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/editors/p5-Padre/Makefile b/editors/p5-Padre/Makefile
index f795482bbf9d..6102e54b1351 100644
--- a/editors/p5-Padre/Makefile
+++ b/editors/p5-Padre/Makefile
@@ -40,16 +40,16 @@ BUILD_DEPENDS= p5-ack>=1.86:${PORTSDIR}/textproc/p5-ack \
p5-Parse-ExuberantCTags>=1.00:${PORTSDIR}/devel/p5-Parse-ExuberantCTags \
p5-Pod-Abstract>=0.16:${PORTSDIR}/textproc/p5-Pod-Abstract \
p5-Pod-POM>=0.17:${PORTSDIR}/textproc/p5-Pod-POM \
- ${SITE_PERL}/Probe/Perl.pm:${PORTSDIR}/sysutils/p5-Probe-Perl \
- ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
- ${SITE_PERL}/Test/NoWarnings.pm:${PORTSDIR}/devel/p5-Test-NoWarnings \
- ${SITE_PERL}/Test/Script.pm:${PORTSDIR}/devel/p5-Test-Script \
+ p5-Probe-Perl>=0:${PORTSDIR}/sysutils/p5-Probe-Perl \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings \
+ p5-Test-Script>=0:${PORTSDIR}/devel/p5-Test-Script \
p5-Text-Diff>=0.35:${PORTSDIR}/textproc/p5-Text-Diff \
p5-Text-FindIndent>=0.06:${PORTSDIR}/textproc/p5-Text-FindIndent \
p5-URI>0:${PORTSDIR}/net/p5-URI \
p5-YAML-Tiny>=1.32:${PORTSDIR}/textproc/p5-YAML-Tiny \
p5-Class-XSAccessor>=1.05:${PORTSDIR}/devel/p5-Class-XSAccessor \
- ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
p5-DBI>=1.58:${PORTSDIR}/databases/p5-DBI \
p5-HTML-Parser>=3.65:${PORTSDIR}/www/p5-HTML-Parser \
p5-Params-Util>=0.33:${PORTSDIR}/devel/p5-Params-Util \
diff --git a/textproc/p5-Pod-Abstract/Makefile b/textproc/p5-Pod-Abstract/Makefile
index 4eaf0a06fa47..1b45e583acea 100644
--- a/textproc/p5-Pod-Abstract/Makefile
+++ b/textproc/p5-Pod-Abstract/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= cm@therek.net
COMMENT= Abstract document tree for Perl POD documents
-BUILD_DEPENDS= ${SITE_PERL}/IO/String.pm:${PORTSDIR}/devel/p5-IO-String \
- ${SITE_PERL}/Task/Weaken.pm:${PORTSDIR}/devel/p5-Task-Weaken
+BUILD_DEPENDS= p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String \
+ p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/x11-toolkits/p5-Alien-wxWidgets/Makefile b/x11-toolkits/p5-Alien-wxWidgets/Makefile
index 376e3062002d..a6d7236a3732 100644
--- a/x11-toolkits/p5-Alien-wxWidgets/Makefile
+++ b/x11-toolkits/p5-Alien-wxWidgets/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= cm@therek.net
COMMENT= Perl5 module for building, finding and using wxWidgets binaries
-BUILD_DEPENDS= ${SITE_PERL}/ExtUtils/CBuilder.pm:${PORTSDIR}/devel/p5-ExtUtils-CBuilder
+BUILD_DEPENDS= p5-ExtUtils-CBuilder>=0:${PORTSDIR}/devel/p5-ExtUtils-CBuilder
OPTIONS= UNICODE "Build with Unicode support" on
@@ -26,7 +26,7 @@ PERL_MODBUILD= yes
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500809
-BUILD_DEPENDS+= ${SITE_PERL}/Module/Pluggable.pm:${PORTSDIR}/devel/p5-Module-Pluggable
+BUILD_DEPENDS+= p5-Module-Pluggable>=0:${PORTSDIR}/devel/p5-Module-Pluggable
.endif
.if defined(WITH_UNICODE)