aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-02 17:29:36 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-02 17:29:36 +0000
commit3ab32baa74b8619142ce727a4cf1c179c8487da0 (patch)
treeacdc21ff3a42c4d80ba907c626c3217bb942422c
parent055365c2db6480daaf9a547cf77ddae0b0f1452a (diff)
downloadports-3ab32baa74b8619142ce727a4cf1c179c8487da0.tar.gz
ports-3ab32baa74b8619142ce727a4cf1c179c8487da0.zip
Notes
-rw-r--r--www/p5-Amon2-Plugin-Web-MobileAgent/Makefile3
-rw-r--r--www/p5-CGI-Application-Dispatch/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-Forward/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-JSON/Makefile3
-rw-r--r--www/p5-Catalyst-Plugin-SmartURI/Makefile3
-rw-r--r--www/p5-Catalyst-TraitFor-Controller-DBIC-DoesPaging/Makefile3
-rw-r--r--www/p5-HTTP-Daemon-SSL/Makefile3
-rw-r--r--www/p5-HTTP-Server-Simple-Mason/Makefile3
-rw-r--r--www/p5-Net-YAP/Makefile3
-rw-r--r--www/p5-Plack-Handler-AnyEvent-SCGI/Makefile3
-rw-r--r--www/p5-Plack-Middleware-ReverseProxy/Makefile3
-rw-r--r--www/p5-Plack-Middleware-Status/Makefile3
-rw-r--r--www/p5-WWW-HatenaDiary/Makefile3
-rw-r--r--www/p5-WWW-Scripter/Makefile3
-rw-r--r--www/p5-WWW-Shorten-Googl/Makefile3
-rw-r--r--www/p5-WWW-WebArchive/Makefile3
-rw-r--r--www/p5-WebService-BuzzurlAPI/Makefile3
-rw-r--r--www/p5-webservice-validator-html-w3c/Makefile3
-rw-r--r--www/squidstats/Makefile2
19 files changed, 37 insertions, 19 deletions
diff --git a/www/p5-Amon2-Plugin-Web-MobileAgent/Makefile b/www/p5-Amon2-Plugin-Web-MobileAgent/Makefile
index a94b7f3c9cd8..a8ba9e49a1d3 100644
--- a/www/p5-Amon2-Plugin-Web-MobileAgent/Makefile
+++ b/www/p5-Amon2-Plugin-Web-MobileAgent/Makefile
@@ -29,7 +29,8 @@ TEST_DEPENDS= \
p5-String-CamelCase>0:${PORTSDIR}/textproc/p5-String-CamelCase \
p5-Module-Find>0:${PORTSDIR}/devel/p5-Module-Find
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Amon2::Plugin::Web::MobileAgent.3 \
Amon2::Plugin::Web::MobileCharset.3 \
diff --git a/www/p5-CGI-Application-Dispatch/Makefile b/www/p5-CGI-Application-Dispatch/Makefile
index 0465087c7c0d..1820f8273956 100644
--- a/www/p5-CGI-Application-Dispatch/Makefile
+++ b/www/p5-CGI-Application-Dispatch/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-CGI-Application>=4.50:${PORTSDIR}/www/p5-CGI-Application \
p5-Try-Tiny>=0:${PORTSDIR}/lang/p5-Try-Tiny
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Application::Dispatch.3 \
CGI::Application::Dispatch::PSGI.3 \
diff --git a/www/p5-CGI-Application-Plugin-Forward/Makefile b/www/p5-CGI-Application-Plugin-Forward/Makefile
index c5890809311a..7016e87b4129 100644
--- a/www/p5-CGI-Application-Plugin-Forward/Makefile
+++ b/www/p5-CGI-Application-Plugin-Forward/Makefile
@@ -14,7 +14,8 @@ BUILD_DEPENDS= p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application \
p5-CGI-Application-Plugin-AutoRunmode>=0:${PORTSDIR}/www/p5-CGI-Application-Plugin-AutoRunmode
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Application::Plugin::Forward.3
diff --git a/www/p5-CGI-Application-Plugin-JSON/Makefile b/www/p5-CGI-Application-Plugin-JSON/Makefile
index facbe0a1632f..54d94ad4a54c 100644
--- a/www/p5-CGI-Application-Plugin-JSON/Makefile
+++ b/www/p5-CGI-Application-Plugin-JSON/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= p5-CGI-Application>4.01:${PORTSDIR}/www/p5-CGI-Application \
p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
p5-JSON-Any>=0:${PORTSDIR}/converters/p5-JSON-Any
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Application::Plugin::JSON.3
diff --git a/www/p5-Catalyst-Plugin-SmartURI/Makefile b/www/p5-Catalyst-Plugin-SmartURI/Makefile
index 96b44a19f929..db2bb0377a39 100644
--- a/www/p5-Catalyst-Plugin-SmartURI/Makefile
+++ b/www/p5-Catalyst-Plugin-SmartURI/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-Catalyst-Runtime>=5.7007:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-parent>=0:${PORTSDIR}/devel/p5-parent
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Plugin::SmartURI.3
diff --git a/www/p5-Catalyst-TraitFor-Controller-DBIC-DoesPaging/Makefile b/www/p5-Catalyst-TraitFor-Controller-DBIC-DoesPaging/Makefile
index f11206c08540..3f75ff476419 100644
--- a/www/p5-Catalyst-TraitFor-Controller-DBIC-DoesPaging/Makefile
+++ b/www/p5-Catalyst-TraitFor-Controller-DBIC-DoesPaging/Makefile
@@ -24,7 +24,8 @@ TEST_DEPENDS= p5-Catalyst-View-JSON>=0:${PORTSDIR}/www/p5-Catalyst-View-JSON \
p5-SQL-Translator>=0:${PORTSDIR}/databases/p5-SQL-Translator \
p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::TraitFor::Controller::DBIC::DoesPaging.3
diff --git a/www/p5-HTTP-Daemon-SSL/Makefile b/www/p5-HTTP-Daemon-SSL/Makefile
index f519ea6680d9..9aad32e88ed7 100644
--- a/www/p5-HTTP-Daemon-SSL/Makefile
+++ b/www/p5-HTTP-Daemon-SSL/Makefile
@@ -17,7 +17,8 @@ COMMENT= A simple http server class with SSL support
RUN_DEPENDS= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTTP::Daemon::SSL.3
diff --git a/www/p5-HTTP-Server-Simple-Mason/Makefile b/www/p5-HTTP-Server-Simple-Mason/Makefile
index b9007d528f63..3929e1c68110 100644
--- a/www/p5-HTTP-Server-Simple-Mason/Makefile
+++ b/www/p5-HTTP-Server-Simple-Mason/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-HTTP-Server-Simple>=0:${PORTSDIR}/www/p5-HTTP-Server-Simple \
p5-Hook-LexWrap>=0:${PORTSDIR}/devel/p5-Hook-LexWrap
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE=yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTTP::Server::Simple::Mason.3
diff --git a/www/p5-Net-YAP/Makefile b/www/p5-Net-YAP/Makefile
index 00c9c9dabd10..96b6c2d8edd8 100644
--- a/www/p5-Net-YAP/Makefile
+++ b/www/p5-Net-YAP/Makefile
@@ -17,7 +17,8 @@ COMMENT= Conduit to communicate with the Yahoo! Application Platform
BUILD_DEPENDS= p5-Net-OAuth-Simple>=1.0:${PORTSDIR}/net/p5-Net-OAuth-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::YAP.3
diff --git a/www/p5-Plack-Handler-AnyEvent-SCGI/Makefile b/www/p5-Plack-Handler-AnyEvent-SCGI/Makefile
index 466f9d02dbd3..8ce74349efc9 100644
--- a/www/p5-Plack-Handler-AnyEvent-SCGI/Makefile
+++ b/www/p5-Plack-Handler-AnyEvent-SCGI/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-TCP>0:${PORTSDIR}/devel/p5-Test-TCP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Handler::AnyEvent::SCGI.3
diff --git a/www/p5-Plack-Middleware-ReverseProxy/Makefile b/www/p5-Plack-Middleware-ReverseProxy/Makefile
index 3f2858e637e1..61b8a69cf566 100644
--- a/www/p5-Plack-Middleware-ReverseProxy/Makefile
+++ b/www/p5-Plack-Middleware-ReverseProxy/Makefile
@@ -13,7 +13,8 @@ RUN_DEPENDS= \
p5-Plack>=0.9988:${PORTSDIR}/www/p5-Plack
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Middleware::ReverseProxy.3
diff --git a/www/p5-Plack-Middleware-Status/Makefile b/www/p5-Plack-Middleware-Status/Makefile
index df69690e662d..c50b48cf1b86 100644
--- a/www/p5-Plack-Middleware-Status/Makefile
+++ b/www/p5-Plack-Middleware-Status/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= \
p5-Plack>0:${PORTSDIR}/www/p5-Plack
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Middleware::Status.3
diff --git a/www/p5-WWW-HatenaDiary/Makefile b/www/p5-WWW-HatenaDiary/Makefile
index c91fe90dc21b..22cc0484fb37 100644
--- a/www/p5-WWW-HatenaDiary/Makefile
+++ b/www/p5-WWW-HatenaDiary/Makefile
@@ -21,7 +21,8 @@ BUILD_DEPENDS= p5-YAML-Syck>=0:${PORTSDIR}/textproc/p5-YAML-Syck \
p5-Web-Scraper>=0:${PORTSDIR}/www/p5-Web-Scraper
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::HatenaDiary.3
diff --git a/www/p5-WWW-Scripter/Makefile b/www/p5-WWW-Scripter/Makefile
index a9c60916015b..915ec604a234 100644
--- a/www/p5-WWW-Scripter/Makefile
+++ b/www/p5-WWW-Scripter/Makefile
@@ -16,7 +16,8 @@ RUN_DEPENDS= p5-libwww>=5.829:${PORTSDIR}/www/p5-libwww \
p5-CSS-DOM>=0:${PORTSDIR}/www/p5-CSS-DOM
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Scripter::Location.3 WWW::Scripter.3 \
WWW::Scripter::History.3 WWW::Scripter::WindowGroup.3
diff --git a/www/p5-WWW-Shorten-Googl/Makefile b/www/p5-WWW-Shorten-Googl/Makefile
index 4aae5f70fed4..007cd33e0d22 100644
--- a/www/p5-WWW-Shorten-Googl/Makefile
+++ b/www/p5-WWW-Shorten-Googl/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-WWW-Shorten>=1.98:${PORTSDIR}/www/p5-WWW-Shorten \
p5-JSON-Any>=0:${PORTSDIR}/converters/p5-JSON-Any
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::Shorten::Googl.3
diff --git a/www/p5-WWW-WebArchive/Makefile b/www/p5-WWW-WebArchive/Makefile
index 3b75436277bf..43b2e822eeab 100644
--- a/www/p5-WWW-WebArchive/Makefile
+++ b/www/p5-WWW-WebArchive/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= p5-App-Options>=0:${PORTSDIR}/devel/p5-App-Options \
p5-App-Trace>=0:${PORTSDIR}/devel/p5-App-Trace \
p5-WWW-Mechanize>=0:${PORTSDIR}/www/p5-WWW-Mechanize
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::WebArchive.3 WWW::WebArchive::Agent.3 \
WWW::WebArchive::WaybackMachine.3
diff --git a/www/p5-WebService-BuzzurlAPI/Makefile b/www/p5-WebService-BuzzurlAPI/Makefile
index ec75d6562fdd..0256175a1312 100644
--- a/www/p5-WebService-BuzzurlAPI/Makefile
+++ b/www/p5-WebService-BuzzurlAPI/Makefile
@@ -23,7 +23,8 @@ RUN_DEPENDS= p5-Class-Accessor>=0.25:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Readonly>=1.01:${PORTSDIR}/devel/p5-Readonly \
p5-UNIVERSAL-require>=0.10:${PORTSDIR}/devel/p5-UNIVERSAL-require
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WebService::BuzzurlAPI.3 \
WebService::BuzzurlAPI::Util.3 \
diff --git a/www/p5-webservice-validator-html-w3c/Makefile b/www/p5-webservice-validator-html-w3c/Makefile
index 1231aa6ca489..0592c39a919e 100644
--- a/www/p5-webservice-validator-html-w3c/Makefile
+++ b/www/p5-webservice-validator-html-w3c/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WebService::Validator::HTML::W3C::Error.3 \
WebService::Validator::HTML::W3C.3
diff --git a/www/squidstats/Makefile b/www/squidstats/Makefile
index 5773925af47f..43d11951efc3 100644
--- a/www/squidstats/Makefile
+++ b/www/squidstats/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= p5-Config-IniFiles>=2.39:${PORTSDIR}/devel/p5-Config-IniFiles \
p5-RRD-Simple>=1.44:${PORTSDIR}/databases/p5-RRD-Simple \
p5-SNMP_Session>=1.11:${PORTSDIR}/net-mgmt/p5-SNMP_Session
-USE_PERL5= yes
+USES= perl5
SQUID_UID?= squid
SQUID_GID?= squid