aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 11:46:54 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 11:46:54 +0000
commit4ad115ab4e7cbe42412a4185a32532ea7f4b9b86 (patch)
tree4d7c2d928bc64195e60de1e71fe1b58b1e0609b6
parent0f3d0b5eb8897f1c27b64a652519e71abd896216 (diff)
downloadports-4ad115ab4e7cbe42412a4185a32532ea7f4b9b86.tar.gz
ports-4ad115ab4e7cbe42412a4185a32532ea7f4b9b86.zip
Notes
-rw-r--r--japanese/anthy/Makefile2
-rw-r--r--japanese/libskk/Makefile8
-rw-r--r--japanese/mozc-server/Makefile8
-rw-r--r--japanese/ochusha/Makefile2
-rw-r--r--japanese/scim-tables/Makefile2
-rw-r--r--japanese/skk-tools/Makefile2
-rw-r--r--java/classpath/Makefile2
-rw-r--r--java/eclipse/Makefile2
-rw-r--r--java/icedtea-web/Makefile2
-rw-r--r--java/jamvm/Makefile2
-rw-r--r--java/sablevm/Makefile2
11 files changed, 13 insertions, 21 deletions
diff --git a/japanese/anthy/Makefile b/japanese/anthy/Makefile
index 582113554ab8..95e4a354bbaf 100644
--- a/japanese/anthy/Makefile
+++ b/japanese/anthy/Makefile
@@ -19,9 +19,9 @@ LICENSE_FILE_GPLv2= ${WRKSRC}/alt-cannadic/COPYING
LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_LDCONFIG= yes
USE_GNOME= lthack
-USE_PKGCONFIG= build
DOCSDIR= share/doc/ja/anthy
ELISPDIR= share/emacs/site-lisp/anthy
diff --git a/japanese/libskk/Makefile b/japanese/libskk/Makefile
index 32d97dea7f7a..c2e8502832ee 100644
--- a/japanese/libskk/Makefile
+++ b/japanese/libskk/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libskk
-# Date created: 21 December 2011
-# Whom: Hiroto Kagotani <hiroto.kagotani@gmail.com>
-#
+# Created by: Hiroto Kagotani <hiroto.kagotani@gmail.com>
# $FreeBSD$
-#
PORTNAME= libskk
PORTVERSION= 1.0.0
@@ -21,7 +17,7 @@ LIB_DEPENDS= gee:${PORTSDIR}/devel/libgee06 \
USE_LDCONFIG= yes
USE_GMAKE= yes
USE_GNOME= intltool gnomehack
-USE_PKGCONFIG= build
+USES= pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV+= DATADIRNAME=share
MAN1= skk.1
diff --git a/japanese/mozc-server/Makefile b/japanese/mozc-server/Makefile
index 377a132babcc..16c4a1920e63 100644
--- a/japanese/mozc-server/Makefile
+++ b/japanese/mozc-server/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mozc-server
-# Date created: 26 June 2010
-# Whom: Daichi GOTO <daichi@freebsd.org>
-#
+# Created by: Daichi GOTO <daichi@freebsd.org>
# $FreeBSD$
-#
PORTNAME= mozc
PORTVERSION= 1.10.1390.102
@@ -19,12 +15,12 @@ COMMENT?= Mozc server for IBus and others
LIB_DEPENDS= protobuf:${PORTSDIR}/devel/protobuf
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
+USES= pkgconfig
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
USE_PYTHON= yes
USE_OPENSSL= yes
-USE_PKGCONFIG= build
MAKE_JOBS_SAFE= yes
diff --git a/japanese/ochusha/Makefile b/japanese/ochusha/Makefile
index 4e0973b56228..79656da2502b 100644
--- a/japanese/ochusha/Makefile
+++ b/japanese/ochusha/Makefile
@@ -14,12 +14,12 @@ COMMENT= GUI BBS browser for 2ch.net
MAN1= ochusha.1
MANCOMPRESSED= no
+USES= pkgconfig
USE_BZIP2= yes
USE_GNOME= glib20 gtk20 libxml2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
-USE_PKGCONFIG= yes
DESKTOP_ENTRIES="Ochusha" "${COMMENT}" \
"${PREFIX}/share/ochusha/ochusha32.xpm" \
diff --git a/japanese/scim-tables/Makefile b/japanese/scim-tables/Makefile
index 08474bd59afa..abb0e561bac8 100644
--- a/japanese/scim-tables/Makefile
+++ b/japanese/scim-tables/Makefile
@@ -13,9 +13,9 @@ COMMENT= SCIM table based Japanese input methods
BUILD_DEPENDS= scim-make-table:${PORTSDIR}/textproc/scim-table-imengine
RUN_DEPENDS= scim-make-table:${PORTSDIR}/textproc/scim-table-imengine
+USES= pkgconfig
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_PKGCONFIG= build
.include <bsd.port.pre.mk>
diff --git a/japanese/skk-tools/Makefile b/japanese/skk-tools/Makefile
index ac5c7ab18d0a..b64c1bdebd25 100644
--- a/japanese/skk-tools/Makefile
+++ b/japanese/skk-tools/Makefile
@@ -30,7 +30,7 @@ PLIST_FILES= bin/skkdic-count bin/skkdic-expr bin/skkdic-sort
.if ${PORT_OPTIONS:MEXPR2}
USE_GNOME= glib20
-USE_PKGCONFIG= build
+USES+= pkgconfig
PORTDOCS+= README.skkdic-expr2
PLIST_FILES+= bin/skkdic-expr2
.else
diff --git a/java/classpath/Makefile b/java/classpath/Makefile
index ef42cdfd6752..fb7310e5fd9e 100644
--- a/java/classpath/Makefile
+++ b/java/classpath/Makefile
@@ -17,11 +17,11 @@ COMMENT= A GNU project to create a free Java class library
LICENSE= GPLv2
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_GMAKE= yes
USE_ICONV= yes
USE_LDCONFIG= yes
USE_PERL5_BUILD=yes
-USE_PKGCONFIG= build
USE_XORG= x11 ice xtst xaw xproto xext
WANT_GNOME= yes
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index 2498d87a6069..6170465eca07 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -40,11 +40,11 @@ TESTS_DESC= Build SDK test suite
ONLY_FOR_ARCHS= i386 amd64
+USES= pkgconfig
USE_ANT= yes
USE_GL= glu
USE_GMAKE= yes
USE_GNOME= desktopfileutils gconf2 gtk20 gnomevfs2 libgnome libgnomeui
-USE_PKGCONFIG= build
USE_JAVA= yes
USE_XZ= yes
BZIP2_SUFX= .tar.bz2
diff --git a/java/icedtea-web/Makefile b/java/icedtea-web/Makefile
index d57938b9cda7..41f056ff0ed6 100644
--- a/java/icedtea-web/Makefile
+++ b/java/icedtea-web/Makefile
@@ -21,7 +21,7 @@ USE_JAVA= yes
JAVA_OS= native
JAVA_VENDOR= openjdk
JAVA_VERSION= 1.6+
-USE_PKGCONFIG= yes
+USES= pkgconfig
USE_PERL5_BUILD=yes
USE_XORG= x11
WANT_GNOME= yes
diff --git a/java/jamvm/Makefile b/java/jamvm/Makefile
index ad624086a40a..0e21d3d28dad 100644
--- a/java/jamvm/Makefile
+++ b/java/jamvm/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/classpath/glibj.zip:${PORTSDIR}/java/classpath
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-classpath-install-dir=${LOCALBASE}
USE_GMAKE= yes
-USE_PKGCONFIG= build
+USES= pkgconfig
OPTIONS_DEFINE= FFI ZIP
OPTIONS_DEFAULT=FFI ZIP
diff --git a/java/sablevm/Makefile b/java/sablevm/Makefile
index e8f853d3b580..c84e9b7e873c 100644
--- a/java/sablevm/Makefile
+++ b/java/sablevm/Makefile
@@ -22,7 +22,7 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_ICONV= yes
USE_LDCONFIG= yes
-USE_PKGCONFIG= build
+USES= pkgconfig
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib