aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-10-07 17:55:57 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-10-07 17:55:57 +0000
commit4c19afcdf6601d1945b042b86b23b8039cce89b1 (patch)
treeec02f381265f58e75aa467825681876e2d29cbfa
parent31da6e085d7b7bfe8fe2da0ec2f5e8600b3459ef (diff)
downloadports-4c19afcdf6601d1945b042b86b23b8039cce89b1.tar.gz
ports-4c19afcdf6601d1945b042b86b23b8039cce89b1.zip
Notes
-rw-r--r--games/openbor/Makefile3
-rw-r--r--games/openbor/distinfo6
-rw-r--r--games/openbor/files/patch-openbor.c9
3 files changed, 4 insertions, 14 deletions
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index 57631be7cd3e..9c0a388fe139 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -2,7 +2,7 @@
PORTNAME= openbor
# Hint: svn revision is git rev-list --count ${GH_TAGNAME}
-PORTVERSION?= 4515
+PORTVERSION?= 4539
.ifndef PKGNAMESUFFIX
PORTREVISION= 0
.endif
@@ -27,7 +27,6 @@ LIB_DEPENDS+= libvpx.so:multimedia/libvpx
USE_GITHUB= yes
GH_ACCOUNT= DCurrent
-GH_TAGNAME?= 12fc70c
USES+= gmake pkgconfig
.if ${PORTVERSION} < 4433
diff --git a/games/openbor/distinfo b/games/openbor/distinfo
index 6be9d9f55f2e..9c55f2806376 100644
--- a/games/openbor/distinfo
+++ b/games/openbor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1496950714
-SHA256 (DCurrent-openbor-4515-12fc70c_GH0.tar.gz) = ee6d6604fe02b873b95339d7305ce874581c268e17ef5693c14801ded4f35f72
-SIZE (DCurrent-openbor-4515-12fc70c_GH0.tar.gz) = 66891846
+TIMESTAMP = 1507042233
+SHA256 (DCurrent-openbor-4539_GH0.tar.gz) = 5ea8329c83a2d0cce5ea577117d87bcd5a0176464870f2f18a6cf9e043150aa6
+SIZE (DCurrent-openbor-4539_GH0.tar.gz) = 66890659
diff --git a/games/openbor/files/patch-openbor.c b/games/openbor/files/patch-openbor.c
index 16991f52e4d0..a60c8d7a90fb 100644
--- a/games/openbor/files/patch-openbor.c
+++ b/games/openbor/files/patch-openbor.c
@@ -52,15 +52,6 @@ Avoid accidental rounding from abs()
ptrdiff_t pos = 0;
char *newbuf = NULL;
-@@ -13933,7 +13933,7 @@ void generate_basemap(int map_index, flo
-
- void load_level(char *filename)
- {
-- char *buf;
-+ char *buf = NULL;
- size_t size, len, sblen;
- ptrdiff_t pos, oldpos;
- char *command;
@@ -15210,6 +15210,11 @@ void bar(int x, int y, int value, int ma
return;
}