aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-09-02 15:43:57 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-09-02 15:43:57 +0000
commit4cecbbcf472d7b8ae1c9626b39497d565a39e87e (patch)
tree861f43d56134958c2f490ae2c87a03137a3019d9
parent2d63d5e45a11c5cf4a57ac430a1931e06051c1b8 (diff)
downloadports-4cecbbcf472d7b8ae1c9626b39497d565a39e87e.tar.gz
ports-4cecbbcf472d7b8ae1c9626b39497d565a39e87e.zip
MFH: r509978 r510809
www/firefox: update to 69.0 Changes: https://www.mozilla.org/firefox/69.0/releasenotes/ PR: 239155 Security: 05463e0a-abd3-4fa4-bd5f-cd5ed132d4c6 Approved by: ports-secteam (joneum) Differential Revision: https://reviews.freebsd.org/D20932
Notes
Notes: svn path=/branches/2019Q3/; revision=510810
-rw-r--r--www/firefox/Makefile8
-rw-r--r--www/firefox/distinfo6
-rw-r--r--www/firefox/files/patch-bug8475682
-rw-r--r--www/firefox/files/patch-dom_media_flac_FlacDecoder.cpp9
4 files changed, 13 insertions, 12 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 2ae3505dcb5d..e51b11f89555 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -2,21 +2,21 @@
# $FreeBSD$
PORTNAME= firefox
-DISTVERSION= 68.0.2
+DISTVERSION= 69.0
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
- MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build3/source
+ MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
DISTFILES= ${DISTNAME}.source${EXTRACT_SUFX}
MAINTAINER= gecko@FreeBSD.org
COMMENT= Web browser based on the browser portion of Mozilla
BUILD_DEPENDS= nspr>=4.21:devel/nspr \
- nss>=3.44.1:security/nss \
+ nss>=3.45:security/nss \
icu>=63.1,1:devel/icu \
libevent>=2.1.8:devel/libevent \
- harfbuzz>=2.4.0:print/harfbuzz \
+ harfbuzz>=2.5.3:print/harfbuzz \
graphite2>=1.3.13:graphics/graphite2 \
png>=1.6.35:graphics/png \
libvpx>=1.5.0:multimedia/libvpx \
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index 4804401b2dbb..56d19ac0a57c 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1565719693
-SHA256 (firefox-68.0.2.source.tar.xz) = 9b3e6d8f99819f9eda9ebba403b644a2b96d19450b42cae422bbf4386902a840
-SIZE (firefox-68.0.2.source.tar.xz) = 311257408
+TIMESTAMP = 1566869555
+SHA256 (firefox-69.0.source.tar.xz) = 413c3febdfeb69eade818824eecbdb11eaeda71de229573810afd641ba741ec5
+SIZE (firefox-69.0.source.tar.xz) = 323421020
diff --git a/www/firefox/files/patch-bug847568 b/www/firefox/files/patch-bug847568
index 9d243256a6d5..9bc463e7132d 100644
--- a/www/firefox/files/patch-bug847568
+++ b/www/firefox/files/patch-bug847568
@@ -249,7 +249,7 @@ index 9297e4d6f501..d8e273887e4b 100644
+option('--with-system-harfbuzz',
+ help="Use system harfbuzz (located with pkgconfig)")
+
-+system_harfbuzz = pkg_check_modules('MOZ_HARFBUZZ', 'harfbuzz >= 2.4.0',
++system_harfbuzz = pkg_check_modules('MOZ_HARFBUZZ', 'harfbuzz >= 2.5.3',
+ when='--with-system-harfbuzz')
+
+set_config('MOZ_SYSTEM_HARFBUZZ', depends_if(system_harfbuzz)(lambda _: True))
diff --git a/www/firefox/files/patch-dom_media_flac_FlacDecoder.cpp b/www/firefox/files/patch-dom_media_flac_FlacDecoder.cpp
index d797b41ed389..0fc81aa4c862 100644
--- a/www/firefox/files/patch-dom_media_flac_FlacDecoder.cpp
+++ b/www/firefox/files/patch-dom_media_flac_FlacDecoder.cpp
@@ -12,13 +12,14 @@ index 53fc3c9937f7..b23771ab80fa 100644
namespace mozilla {
-@@ -15,6 +16,10 @@ FlacDecoder::IsEnabled()
- {
+@@ -14,6 +15,11 @@ namespace mozilla {
+ bool FlacDecoder::IsEnabled() {
#ifdef MOZ_FFVPX
- return StaticPrefs::MediaFlacEnabled();
+ return StaticPrefs::media_flac_enabled();
+#elif defined(MOZ_FFMPEG)
+ RefPtr<PDMFactory> platform = new PDMFactory();
-+ return StaticPrefs::MediaFlacEnabled() && platform->SupportsMimeType(NS_LITERAL_CSTRING("audio/flac"),
++ return StaticPrefs::media_flac_enabled() &&
++ platform->SupportsMimeType(NS_LITERAL_CSTRING("audio/flac"),
+ /* DecoderDoctorDiagnostics* */ nullptr);
#else
// Until bug 1295886 is fixed.