aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-09-16 11:30:35 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-09-16 11:30:35 +0000
commit5436a0de9948a2e69f024dcd5f5e52419858fb82 (patch)
tree2422295e6ee7c2de5a8f93f1de1278a3a552cfa7
parent89c8d72066101de35dda38d6dda74708769188ed (diff)
downloadports-5436a0de9948a2e69f024dcd5f5e52419858fb82.tar.gz
ports-5436a0de9948a2e69f024dcd5f5e52419858fb82.zip
MFH: r511814 www/py-soupsieve: Add missing dependency
soupsieve depends on backports.functools_lru_cache [1] on Python versions < 3, add the dependency accordingly. While I'm here: - Add TEST_DEPENDS and test target to improve future QA Note: soupsieve 'requires' [2] beautifulsoup4, but beautifulsoup4 depends on soupsieve via install_requires, causing a technical circular dependency, which is why soupsieve doesn't seem to explicitly install_requires on it ... anymore [3]. This seems bizzare. [1] requirements/project.txt: backports.functools_lru_cache ; python_version < '3' [2] https://github.com/facelessuser/soupsieve#installation [3] https://github.com/facelessuser/soupsieve/commit/9a792216ea1ffce018c7968105540c08b82b96db QA: 624 passed, 2 skipped, 6 warnings in 35.70 seconds PR: 240490 Reported by: jbeich Approved by: portmgr (blanket: missing dependencies, ports compliance) Approved by: ports-secteam (blanket: run-time bugfix)
Notes
Notes: svn path=/branches/2019Q3/; revision=512169
-rw-r--r--www/py-soupsieve/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/www/py-soupsieve/Makefile b/www/py-soupsieve/Makefile
index a0828d5709cc..fa2fee055062 100644
--- a/www/py-soupsieve/Makefile
+++ b/www/py-soupsieve/Makefile
@@ -2,6 +2,7 @@
PORTNAME= soupsieve
PORTVERSION= 1.9
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,8 +13,23 @@ COMMENT= CSS4 selector implementation for BeautifulSoup
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}html5lib>0:www/py-html5lib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}beautifulsoup>4:www/py-beautifulsoup@${PY_FLAVOR}
+
USES= python
USE_PYTHON= autoplist concurrent distutils
+
NO_ARCH= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_VER} < 3
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}backports.functools_lru_cache>0:devel/py-backports.functools_lru_cache@${PY_FLAVOR}
+.endif
+
+do-test:
+ cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs
+
+.include <bsd.port.post.mk>