aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-04-26 23:36:13 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-04-26 23:36:13 +0000
commit57f3db43b7bfea20a44852885a0835adcbb37773 (patch)
tree06517f1705c370719d06ecd2582b4474a359e4f8
parentb8abdfd3dba14fba5f19ced34a8f1d6ae04067af (diff)
downloadports-57f3db43b7bfea20a44852885a0835adcbb37773.tar.gz
ports-57f3db43b7bfea20a44852885a0835adcbb37773.zip
Notes
-rw-r--r--MOVED1
-rw-r--r--games/Makefile2
-rw-r--r--games/chromium-bsu/Makefile30
-rw-r--r--games/chromium-bsu/distinfo6
-rw-r--r--games/chromium-bsu/pkg-plist11
-rw-r--r--games/chromium/Makefile59
-rw-r--r--games/chromium/distinfo3
-rw-r--r--games/chromium/pkg-descr6
-rw-r--r--games/chromium/pkg-plist81
9 files changed, 34 insertions, 165 deletions
diff --git a/MOVED b/MOVED
index eb1e8daa616d..acadc4518a55 100644
--- a/MOVED
+++ b/MOVED
@@ -3939,3 +3939,4 @@ www/mod_mysqluserdir||2009-04-13|Depends on broken databases/mysql323-client
x11/nvidia-driver-71xx|x11/nvidia-driver-71|2009-04-13|Renamed
x11/nvidia-driver-96xx|x11/nvidia-driver-96|2009-04-13|Renamed
emulators/cpmtools27|emulators/cpmtools2|2009-04-25|Renamed
+games/chromium|games/chromium-bsu|2009-04-26|Renamed
diff --git a/games/Makefile b/games/Makefile
index 7cbfbec482fa..5244c3e2b835 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -124,7 +124,7 @@
SUBDIR += cheech
SUBDIR += childsplay
SUBDIR += childsplay_plugins
- SUBDIR += chromium
+ SUBDIR += chromium-bsu
SUBDIR += circuslinux
SUBDIR += cleanq3
SUBDIR += columns
diff --git a/games/chromium-bsu/Makefile b/games/chromium-bsu/Makefile
index 7ac1eb098995..08ca2e720426 100644
--- a/games/chromium-bsu/Makefile
+++ b/games/chromium-bsu/Makefile
@@ -5,10 +5,10 @@
# $FreeBSD$
#
-PORTNAME= chromium
-PORTVERSION= 0.9.13.3
+PORTNAME= chromium-bsu
+PORTVERSION= 0.9.14
CATEGORIES= games
-MASTER_SITES= SF/chromium-bsu
+MASTER_SITES= SF
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= An arcade-style, top-scrolling space shooter
@@ -21,11 +21,12 @@ GNU_CONFIGURE= yes
USE_GL= gl glu
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-glc
MAKE_JOBS_SAFE= yes
PORTDOCS= *
-MAN6= chromium.6
+MAN6= chromium-bsu.6
OPTIONS= SDL_MIXER "Use SDL_mixer instead of openal for audio" off \
GLUT "Use GLUT instead of SDL for video" off
@@ -34,9 +35,9 @@ OPTIONS= SDL_MIXER "Use SDL_mixer instead of openal for audio" off \
.if defined(WITH_GLUT)
USE_GL+= glut
-CONFIGURE_ARGS+=--disable-sdl
+CONFIGURE_ARGS+=--disable-sdl --disable-sdlimage
.else
-USE_SDL+= sdl
+USE_SDL+= sdl image
CONFIGURE_ARGS+=--disable-glut
.endif
@@ -49,11 +50,22 @@ LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal \
CONFIGURE_ARGS+=--disable-sdlmixer
.endif
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
post-patch:
+ @${REINPLACE_CMD} -e '/^LIBS =/ s|$$| @INTLLIBS@|' \
+ ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|\([A-Z][A-Z_]*[A-Z]\)\+="\(.*\)"$$|\1="$$\1 \2"|; \
+ s|\([A-Z][A-Z_]*[A-Z]\)\+=\(.*\)$$|\1="$$\1 \2"|' \
+ ${WRKSRC}/configure
.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e '/SUBDIRS/ s|doc||' ${WRKSRC}/data/Makefile.in
+ @${REINPLACE_CMD} -e '/doc / d' ${WRKSRC}/data/Makefile.in
.endif
- @${REINPLACE_CMD} -e '/^bindir=.*games/ d; /^datadir=.*games/ d' \
- ${WRKSRC}/configure
.include <bsd.port.post.mk>
diff --git a/games/chromium-bsu/distinfo b/games/chromium-bsu/distinfo
index 4819088242b5..5fe19ab49582 100644
--- a/games/chromium-bsu/distinfo
+++ b/games/chromium-bsu/distinfo
@@ -1,3 +1,3 @@
-MD5 (chromium-0.9.13.3.tar.gz) = 877a0412ae3839f5c1174922a655b405
-SHA256 (chromium-0.9.13.3.tar.gz) = 60affa635624a992483da40de353c2681cd15aaaa52b2ae9753d38c865574c40
-SIZE (chromium-0.9.13.3.tar.gz) = 1504097
+MD5 (chromium-bsu-0.9.14.tar.gz) = 26df69b13e2ca370b6b45ac8e9efddd5
+SHA256 (chromium-bsu-0.9.14.tar.gz) = 17e6f846458dff790d1d9c534bb5c9087ce97d6a4616f4cbd4851abdfb2d1709
+SIZE (chromium-bsu-0.9.14.tar.gz) = 1615989
diff --git a/games/chromium-bsu/pkg-plist b/games/chromium-bsu/pkg-plist
index efa6b9f05c70..4874b52b1242 100644
--- a/games/chromium-bsu/pkg-plist
+++ b/games/chromium-bsu/pkg-plist
@@ -1,5 +1,5 @@
-bin/chromium
-share/applications/chromium.desktop
+bin/chromium-bsu
+share/applications/chromium-bsu.desktop
%%DATADIR%%/png/check.png
%%DATADIR%%/png/chrome.jpg
%%DATADIR%%/png/cursor.png
@@ -49,6 +49,8 @@ share/applications/chromium.desktop
%%DATADIR%%/png/heroExplo02.png
%%DATADIR%%/png/heroShields.png
%%DATADIR%%/png/heroSuper.png
+%%DATADIR%%/png/icon32.png
+%%DATADIR%%/png/icon64.png
%%DATADIR%%/png/life.png
%%DATADIR%%/png/menu_back.png
%%DATADIR%%/png/menu_updown.png
@@ -74,7 +76,10 @@ share/applications/chromium.desktop
%%DATADIR%%/wav/music_game.wav
%%DATADIR%%/wav/music_menu.wav
%%DATADIR%%/wav/power.wav
-share/pixmaps/chromium.png
+%%NLS%%share/locale/bg/LC_MESSAGES/chromium-bsu.mo
+%%NLS%%share/locale/de/LC_MESSAGES/chromium-bsu.mo
+%%NLS%%share/locale/es/LC_MESSAGES/chromium-bsu.mo
+share/pixmaps/chromium-bsu.png
@dirrm %%DATADIR%%/wav
@dirrm %%DATADIR%%/png
@dirrm %%DATADIR%%
diff --git a/games/chromium/Makefile b/games/chromium/Makefile
deleted file mode 100644
index 7ac1eb098995..000000000000
--- a/games/chromium/Makefile
+++ /dev/null
@@ -1,59 +0,0 @@
-# New ports collection makefile for: chromium
-# Date created: 17 Dec, 2003
-# Whom: Eric Anholt <anholt@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= chromium
-PORTVERSION= 0.9.13.3
-CATEGORIES= games
-MASTER_SITES= SF/chromium-bsu
-
-MAINTAINER= amdmi3@FreeBSD.org
-COMMENT= An arcade-style, top-scrolling space shooter
-
-LIB_DEPENDS= glpng.1:${PORTSDIR}/graphics/glpng \
- ftgl.2:${PORTSDIR}/graphics/ftgl \
- fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
-
-GNU_CONFIGURE= yes
-USE_GL= gl glu
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-MAKE_JOBS_SAFE= yes
-
-PORTDOCS= *
-
-MAN6= chromium.6
-
-OPTIONS= SDL_MIXER "Use SDL_mixer instead of openal for audio" off \
- GLUT "Use GLUT instead of SDL for video" off
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_GLUT)
-USE_GL+= glut
-CONFIGURE_ARGS+=--disable-sdl
-.else
-USE_SDL+= sdl
-CONFIGURE_ARGS+=--disable-glut
-.endif
-
-.if defined(WITH_SDL_MIXER)
-USE_SDL+= mixer
-CONFIGURE_ARGS+=--disable-openal
-.else
-LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal \
- alut.1:${PORTSDIR}/audio/freealut
-CONFIGURE_ARGS+=--disable-sdlmixer
-.endif
-
-post-patch:
-.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e '/SUBDIRS/ s|doc||' ${WRKSRC}/data/Makefile.in
-.endif
- @${REINPLACE_CMD} -e '/^bindir=.*games/ d; /^datadir=.*games/ d' \
- ${WRKSRC}/configure
-
-.include <bsd.port.post.mk>
diff --git a/games/chromium/distinfo b/games/chromium/distinfo
deleted file mode 100644
index 4819088242b5..000000000000
--- a/games/chromium/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (chromium-0.9.13.3.tar.gz) = 877a0412ae3839f5c1174922a655b405
-SHA256 (chromium-0.9.13.3.tar.gz) = 60affa635624a992483da40de353c2681cd15aaaa52b2ae9753d38c865574c40
-SIZE (chromium-0.9.13.3.tar.gz) = 1504097
diff --git a/games/chromium/pkg-descr b/games/chromium/pkg-descr
deleted file mode 100644
index 909f495ba1b5..000000000000
--- a/games/chromium/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-Chromium B.S.U. is a fast paced, arcade-style, top-scrolling space shooter.
-
-WWW: http://www.reptilelabour.com/software/chromium/
-
-- Eric Anholt
-anholt@FreeBSD.org
diff --git a/games/chromium/pkg-plist b/games/chromium/pkg-plist
deleted file mode 100644
index efa6b9f05c70..000000000000
--- a/games/chromium/pkg-plist
+++ /dev/null
@@ -1,81 +0,0 @@
-bin/chromium
-share/applications/chromium.desktop
-%%DATADIR%%/png/check.png
-%%DATADIR%%/png/chrome.jpg
-%%DATADIR%%/png/cursor.png
-%%DATADIR%%/png/darken.png
-%%DATADIR%%/png/elect.png
-%%DATADIR%%/png/electric.png
-%%DATADIR%%/png/enemy00.png
-%%DATADIR%%/png/enemy01-extra.png
-%%DATADIR%%/png/enemy01-rot.png
-%%DATADIR%%/png/enemy01.png
-%%DATADIR%%/png/enemy02.png
-%%DATADIR%%/png/enemy03-extra.png
-%%DATADIR%%/png/enemy03.png
-%%DATADIR%%/png/enemy04.png
-%%DATADIR%%/png/enemy05.png
-%%DATADIR%%/png/enemy06.png
-%%DATADIR%%/png/enemyAmmo00.png
-%%DATADIR%%/png/enemyAmmo01.png
-%%DATADIR%%/png/enemyAmmo02.png
-%%DATADIR%%/png/enemyAmmo03.png
-%%DATADIR%%/png/enemyAmmo04.png
-%%DATADIR%%/png/enemyAmmoExplo00.png
-%%DATADIR%%/png/enemyAmmoExplo01.png
-%%DATADIR%%/png/enemyAmmoExplo02.png
-%%DATADIR%%/png/enemyAmmoExplo03.png
-%%DATADIR%%/png/enemyAmmoExplo04.png
-%%DATADIR%%/png/enemyExplo.png
-%%DATADIR%%/png/explo.png
-%%DATADIR%%/png/glitter.png
-%%DATADIR%%/png/gndBaseSea.png
-%%DATADIR%%/png/gndMetalBase00.png
-%%DATADIR%%/png/gndMetalBase01.png
-%%DATADIR%%/png/gndMetalBase02.png
-%%DATADIR%%/png/gndMetalBlip.png
-%%DATADIR%%/png/hero.png
-%%DATADIR%%/png/heroAmmo00.png
-%%DATADIR%%/png/heroAmmo01.png
-%%DATADIR%%/png/heroAmmo02.png
-%%DATADIR%%/png/heroAmmoExplo00.png
-%%DATADIR%%/png/heroAmmoExplo01.png
-%%DATADIR%%/png/heroAmmoExplo02.png
-%%DATADIR%%/png/heroAmmoFlash00.png
-%%DATADIR%%/png/heroAmmoFlash01.png
-%%DATADIR%%/png/heroAmmoFlash02.png
-%%DATADIR%%/png/heroExplo00.png
-%%DATADIR%%/png/heroExplo01.png
-%%DATADIR%%/png/heroExplo02.png
-%%DATADIR%%/png/heroShields.png
-%%DATADIR%%/png/heroSuper.png
-%%DATADIR%%/png/life.png
-%%DATADIR%%/png/menu_back.png
-%%DATADIR%%/png/menu_updown.png
-%%DATADIR%%/png/powerUpAmmo.png
-%%DATADIR%%/png/powerUpShield.png
-%%DATADIR%%/png/powerUpTex.png
-%%DATADIR%%/png/reflect-blend.png
-%%DATADIR%%/png/reflect-gnd.png
-%%DATADIR%%/png/reflect.png
-%%DATADIR%%/png/shields.png
-%%DATADIR%%/png/stat-top.png
-%%DATADIR%%/png/statBar.png
-%%DATADIR%%/png/superBomb.png
-%%DATADIR%%/png/useFocus.png
-%%DATADIR%%/png/useItem00.png
-%%DATADIR%%/png/useItem01.png
-%%DATADIR%%/wav/boom.wav
-%%DATADIR%%/wav/exploBig.wav
-%%DATADIR%%/wav/exploPop.wav
-%%DATADIR%%/wav/exploStd.wav
-%%DATADIR%%/wav/life_add.wav
-%%DATADIR%%/wav/life_lose.wav
-%%DATADIR%%/wav/music_game.wav
-%%DATADIR%%/wav/music_menu.wav
-%%DATADIR%%/wav/power.wav
-share/pixmaps/chromium.png
-@dirrm %%DATADIR%%/wav
-@dirrm %%DATADIR%%/png
-@dirrm %%DATADIR%%
-@dirrmtry share/applications