aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2008-07-01 14:47:01 +0000
committerVasil Dimov <vd@FreeBSD.org>2008-07-01 14:47:01 +0000
commit58c9262b54e1b26974d0804dc58ef98dab1cf270 (patch)
treeabb9305108d01ce19e627d7af73f21eb7e95bb45
parent66d4a2e48dbc7657ce1c722cdda7731d5d6bfbf3 (diff)
downloadports-58c9262b54e1b26974d0804dc58ef98dab1cf270.tar.gz
ports-58c9262b54e1b26974d0804dc58ef98dab1cf270.zip
Notes
-rw-r--r--graphics/hugin/Makefile92
-rw-r--r--graphics/hugin/distinfo6
-rw-r--r--graphics/hugin/files/patch-CMakeLists.txt10
-rw-r--r--graphics/hugin/files/patch-bootstrap20
-rw-r--r--graphics/hugin/files/patch-configure.ac36
-rw-r--r--graphics/hugin/files/patch-doc_CMakeLists.txt11
-rw-r--r--graphics/hugin/files/patch-m4_ax_boost.m420
-rw-r--r--graphics/hugin/files/patch-m4_ax_check_graphics.m474
-rw-r--r--graphics/hugin/files/patch-m4_ax_check_panotools.m420
-rw-r--r--graphics/hugin/files/patch-src-common-utils.cpp14
-rw-r--r--graphics/hugin/files/patch-src-hugin-ImagesPanel.cpp15
-rw-r--r--graphics/hugin/files/patch-src-hugin-Makefile.in10
-rw-r--r--graphics/hugin/files/patch-src-include-common-utils.h12
-rw-r--r--graphics/hugin/files/patch-src-include-panoinc.h11
-rw-r--r--graphics/hugin/files/patch-src_hugin1_hugin_config_defaults.h (renamed from graphics/hugin/files/patch-src_include_hugin_config_defaults.h)10
-rw-r--r--graphics/hugin/files/patch-src_hugin_xrc_Makefile.am8
-rw-r--r--graphics/hugin/pkg-plist191
17 files changed, 226 insertions, 334 deletions
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index b617501b609a..a6049cda73c8 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -6,77 +6,69 @@
#
PORTNAME= hugin
-DISTVERSION= 0.7_beta4
-PORTREVISION= 3
+PORTVERSION= 0.7.r3135
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= vd/hugin
MAINTAINER= vd@FreeBSD.org
COMMENT= A GUI for Panorama Tools, to stitch panoramic images
-# zip is needed for building the help file
-BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
-LIB_DEPENDS= pano13:${PORTSDIR}/graphics/libpano13 \
- tiff:${PORTSDIR}/graphics/tiff \
- png:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
jpeg:${PORTSDIR}/graphics/jpeg \
+ png:${PORTSDIR}/graphics/png \
+ IlmImf:${PORTSDIR}/graphics/OpenEXR \
+ exiv2:${PORTSDIR}/graphics/exiv2 \
+ pano13:${PORTSDIR}/graphics/libpano13 \
boost_date_time:${PORTSDIR}/devel/boost
+RUN_DEPENDS= enblend>=3.1.r20080615:${PORTSDIR}/graphics/enblend \
+ exiftool:${PORTSDIR}/graphics/p5-Image-ExifTool
-OPTIONS= ENBLEND "enblend for high quality blending" on \
- AUTOPANOSIFT "autopano-sift for automatic control points" on \
- PTSTITCHER "PTStitcher for stitching images" on
+# TODO add autopano-sift-C to the ports collection and hook it here as
+# an optional dependency
+
+OPTIONS= PANOMATIC "Install graphics/panomatic" on \
+ AUTOPANOSIFT "Install graphics/autopano-sift" on
USE_BZIP2= yes
-USE_AUTOTOOLS= autoconf:261:env autoheader:261:env aclocal:110:env \
- automake:110:env libtool:15:env
-
-IS_INTERACTIVE= yes
-
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS} WXRC=${WXRC_CMD}
-CONFIGURE_ARGS+=--with-boost=${LOCALBASE}
-# --disable-desktop
-USE_GMAKE= yes
-USE_ICONV= yes
-USE_WX= 2.6
-WX_CONF_ARGS= absolute
-
-.if defined(WX_UNICODE)
-CONFIGURE_ARGS+=--with-unicode=yes
-.else
-CONFIGURE_ARGS+=--with-unicode=no
-.endif
+USE_CMAKE= yes
+
+CMAKE_ARGS= -DwxWidgets_CONFIG_EXECUTABLE=${WX_CONFIG}
+CMAKE_VERBOSE= yes
+CMAKE_USE_PTHREAD= yes
+
+USE_WX= 2.8+
+
+USE_GETTEXT= yes
MAN1= fulla.1
-DOCSDIR= ${PREFIX}/share/hugin/xrc/data
+#DOCSDIR= ${PREFIX}/share/hugin/xrc/data
+
+# workaround a bug in cmake (?). Without this we get an error like:
+# cd /usr/ports/graphics/hugin/work/hugin-0.7.r3135/src/hugin1/base_wx && /usr/bin/c++ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -D_THREAD_SAFE -O2 -fno-strict-aliasing -pipe -pthread;-D_THREAD_SAFE -O3 -DNDEBUG -I/usr/ports/graphics/hugin/work/hugin-0.7.r3135/src -I/usr/ports/graphics/hugin/work/hugin-0.7.r3135/src/hugin_base -I/usr/ports/graphics/hugin/work/hugin-0.7.r3135/src/foreign -I/usr/ports/graphics/hugin/work/hugin-0.7.r3135/src/foreign/vigra -I/usr/local/include -I/usr/local/include/OpenEXR -isystem /usr/local/lib/wx/include/gtk2-ansi-release-2.8 -isystem /usr/local/include/wx-2.8 -I/usr/ports/graphics/hugin/work/hugin-0.7.r3135/src/hugin1 -o CMakeFiles/huginbasewx.dir/ImageCache.o -c /usr/ports/graphics/hugin/work/hugin-0.7.r3135/src/hugin1/base_wx/ImageCache.cpp
+# c++: No input files specified
+# with cmake 2.6.0. It works with cmake 2.4.8.
+post-configure:
+ ${REINPLACE_CMD} \
+ 's/-pthread;-D_THREAD_SAFE/-pthread -D_THREAD_SAFE/g' \
+ ${WRKSRC}/src/hugin1/base_wx/CMakeFiles/huginbasewx.dir/flags.make \
+ ${WRKSRC}/src/hugin1/hugin/CMakeFiles/hugin.dir/flags.make \
+ ${WRKSRC}/src/hugin1/hugin/CMakeFiles/hugin.dir/link.txt \
+ ${WRKSRC}/src/hugin1/nona_gui/CMakeFiles/nona_gui.dir/flags.make \
+ ${WRKSRC}/src/hugin1/nona_gui/CMakeFiles/nona_gui.dir/link.txt \
+ ${WRKSRC}/src/hugin1/stitch_project/CMakeFiles/hugin_stitch_project.dir/flags.make \
+ ${WRKSRC}/src/hugin1/stitch_project/CMakeFiles/hugin_stitch_project.dir/link.txt
.include <bsd.port.pre.mk>
-.if defined(WITH_ENBLEND)
-RUN_DEPENDS+= enblend:${PORTSDIR}/graphics/enblend
+.if defined(WITH_PANOMATIC)
+RUN_DEPENDS+= panomatic:${PORTSDIR}/graphics/panomatic
.endif
.if defined(WITH_AUTOPANOSIFT)
RUN_DEPENDS+= autopanog:${PORTSDIR}/graphics/autopano-sift
.endif
-.if defined(WITH_PTSTITCHER)
-RUN_DEPENDS+= PTStitcher:${PORTSDIR}/graphics/linux-panorama-tools
-.endif
-
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.endif
-
-pre-configure:
- cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ./bootstrap
-
.include <bsd.port.post.mk>
diff --git a/graphics/hugin/distinfo b/graphics/hugin/distinfo
index 384859690345..97e2c4249399 100644
--- a/graphics/hugin/distinfo
+++ b/graphics/hugin/distinfo
@@ -1,3 +1,3 @@
-MD5 (hugin-0.7_beta4.tar.bz2) = 28b69d85ae06a22fe9514f7f77e6dddb
-SHA256 (hugin-0.7_beta4.tar.bz2) = 4527d40ae56a6ef67583a350ab67505e86054c0b297b2d18cf892c2751cabcfd
-SIZE (hugin-0.7_beta4.tar.bz2) = 2319243
+MD5 (hugin-0.7.r3135.tar.bz2) = db441446f61e4b185e170f580042c875
+SHA256 (hugin-0.7.r3135.tar.bz2) = 39c3f0f6f8afd0896a0973e75d7179342fe49ca7de8f50c16b2ba76a83f05d55
+SIZE (hugin-0.7.r3135.tar.bz2) = 3704233
diff --git a/graphics/hugin/files/patch-CMakeLists.txt b/graphics/hugin/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..5e10ca6fdc22
--- /dev/null
+++ b/graphics/hugin/files/patch-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- CMakeLists.txt.orig 2008-06-30 08:28:53.000000000 +0300
++++ CMakeLists.txt 2008-06-30 08:29:57.000000000 +0300
+@@ -202,6 +202,7 @@
+ SET(HUGINDATADIR share/hugin)
+ SET(DATADIR share)
+ SET(BINDIR bin)
++SET(MANDIR man)
+ SET(LOCALEDIR share/locale)
+ SET(ICONDIR share/icons)
+ SET(LINKDIR share/applications)
diff --git a/graphics/hugin/files/patch-bootstrap b/graphics/hugin/files/patch-bootstrap
deleted file mode 100644
index c4b5b99e833f..000000000000
--- a/graphics/hugin/files/patch-bootstrap
+++ /dev/null
@@ -1,20 +0,0 @@
---- bootstrap.orig 2006-12-17 23:13:03.000000000 +0200
-+++ bootstrap 2008-06-11 12:14:34.000000000 +0300
-@@ -42,7 +42,7 @@
- gettextize_version=`$GETTEXTIZE --version | sed 's/^[^0-9]*\([0-9.][0-9.]*\).*/\1/'`
- # echo gettextize version: $gettextize_version
- case $gettextize_version in
-- 0.11*|0.12*|0.13*|0.14*|0.15*|0.16*)
-+ 0.1[1-9]*|0.[2-9]*|[1-9].*)
- have_gettextize=true
- ;;
- esac
-@@ -79,7 +79,7 @@
- automake_version=`$AUTOMAKE --version | sed 's/^[^0-9]*\([0-9.][0-9.]*\).*/\1/'`
- # echo automake version: $automake_version
- case $automake_version in
-- 1.7*|1.8*|1.9*)
-+ 1.7*|1.8*|1.9*|1.[1-9][0-9]*)
- have_automake=true
- ;;
- esac
diff --git a/graphics/hugin/files/patch-configure.ac b/graphics/hugin/files/patch-configure.ac
deleted file mode 100644
index 328b63040d84..000000000000
--- a/graphics/hugin/files/patch-configure.ac
+++ /dev/null
@@ -1,36 +0,0 @@
---- configure.ac.orig Mon Aug 21 01:19:33 2006
-+++ configure.ac Tue Jan 23 15:48:26 2007
-@@ -35,6 +35,10 @@
- ;;
- esac
- ;;
-+ *freebsd*)
-+ HSYS=freebsd
-+ HCPU="${target_cpu}"
-+ ;;
- darwin*)
- HSYS=darwin
- HCPU="${target_cpu}"
-@@ -56,6 +60,7 @@
- ;;
- esac
- AM_CONDITIONAL(HAVE_LINUX, test "${HSYS}" = "linux")
-+AM_CONDITIONAL(HAVE_FREEBSD, test "${HSYS}" = "freebsd")
- AM_CONDITIONAL(HAVE_DARWIN, test "${HSYS}" = "darwin")
- AM_CONDITIONAL(HAVE_MINGW, test "${HSYS}" = "mingw32")
-
-@@ -240,6 +245,14 @@
- where wxWidgets libraries are installed (returned by
- 'wx-config --libs' command) is in LD_LIBRARY_PATH or
- equivalent variable and wxWidgets version is 2.4.2 or above.
-+ ])
-+fi
-+
-+AM_PATH_WXRC([HAVE_WXRC=1], [HAVE_WXRC=0])
-+if test "x$HAVE_WXRC" != x1; then
-+ AC_MSG_ERROR([
-+ The wxrc program was not installed or not found.
-+ Please check the wxWidgets installation.
- ])
- fi
-
diff --git a/graphics/hugin/files/patch-doc_CMakeLists.txt b/graphics/hugin/files/patch-doc_CMakeLists.txt
new file mode 100644
index 000000000000..1ff5cc6e4513
--- /dev/null
+++ b/graphics/hugin/files/patch-doc_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- doc/CMakeLists.txt.orig 2008-06-30 08:31:18.000000000 +0300
++++ doc/CMakeLists.txt 2008-06-30 08:31:40.000000000 +0300
+@@ -3,7 +3,7 @@
+ INSTALL(FILES fulla.html DESTINATION doc)
+ INSTALL(FILES nona.txt DESTINATION doc)
+ ELSE (WIN32)
+-INSTALL(FILES fulla.1 DESTINATION share/man/man1)
++INSTALL(FILES fulla.1 DESTINATION ${MANDIR}/man1)
+ INSTALL(FILES nona.txt DESTINATION share/hugin)
+ ENDIF(WIN32)
+
diff --git a/graphics/hugin/files/patch-m4_ax_boost.m4 b/graphics/hugin/files/patch-m4_ax_boost.m4
deleted file mode 100644
index c69674823fa2..000000000000
--- a/graphics/hugin/files/patch-m4_ax_boost.m4
+++ /dev/null
@@ -1,20 +0,0 @@
---- m4/ax_boost.m4.orig 2006-11-30 09:36:48.000000000 +0200
-+++ m4/ax_boost.m4 2007-12-12 18:39:43.000000000 +0200
-@@ -97,7 +97,7 @@
- dnl this location ist chosen if boost libraries are installed with the --layout=system option
- dnl or if you install boost with RPM
- if test "$ac_boost_path" != ""; then
-- BOOST_LDFLAGS="-L$ac_boost_path/lib"
-+ BOOST_LDFLAGS="-L$ac_boost_path/lib $PTHREAD_LIBS"
- BOOST_CPPFLAGS="-I$ac_boost_path/include"
- else
- for ac_boost_path_tmp in /usr /usr/local /opt ; do
-@@ -331,7 +331,7 @@
- for BT in "-mt" ""; do
- for BL in "" "-s" ; do
- ax_lib=$BP$BN$BC$BT$BL$BV;
-- AC_CHECK_LIB($ax_lib, main, [BOOST_THREAD_LIB="-l$ax_lib" AC_SUBST(BOOST_THREAD_LIB) link_thread="yes"
-+ AC_CHECK_LIB($ax_lib, main, [BOOST_THREAD_LIB="-l$ax_lib $BOOST_LDFLAGS" AC_SUBST(BOOST_THREAD_LIB) link_thread="yes"
- break 5],
- [link_thread="no"])
- done
diff --git a/graphics/hugin/files/patch-m4_ax_check_graphics.m4 b/graphics/hugin/files/patch-m4_ax_check_graphics.m4
deleted file mode 100644
index 206c6a3f6676..000000000000
--- a/graphics/hugin/files/patch-m4_ax_check_graphics.m4
+++ /dev/null
@@ -1,74 +0,0 @@
---- m4/ax_check_graphics.m4.orig Wed Jan 17 15:23:15 2007
-+++ m4/ax_check_graphics.m4 Wed Jan 17 15:27:55 2007
-@@ -44,7 +44,7 @@
- ZLIB_OLD_LDFLAGS=$LDFLAGS
- ZLIB_OLD_CPPFLAGS=$CPPFLAGS
- if test "x$ZLIB_HOME" != 'x' ; then
-- if test "x$HCPU" = 'xamd64' ; then
-+ if test "x$HCPU" = 'xamd64' -a "x$HSYS" != 'xfreebsd' ; then
- LDFLAGS="$LDFLAGS -L$ZLIB_HOME/lib64"
- else
- LDFLAGS="$LDFLAGS -L$ZLIB_HOME/lib"
-@@ -69,7 +69,7 @@
- LIB_ZLIB="-lz"
- ZLIB_FLAGS="-DHasZLIB"
- else
-- if test "x$HCPU" = 'xamd64' ; then
-+ if test "x$HCPU" = 'xamd64' -a "x$HSYS" != 'xfreebsd' ; then
- LIB_ZLIB="-L$ZLIB_HOME/lib64 -lz"
- else
- LIB_ZLIB="-L$ZLIB_HOME/lib -lz"
-@@ -133,7 +133,7 @@
- PNG_OLD_LDFLAGS=$LDFLAGS
- PNG_OLD_CPPFLAGS=$CPPFLAGS
- if test "x$PNG_HOME" != 'x' ; then
-- if test "x$HCPU" = 'xamd64' ; then
-+ if test "x$HCPU" = 'xamd64' -a "x$HSYS" != 'xfreebsd' ; then
- LDFLAGS="$LDFLAGS -L$PNG_HOME/lib64"
- else
- LDFLAGS="$LDFLAGS -L$PNG_HOME/lib"
-@@ -158,7 +158,7 @@
- LIB_PNG="-lpng"
- PNG_FLAGS="-DHasPNG"
- else
-- if test "x$HCPU" = 'xamd64' ; then
-+ if test "x$HCPU" = 'xamd64' -a "x$HSYS" != 'xfreebsd' ; then
- LIB_PNG="-L$PNG_HOME/lib64 -lpng"
- else
- LIB_PNG="-L$PNG_HOME/lib -lpng"
-@@ -224,7 +224,7 @@
- JPEG_OLD_LDFLAGS=$LDFLAGS
- JPEG_OLD_CPPFLAGS=$CPPFLAGS
- if test "x$JPEG_HOME" != 'x' ; then
-- if test "x$HCPU" = 'xamd64' ; then
-+ if test "x$HCPU" = 'xamd64' -a "x$HSYS" != 'xfreebsd' ; then
- LDFLAGS="$LDFLAGS -L$JPEG_HOME/lib64"
- else
- LDFLAGS="$LDFLAGS -L$JPEG_HOME/lib"
-@@ -274,7 +274,7 @@
- LIB_JPEG="-ljpeg"
- JPEG_FLAGS="-DHasJPEG"
- else
-- if test "x$HCPU" = 'xamd64' ; then
-+ if test "x$HCPU" = 'xamd64' -a "x$HSYS" != 'xfreebsd' ; then
- LIB_JPEG="-L$JPEG_HOME/lib64 -ljpeg"
- else
- LIB_JPEG="-L$JPEG_HOME/lib -ljpeg"
-@@ -339,7 +339,7 @@
- TIFF_OLD_LDFLAGS=$LDFLAGS
- TIFF_OLD_CPPFLAGS=$CPPFLAGS
- if test "x$TIFF_HOME" != 'x' ; then
-- if test "x$HCPU" = 'xamd64' ; then
-+ if test "x$HCPU" = 'xamd64' -a "x$HSYS" != 'xfreebsd' ; then
- LDFLAGS="$LDFLAGS -L$TIFF_HOME/lib64"
- else
- LDFLAGS="$LDFLAGS -L$TIFF_HOME/lib"
-@@ -364,7 +364,7 @@
- LIB_TIFF="-ltiff"
- TIFF_FLAGS="-DHasTIFF"
- else
-- if test "x$HCPU" = 'xamd64' ; then
-+ if test "x$HCPU" = 'xamd64' -a "x$HSYS" != 'xfreebsd' ; then
- LIB_TIFF="-L$TIFF_HOME/lib64 -ltiff"
- else
- LIB_TIFF="-L$TIFF_HOME/lib -ltiff"
diff --git a/graphics/hugin/files/patch-m4_ax_check_panotools.m4 b/graphics/hugin/files/patch-m4_ax_check_panotools.m4
deleted file mode 100644
index 280956d3740a..000000000000
--- a/graphics/hugin/files/patch-m4_ax_check_panotools.m4
+++ /dev/null
@@ -1,20 +0,0 @@
---- m4/ax_check_panotools.m4.orig Wed Dec 20 21:41:29 2006
-+++ m4/ax_check_panotools.m4 Wed May 2 21:54:25 2007
-@@ -57,7 +57,7 @@
- passed=0;
- PANO_OLD_LDFLAGS=$LDFLAGS
- PANO_OLD_CPPFLAGS=$CPPFLAGS
-- if test "x$HCPU" = 'xamd64' ; then
-+ if test "x$HCPU" = 'xamd64' -a "x$HSYS" != 'xfreebsd' ; then
- LDFLAGS="$LDFLAGS -L$PANO_HOME/lib64"
- else
- LDFLAGS="$LDFLAGS -L$PANO_HOME/lib"
-@@ -95,7 +95,7 @@
- PANO_FLAGS="-DHasPANO12"
- fi
- else
-- if test "x$HCPU" = 'xamd64' ; then
-+ if test "x$HCPU" = 'xamd64' -a "x$HSYS" != 'xfreebsd' ; then
- if test "$have_pano13" = 'yes' ; then
- LIB_PANO="-L$PANO_HOME/lib64 -lpano13"
- else
diff --git a/graphics/hugin/files/patch-src-common-utils.cpp b/graphics/hugin/files/patch-src-common-utils.cpp
deleted file mode 100644
index 9dddd7b41572..000000000000
--- a/graphics/hugin/files/patch-src-common-utils.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/common/utils.cpp.orig Mon Jan 17 07:29:39 2005
-+++ src/common/utils.cpp Thu Aug 11 20:28:47 2005
-@@ -37,8 +37,10 @@
- char tmp[100];
- struct tm t;
- struct timeval tv;
-+ time_t _clock;
- gettimeofday(&tv,NULL);
-- localtime_r(&tv.tv_sec, &t);
-+ _clock = tv.tv_sec;
-+ localtime_r(&_clock, &t);
- strftime(tmp,99,"%H:%M:%S",&t);
- sprintf(tmp+8,".%06ld",tv.tv_usec);
- return tmp;
diff --git a/graphics/hugin/files/patch-src-hugin-ImagesPanel.cpp b/graphics/hugin/files/patch-src-hugin-ImagesPanel.cpp
deleted file mode 100644
index be910b25f420..000000000000
--- a/graphics/hugin/files/patch-src-hugin-ImagesPanel.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/hugin/ImagesPanel.cpp.orig Thu Aug 11 20:18:49 2005
-+++ src/hugin/ImagesPanel.cpp Thu Aug 11 20:20:24 2005
-@@ -448,9 +448,9 @@
- for (UIntSet::const_iterator it = selImg.begin();
- it != selImg.end(); ++it )
- {
-- vars[i].insert(make_pair("y", Variable("y",0.0)));
-- vars[i].insert(make_pair("p", Variable("p",0.0)));
-- vars[i].insert(make_pair("r", Variable("r",0.0)));
-+ vars[i].insert(make_pair((char *) "y", Variable("y",0.0)));
-+ vars[i].insert(make_pair((char *) "p", Variable("p",0.0)));
-+ vars[i].insert(make_pair((char *) "r", Variable("r",0.0)));
- i++;
- }
- GlobalCmdHist::getInstance().addCommand(
diff --git a/graphics/hugin/files/patch-src-hugin-Makefile.in b/graphics/hugin/files/patch-src-hugin-Makefile.in
deleted file mode 100644
index 271dc85c4e85..000000000000
--- a/graphics/hugin/files/patch-src-hugin-Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/hugin/Makefile.in.marco Sun Dec 18 23:26:42 2005
-+++ src/hugin/Makefile.in Sun Dec 18 23:27:30 2005
-@@ -754,7 +754,6 @@
- install-data-am: install-desktopDATA install-gnomemimeiconDATA \
- install-sharedmimepackageDATA
- @$(NORMAL_INSTALL)
-- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
-
- install-exec-am: install-binPROGRAMS
-
diff --git a/graphics/hugin/files/patch-src-include-common-utils.h b/graphics/hugin/files/patch-src-include-common-utils.h
deleted file mode 100644
index 17d99366f2f7..000000000000
--- a/graphics/hugin/files/patch-src-include-common-utils.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/include/common/utils.h.orig Mon Jan 17 07:29:40 2005
-+++ src/include/common/utils.h Thu Aug 11 20:24:45 2005
-@@ -30,6 +30,9 @@
- #include <sstream>
- #include <cassert>
-
-+#include <locale.h>
-+#include <stdio.h>
-+
- #include "platform.h"
-
- #ifdef __WXMSW__
diff --git a/graphics/hugin/files/patch-src-include-panoinc.h b/graphics/hugin/files/patch-src-include-panoinc.h
deleted file mode 100644
index bfb9142c7162..000000000000
--- a/graphics/hugin/files/patch-src-include-panoinc.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/include/panoinc.h.orig Wed Mar 2 23:04:45 2005
-+++ src/include/panoinc.h Wed Mar 2 23:05:09 2005
-@@ -32,6 +32,8 @@
- #ifdef __unix__
- #include <sys/time.h>
- #include <sys/resource.h>
-+#include <sys/types.h>
-+#include <sys/wait.h>
- #endif
-
- #include <vector>
diff --git a/graphics/hugin/files/patch-src_include_hugin_config_defaults.h b/graphics/hugin/files/patch-src_hugin1_hugin_config_defaults.h
index 0894a0886f2f..2487cd3d153a 100644
--- a/graphics/hugin/files/patch-src_include_hugin_config_defaults.h
+++ b/graphics/hugin/files/patch-src_hugin1_hugin_config_defaults.h
@@ -1,11 +1,11 @@
---- src/include/hugin/config_defaults.h.orig 2008-06-15 18:26:33.000000000 +0300
-+++ src/include/hugin/config_defaults.h 2008-06-15 18:27:33.000000000 +0300
-@@ -150,8 +150,8 @@
+--- src/hugin1/hugin/config_defaults.h.orig 2008-06-20 17:21:28.000000000 +0300
++++ src/hugin1/hugin/config_defaults.h 2008-06-20 17:22:40.000000000 +0300
+@@ -160,8 +160,8 @@
#define HUGIN_APKOLOR_EXE ""
#define HUGIN_APKOLOR_ARGS ""
--#define HUGIN_APSIFT_EXE "autopano-complete.sh"
--#define HUGIN_APSIFT_ARGS "--output %o --points %p %i"
+-#define HUGIN_APSIFT_EXE "autopano-sift-c"
+-#define HUGIN_APSIFT_ARGS "--maxmatches %p %o %i"
+#define HUGIN_APSIFT_EXE "autopano-complete"
+#define HUGIN_APSIFT_ARGS "-o %o -p %p %i"
#define HUGIN_STITCHER_RUN_EDITOR 0l
diff --git a/graphics/hugin/files/patch-src_hugin_xrc_Makefile.am b/graphics/hugin/files/patch-src_hugin_xrc_Makefile.am
deleted file mode 100644
index dc9fd15bf0a5..000000000000
--- a/graphics/hugin/files/patch-src_hugin_xrc_Makefile.am
+++ /dev/null
@@ -1,8 +0,0 @@
---- src/hugin/xrc/Makefile.am.orig Tue Jan 23 15:13:43 2007
-+++ src/hugin/xrc/Makefile.am Tue Jan 23 15:52:04 2007
-@@ -42,4 +42,4 @@
- dist_xrc_DATA = $(XRC_FILES)
-
- .xrc.xrs:
-- -wxrc -g -o $(srcdir)/$@ $<
-+ -$(WXRC) -g -o $(srcdir)/$@ $<
diff --git a/graphics/hugin/pkg-plist b/graphics/hugin/pkg-plist
index 4a3988b3ea54..3c318d0034cd 100644
--- a/graphics/hugin/pkg-plist
+++ b/graphics/hugin/pkg-plist
@@ -1,19 +1,33 @@
+bin/align_image_stack
bin/autooptimiser
-bin/color_correct_tiff
bin/fulla
bin/hugin
+bin/hugin_hdrmerge
+bin/hugin_stitch_project
+bin/matchpoint
bin/nona
bin/nona_gui
-bin/zhang_undistort
+bin/tca_correct
+bin/vig_optimize
+lib/libhuginANN.so
+lib/libhuginANN.so.0.0
+lib/libhuginbase.so
+lib/libhuginbase.so.0.0
+lib/libhuginjhead.so
+lib/libhuginjhead.so.0.0
+lib/libhuginvigraimpex.so
+lib/libhuginvigraimpex.so.0.0
+share/applications/hugin.desktop
+share/applications/hugin_stitch_project.desktop
+%%DATADIR%%/nona.txt
%%DATADIR%%/xrc/about.xrc
-%%DATADIR%%/xrc/anchor_orientation.xrc
%%DATADIR%%/xrc/assistant_panel.xrc
-%%DATADIR%%/xrc/cp_editor_panel-2.5.xrc
%%DATADIR%%/xrc/cp_editor_panel.xrc
%%DATADIR%%/xrc/cp_list_frame.xrc
%%DATADIR%%/xrc/crop_panel.xrc
%%DATADIR%%/xrc/data/1leftarrow.png
%%DATADIR%%/xrc/data/1rightarrow.png
+%%DATADIR%%/xrc/data/CMakeLists.txt
%%DATADIR%%/xrc/data/CPCursor0.png
%%DATADIR%%/xrc/data/CPCursor1.png
%%DATADIR%%/xrc/data/CPCursor2.png
@@ -22,8 +36,6 @@ bin/zhang_undistort
%%DATADIR%%/xrc/data/CPCursor5.png
%%DATADIR%%/xrc/data/CPCursor6.png
%%DATADIR%%/xrc/data/about.htm
-%%DATADIR%%/xrc/data/about_fr.htm
-%%DATADIR%%/xrc/data/about_pl.htm
%%DATADIR%%/xrc/data/center_pano.xpm
%%DATADIR%%/xrc/data/close.xpm
%%DATADIR%%/xrc/data/druid.control.128.png
@@ -42,25 +54,124 @@ bin/zhang_undistort
%%DATADIR%%/xrc/data/filesaveas.png
%%DATADIR%%/xrc/data/find.png
%%DATADIR%%/xrc/data/fit_pano.xpm
-%%DATADIR%%/xrc/data/help_common/horiz-guide.jpg
-%%DATADIR%%/xrc/data/help_common/hugin.png
-%%DATADIR%%/xrc/data/help_common/problem-circle.jpg
-%%DATADIR%%/xrc/data/help_en_EN/FAQ.html
-%%DATADIR%%/xrc/data/help_en_EN/contents.html
+%%DATADIR%%/xrc/data/help_en_EN/16bit_workflow_with_hugin.html
+%%DATADIR%%/xrc/data/help_en_EN/Aliasing.html
+%%DATADIR%%/xrc/data/help_en_EN/Align_a_stack_of_photos.html
+%%DATADIR%%/xrc/data/help_en_EN/Align_image_stack.html
+%%DATADIR%%/xrc/data/help_en_EN/Alpha_channel.html
+%%DATADIR%%/xrc/data/help_en_EN/Aspect_Ratio.html
+%%DATADIR%%/xrc/data/help_en_EN/Autooptimiser.html
+%%DATADIR%%/xrc/data/help_en_EN/Autopano-sift-C.html
+%%DATADIR%%/xrc/data/help_en_EN/Autopano-sift.html
+%%DATADIR%%/xrc/data/help_en_EN/Autopano.html
+%%DATADIR%%/xrc/data/help_en_EN/Banding.html
+%%DATADIR%%/xrc/data/help_en_EN/Barrel_distortion.html
+%%DATADIR%%/xrc/data/help_en_EN/Bracketing.html
+%%DATADIR%%/xrc/data/help_en_EN/CCD.html
+%%DATADIR%%/xrc/data/help_en_EN/CMakeLists.txt
+%%DATADIR%%/xrc/data/help_en_EN/Camera_response_curve.html
+%%DATADIR%%/xrc/data/help_en_EN/Chromatic_aberration.html
+%%DATADIR%%/xrc/data/help_en_EN/Color_correct_tiff.html
+%%DATADIR%%/xrc/data/help_en_EN/Colour_profile.html
+%%DATADIR%%/xrc/data/help_en_EN/Control_points.html
+%%DATADIR%%/xrc/data/help_en_EN/Crop_factor.html
+%%DATADIR%%/xrc/data/help_en_EN/Cropped_TIFF.html
+%%DATADIR%%/xrc/data/help_en_EN/Cubic.html
+%%DATADIR%%/xrc/data/help_en_EN/Cubic_Projection.html
+%%DATADIR%%/xrc/data/help_en_EN/Cylindrical.html
+%%DATADIR%%/xrc/data/help_en_EN/Cylindrical_Projection.html
+%%DATADIR%%/xrc/data/help_en_EN/Cylindrical_panorama.html
+%%DATADIR%%/xrc/data/help_en_EN/Depth_of_Field.html
+%%DATADIR%%/xrc/data/help_en_EN/Dust_Removal_with_Flatfield.html
+%%DATADIR%%/xrc/data/help_en_EN/Dynamic_range.html
+%%DATADIR%%/xrc/data/help_en_EN/EXIF.html
+%%DATADIR%%/xrc/data/help_en_EN/Enblend.html
+%%DATADIR%%/xrc/data/help_en_EN/Enfuse.html
+%%DATADIR%%/xrc/data/help_en_EN/Entrance_pupil.html
+%%DATADIR%%/xrc/data/help_en_EN/Equirectangular.html
+%%DATADIR%%/xrc/data/help_en_EN/Equirectangular_Projection.html
+%%DATADIR%%/xrc/data/help_en_EN/Field_of_View.html
+%%DATADIR%%/xrc/data/help_en_EN/Fisheye_Projection.html
+%%DATADIR%%/xrc/data/help_en_EN/Focal_Length.html
+%%DATADIR%%/xrc/data/help_en_EN/Freepv.html
+%%DATADIR%%/xrc/data/help_en_EN/Fulla.html
+%%DATADIR%%/xrc/data/help_en_EN/GIF.html
+%%DATADIR%%/xrc/data/help_en_EN/Gamma.html
+%%DATADIR%%/xrc/data/help_en_EN/HDR.html
+%%DATADIR%%/xrc/data/help_en_EN/HDR_workflow_with_hugin.html
+%%DATADIR%%/xrc/data/help_en_EN/Horizontal_control_points.html
+%%DATADIR%%/xrc/data/help_en_EN/Hugin.html
+%%DATADIR%%/xrc/data/help_en_EN/Hugin_Assistant_tab.html
+%%DATADIR%%/xrc/data/help_en_EN/Hugin_Camera_and_Lens_tab.html
+%%DATADIR%%/xrc/data/help_en_EN/Hugin_Control_Points_tab.html
+%%DATADIR%%/xrc/data/help_en_EN/Hugin_Control_Points_table.html
+%%DATADIR%%/xrc/data/help_en_EN/Hugin_Crop_tab.html
+%%DATADIR%%/xrc/data/help_en_EN/Hugin_Exposure_tab.html
+%%DATADIR%%/xrc/data/help_en_EN/Hugin_FAQ.html
+%%DATADIR%%/xrc/data/help_en_EN/Hugin_Images_tab.html
+%%DATADIR%%/xrc/data/help_en_EN/Hugin_Keyboard_shortcuts.html
+%%DATADIR%%/xrc/data/help_en_EN/Hugin_Main_window.html
+%%DATADIR%%/xrc/data/help_en_EN/Hugin_Optimizer_tab.html
+%%DATADIR%%/xrc/data/help_en_EN/Hugin_Preferences.html
+%%DATADIR%%/xrc/data/help_en_EN/Hugin_Preview_window.html
+%%DATADIR%%/xrc/data/help_en_EN/Hugin_Stitcher_tab.html
+%%DATADIR%%/xrc/data/help_en_EN/Interpolation.html
+%%DATADIR%%/xrc/data/help_en_EN/JPEG.html
+%%DATADIR%%/xrc/data/help_en_EN/LICENCE.manual
+%%DATADIR%%/xrc/data/help_en_EN/Landscape.html
+%%DATADIR%%/xrc/data/help_en_EN/Lens_correction_model.html
+%%DATADIR%%/xrc/data/help_en_EN/Lens_distortion.html
+%%DATADIR%%/xrc/data/help_en_EN/MatchPoint.html
+%%DATADIR%%/xrc/data/help_en_EN/NPP.html
+%%DATADIR%%/xrc/data/help_en_EN/Nadir.html
+%%DATADIR%%/xrc/data/help_en_EN/No-parallax_point.html
+%%DATADIR%%/xrc/data/help_en_EN/Nodal_Point.html
+%%DATADIR%%/xrc/data/help_en_EN/Nona.html
+%%DATADIR%%/xrc/data/help_en_EN/Nona_gui.html
+%%DATADIR%%/xrc/data/help_en_EN/OpenEXR.html
+%%DATADIR%%/xrc/data/help_en_EN/PNG.html
+%%DATADIR%%/xrc/data/help_en_EN/PPI.html
+%%DATADIR%%/xrc/data/help_en_EN/PSD.html
+%%DATADIR%%/xrc/data/help_en_EN/PTOptimizer.html
+%%DATADIR%%/xrc/data/help_en_EN/PTStitcher.html
+%%DATADIR%%/xrc/data/help_en_EN/PTblender.html
+%%DATADIR%%/xrc/data/help_en_EN/PTmender.html
+%%DATADIR%%/xrc/data/help_en_EN/PTtiff2psd.html
+%%DATADIR%%/xrc/data/help_en_EN/Pano12.html
+%%DATADIR%%/xrc/data/help_en_EN/Panoglview.html
+%%DATADIR%%/xrc/data/help_en_EN/Panoinfo.html
+%%DATADIR%%/xrc/data/help_en_EN/Panomatic.html
+%%DATADIR%%/xrc/data/help_en_EN/Panorama.html
+%%DATADIR%%/xrc/data/help_en_EN/Panorama_formats.html
+%%DATADIR%%/xrc/data/help_en_EN/Panorama_tools.html
+%%DATADIR%%/xrc/data/help_en_EN/Panotools.html
+%%DATADIR%%/xrc/data/help_en_EN/Parallax.html
+%%DATADIR%%/xrc/data/help_en_EN/Perspective_correction.html
+%%DATADIR%%/xrc/data/help_en_EN/Perspective_distortion.html
+%%DATADIR%%/xrc/data/help_en_EN/Pincushion_distortion.html
+%%DATADIR%%/xrc/data/help_en_EN/Pitch.html
+%%DATADIR%%/xrc/data/help_en_EN/Portrait.html
+%%DATADIR%%/xrc/data/help_en_EN/Projections.html
+%%DATADIR%%/xrc/data/help_en_EN/QTVR.html
+%%DATADIR%%/xrc/data/help_en_EN/RAW.html
+%%DATADIR%%/xrc/data/help_en_EN/RGBE.html
+%%DATADIR%%/xrc/data/help_en_EN/Rectilinear_Projection.html
+%%DATADIR%%/xrc/data/help_en_EN/Roll.html
+%%DATADIR%%/xrc/data/help_en_EN/Spherical.html
+%%DATADIR%%/xrc/data/help_en_EN/Stereographic_Projection.html
+%%DATADIR%%/xrc/data/help_en_EN/Straight_line_control_points.html
+%%DATADIR%%/xrc/data/help_en_EN/TIFF.html
+%%DATADIR%%/xrc/data/help_en_EN/Tone_mapping.html
+%%DATADIR%%/xrc/data/help_en_EN/Vertical_control_points.html
+%%DATADIR%%/xrc/data/help_en_EN/Vignetting.html
+%%DATADIR%%/xrc/data/help_en_EN/Wavy_distortion.html
+%%DATADIR%%/xrc/data/help_en_EN/Yaw.html
+%%DATADIR%%/xrc/data/help_en_EN/Zenith.html
%%DATADIR%%/xrc/data/help_en_EN/hugin.hhc
%%DATADIR%%/xrc/data/help_en_EN/hugin.hhk
%%DATADIR%%/xrc/data/help_en_EN/hugin.hhp
-%%DATADIR%%/xrc/data/help_en_EN/keyboard.html
%%DATADIR%%/xrc/data/help_en_EN/license.html
-%%DATADIR%%/xrc/data/help_en_EN/manual.html
-%%DATADIR%%/xrc/data/help_fr_FR/FAQ.html
-%%DATADIR%%/xrc/data/help_fr_FR/contents.html
-%%DATADIR%%/xrc/data/help_fr_FR/hugin.hhc
-%%DATADIR%%/xrc/data/help_fr_FR/hugin.hhk
-%%DATADIR%%/xrc/data/help_fr_FR/hugin.hhp
-%%DATADIR%%/xrc/data/help_fr_FR/keyboard.html
-%%DATADIR%%/xrc/data/help_fr_FR/license.html
-%%DATADIR%%/xrc/data/help_fr_FR/manual.html
+%%DATADIR%%/xrc/data/help_en_EN/pages.txt
%%DATADIR%%/xrc/data/hugin.png
%%DATADIR%%/xrc/data/icon.ico
%%DATADIR%%/xrc/data/icon.png
@@ -104,28 +215,38 @@ bin/zhang_undistort
%%DATADIR%%/xrc/edit_text.xrc
%%DATADIR%%/xrc/help.xrc
%%DATADIR%%/xrc/images_panel.xrc
-%%DATADIR%%/xrc/images_panel-2.5.xrc
%%DATADIR%%/xrc/keyboard_help.xrc
%%DATADIR%%/xrc/lens_panel.xrc
-%%DATADIR%%/xrc/lens_panel-2.5.xrc
%%DATADIR%%/xrc/main_frame.xrc
-%%DATADIR%%/xrc/main_frame-2.5.xrc
%%DATADIR%%/xrc/main_menu.xrc
-%%DATADIR%%/xrc/main_menubar.xrc
%%DATADIR%%/xrc/main_tool.xrc
-%%DATADIR%%/xrc/nona_panel.xrc
%%DATADIR%%/xrc/optimize_panel.xrc
-%%DATADIR%%/xrc/optimize_panel-2.5.xrc
+%%DATADIR%%/xrc/optimize_photo_panel.xrc
%%DATADIR%%/xrc/pano_panel.xrc
-%%DATADIR%%/xrc/pano_panel-2.5.xrc
%%DATADIR%%/xrc/pref_dialog.xrc
%%DATADIR%%/xrc/preview_frame.xrc
-%%DATADIR%%/xrc/ptstitcher_panel.xrc
%%DATADIR%%/xrc/run_optimizer_frame.xrc
%%DATADIR%%/xrc/run_stitcher_frame.xrc
%%DATADIR%%/xrc/vig_corr_dlg.xrc
-share/applications/hugin.desktop
share/icons/gnome/48x48/mimetypes/gnome-mime-application-x-ptoptimizer-script.png
+share/locale/ca_ES/LC_MESSAGES/hugin.mo
+share/locale/cs_CZ/LC_MESSAGES/hugin.mo
+share/locale/de/LC_MESSAGES/hugin.mo
+share/locale/en_GB/LC_MESSAGES/hugin.mo
+share/locale/es/LC_MESSAGES/hugin.mo
+share/locale/fr/LC_MESSAGES/hugin.mo
+share/locale/hu/LC_MESSAGES/hugin.mo
+share/locale/it/LC_MESSAGES/hugin.mo
+share/locale/ja/LC_MESSAGES/hugin.mo
+share/locale/ko/LC_MESSAGES/hugin.mo
+share/locale/nl/LC_MESSAGES/hugin.mo
+share/locale/pl/LC_MESSAGES/hugin.mo
+share/locale/pt_BR/LC_MESSAGES/hugin.mo
+share/locale/ru/LC_MESSAGES/hugin.mo
+share/locale/sk/LC_MESSAGES/hugin.mo
+share/locale/sv/LC_MESSAGES/hugin.mo
+share/locale/uk/LC_MESSAGES/hugin.mo
+share/locale/zh_CN/LC_MESSAGES/hugin.mo
share/mime/packages/hugin.xml
share/pixmaps/hugin.png
@dirrmtry share/applications
@@ -133,15 +254,13 @@ share/pixmaps/hugin.png
@dirrmtry share/icons/gnome/48x48
@dirrmtry share/icons/gnome
@dirrmtry share/icons
-%%NLS%%@dirrmtry share/locale/ca_ES/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/ca_ES
-%%NLS%%@dirrmtry share/locale/cs_CZ/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/cs_CZ
+@dirrmtry share/locale/ca_ES/LC_MESSAGES
+@dirrmtry share/locale/ca_ES
+@dirrmtry share/locale/cs_CZ/LC_MESSAGES
+@dirrmtry share/locale/cs_CZ
@dirrmtry share/mime/packages
@dirrmtry share/mime
-@dirrm %%DATADIR%%/xrc/data/help_common
@dirrm %%DATADIR%%/xrc/data/help_en_EN
-@dirrm %%DATADIR%%/xrc/data/help_fr_FR
@dirrm %%DATADIR%%/xrc/data
@dirrm %%DATADIR%%/xrc
@dirrm %%DATADIR%%