aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-09-16 11:35:29 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-09-16 11:35:29 +0000
commit61bf55271ccf55a08ffffbf61fc3ee4369cdc2a3 (patch)
tree718959fa90285314758ccdf7cf0a7b5a5c4e7de6
parent6fc6338880304d7c0cc5183d87fa7363eee50083 (diff)
downloadports-61bf55271ccf55a08ffffbf61fc3ee4369cdc2a3.tar.gz
ports-61bf55271ccf55a08ffffbf61fc3ee4369cdc2a3.zip
MFH: r512100
net-im/py-unmessage: Add missing dependencies unmessage currently fails at runtime with the following errors: 1) pkg_resources.DistributionNotFound: The 'service_identity' distribution was not found and is required by Twisted unmessage depends on Twisted *and* its "tls" optional (extras_require) dependencies, requiring unmessage to depend directly on them: - openssl - service_identity - idna 2) ImportError: No module named _sqlite3 (fixed by ports r512099) 3) File "/usr/local/lib/python2.7/site-packages/unmessage/gui.py", line 5, in <module> import Tkinter as Tk Add dependency on x11-toolkits/py-tkinter accordingly While I'm here: Pet portlint: extra item in USES/USE_x section: "NO_ARCH". [1] setup.py: install_requires: 'Twisted[tls]>=16.6.0', Reported by: DanDare (via IRC) Approved by: portmgr (blanket(s): missing dependencies, ports compliance) Approved by: ports-secteam (blanket(s): dependency fix, run-time bugfix)
Notes
Notes: svn path=/branches/2019Q3/; revision=512171
-rw-r--r--net-im/py-unmessage/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-im/py-unmessage/Makefile b/net-im/py-unmessage/Makefile
index 0f7b0bb13baa..688384be9fb0 100644
--- a/net-im/py-unmessage/Makefile
+++ b/net-im/py-unmessage/Makefile
@@ -3,6 +3,7 @@
PORTNAME= unmessage
PORTVERSION= 0.2.0
+PORTREVISION= 1
CATEGORIES= net-im net-p2p python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,10 +21,16 @@ RUN_DEPENDS= tor:security/tor \
${PYTHON_PKGNAMEPREFIX}pynacl>=1.0.1:security/py-pynacl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyperclip>=1.5.27:devel/py-pyperclip@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=16.6.0:devel/py-twisted@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}txtorcon>=0.19.0:security/py-txtorcon@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}txtorcon>=0.19.0:security/py-txtorcon@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
+# Twisted[tls]
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}openssl>=16.0.0:security/py-openssl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}service_identity>0:security/py-service_identity@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}idna>=0.6:dns/py-idna@${PY_FLAVOR}
USES= python:2.7
USE_PYTHON= distutils autoplist
+
NO_ARCH= yes
.include <bsd.port.mk>