aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2012-08-07 14:32:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2012-08-07 14:32:04 +0000
commit6768826d8902fc6e4a5f4b0b5068bf8819edf317 (patch)
treec1e82fa266ee0ad0316a6d4f4ad4ffe7d828f2bc
parent45c44b7a6d0841c5e02919868ee70f67535ad0d0 (diff)
downloadports-6768826d8902fc6e4a5f4b0b5068bf8819edf317.tar.gz
ports-6768826d8902fc6e4a5f4b0b5068bf8819edf317.zip
Notes
-rw-r--r--multimedia/gstreamer-plugins-ugly/files/patch-ext-amr40
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common2
2 files changed, 42 insertions, 0 deletions
diff --git a/multimedia/gstreamer-plugins-ugly/files/patch-ext-amr b/multimedia/gstreamer-plugins-ugly/files/patch-ext-amr
new file mode 100644
index 000000000000..67c8fa7ca414
--- /dev/null
+++ b/multimedia/gstreamer-plugins-ugly/files/patch-ext-amr
@@ -0,0 +1,40 @@
+--- ext/amrnb/amrnbdec.h.orig 2011-12-30 18:40:45.000000000 +0100
++++ ext/amrnb/amrnbdec.h 2012-08-07 16:21:06.000000000 +0200
+@@ -22,7 +22,8 @@
+
+ #include <gst/gst.h>
+ #include <gst/audio/gstaudiodecoder.h>
+-#include <interf_dec.h>
++
++#include <opencore-amrnb/interf_dec.h>
+
+ G_BEGIN_DECLS
+
+--- ext/amrnb/amrnbenc.h.orig 2011-12-30 18:40:45.000000000 +0100
++++ ext/amrnb/amrnbenc.h 2012-08-07 16:19:26.000000000 +0200
+@@ -21,9 +21,10 @@
+ #define __GST_AMRNBENC_H__
+
+ #include <gst/gst.h>
+-#include <interf_enc.h>
+ #include <gst/audio/gstaudioencoder.h>
+
++#include <opencore-amrnb/interf_enc.h>
++
+ G_BEGIN_DECLS
+
+ #define GST_TYPE_AMRNBENC \
+--- ext/amrwbdec/amrwbdec.h.orig 2011-12-30 18:40:45.000000000 +0100
++++ ext/amrwbdec/amrwbdec.h 2012-08-07 16:19:05.000000000 +0200
+@@ -22,8 +22,9 @@
+
+ #include <gst/gst.h>
+ #include <gst/audio/gstaudiodecoder.h>
+-#include <dec_if.h>
+-#include <if_rom.h>
++
++#include <opencore-amrwb/dec_if.h>
++#include <opencore-amrwb/if_rom.h>
+
+ G_BEGIN_DECLS
+
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index 08f65ed46fc3..2ad36bc017ac 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -180,6 +180,7 @@ gst_aalib_PLIST_FILES= ${GST_LIB_DIR}/libgstaasink.so \
${GST_LIB_DIR}/libgstaasink.la
# amrnb
+gst_amrnb_BUILD_DEPENDS+=opencore-amr>=0.1.3:${PORTSDIR}/audio/opencore.amr
gst_amrnb_LIB_DEPENDS+= opencore-amrnb.0:${PORTSDIR}/audio/opencore-amr
gst_amrnb_PLIST_FILES= ${GST_LIB_DIR}/libgstamrnb.la \
${GST_LIB_DIR}/libgstamrnb.so \
@@ -189,6 +190,7 @@ gst_amrnb_PLIST_DIRSTRY=share/gstreamer-${VERSION}/presets \
gst_amrnb_DIST= ugly
# amrwbdec
+gst_amrwbdec_BUILD_DEPENDS+= opencore-amr>=0.1.3:${PORTSDIR}/audio/opencore.amr
gst_amrwbdec_LIB_DEPENDS+= opencore-amrwb.0:${PORTSDIR}/audio/opencore-amr
gst_amrwbdec_CONFIGURE_ARGS+= --enable-amrwb
gst_amrwbdec_PLIST_FILES= ${GST_LIB_DIR}/libgstamrwbdec.la \