aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-03-15 11:56:56 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-03-15 11:56:56 +0000
commit7ef024431aa7a8fc78b36a7160892c5bbdc3443d (patch)
treeab49b1faaaa6eebef518ac55c2516653d929ec8d
parent30a239d95e6d8883a382041678dec016a5b25577 (diff)
downloadports-7ef024431aa7a8fc78b36a7160892c5bbdc3443d.tar.gz
ports-7ef024431aa7a8fc78b36a7160892c5bbdc3443d.zip
Notes
-rw-r--r--devel/pure-ffi/Makefile10
-rw-r--r--devel/pure-ffi/pkg-descr2
2 files changed, 7 insertions, 5 deletions
diff --git a/devel/pure-ffi/Makefile b/devel/pure-ffi/Makefile
index c3a35fab2722..8d8525e714cf 100644
--- a/devel/pure-ffi/Makefile
+++ b/devel/pure-ffi/Makefile
@@ -10,10 +10,10 @@ DIST_SUBDIR= pure
MAINTAINER= lichray@gmail.com
COMMENT= Pure language interface to libffi
-LICENSE= GPLv3 LGPL3
-LICENSE_COMB= dual
+LICENSE= LGPL3+
+LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
-LIB_DEPENDS+= libffi.so:devel/libffi
+LIB_DEPENDS= libffi.so:devel/libffi
USES= pkgconfig pure
@@ -26,9 +26,11 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
diff --git a/devel/pure-ffi/pkg-descr b/devel/pure-ffi/pkg-descr
index d4cec088aeea..a646c7bd4cf2 100644
--- a/devel/pure-ffi/pkg-descr
+++ b/devel/pure-ffi/pkg-descr
@@ -3,4 +3,4 @@ functions from Pure and vice versa. It extends and complements Pure's
built-in C interface in that it also handles C structs and makes Pure
functions callable from C without writing a single line of C code.
-WWW: http://docs.pure-lang.googlecode.com/hg/pure-ffi.html
+WWW: https://puredocs.bitbucket.io/pure-ffi.html