aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-02 10:33:27 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-02 10:33:27 +0000
commit829807329296118eac74cbfc24c7e972493c9de7 (patch)
tree01d0d26970420b887e6a114059de1198fc1e53f7
parentf751086f9229f97ebc6f50d8d540d5aeb4a1c8f7 (diff)
downloadports-829807329296118eac74cbfc24c7e972493c9de7.tar.gz
ports-829807329296118eac74cbfc24c7e972493c9de7.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libleaftag/Makefile24
-rw-r--r--devel/libleaftag/distinfo3
-rw-r--r--devel/libleaftag/pkg-descr8
-rw-r--r--devel/libleaftag/pkg-plist11
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 33ed27c84ac3..422f1df8340b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -519,6 +519,7 @@
SUBDIR += libhoard
SUBDIR += libical
SUBDIR += libisc
+ SUBDIR += libleaftag
SUBDIR += libltdl15
SUBDIR += libmatheval
SUBDIR += libmba
diff --git a/devel/libleaftag/Makefile b/devel/libleaftag/Makefile
new file mode 100644
index 000000000000..ce9746f75472
--- /dev/null
+++ b/devel/libleaftag/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: libleaftag
+# Date Created: 24 May 2006
+# Whom: Khairil Yusof <kaeru@inigo-tech.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libleaftag
+PORTVERSION= 0.3.0
+CATEGORIES= devel deskutils
+MASTER_SITES= http://releases.chipx86.com/leaftag/libleaftag/
+
+MAINTAINER= kaeru@inigo-tech.com
+COMMENT= Leaftag is a library for tagging files on the desktop
+
+USE_SQLITE= 2
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack glib20 pkgconfig
+USE_LDCONFIG= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/devel/libleaftag/distinfo b/devel/libleaftag/distinfo
new file mode 100644
index 000000000000..da6747f1e772
--- /dev/null
+++ b/devel/libleaftag/distinfo
@@ -0,0 +1,3 @@
+MD5 (libleaftag-0.3.0.tar.gz) = 5328f5ccb00c5a1902ce1697cd58573e
+SHA256 (libleaftag-0.3.0.tar.gz) = a4c918c02b1195eca898dd664c59ee060fda9b807c0a934e7889e616957440c0
+SIZE (libleaftag-0.3.0.tar.gz) = 320956
diff --git a/devel/libleaftag/pkg-descr b/devel/libleaftag/pkg-descr
new file mode 100644
index 000000000000..e8ad5cbb64e8
--- /dev/null
+++ b/devel/libleaftag/pkg-descr
@@ -0,0 +1,8 @@
+Leaftag is a library and set of utilities for tagging files on the desktop.
+
+libleaftag is the core tagging library. It's GObject-based and provides a
+simple means for tagging and untagging files, retrieving lists of tags, and
+generally manipulating the database.
+
+Project homepage:
+WWW: http://www.chipx86.com/wiki/Leaftag
diff --git a/devel/libleaftag/pkg-plist b/devel/libleaftag/pkg-plist
new file mode 100644
index 000000000000..827e4adc2c80
--- /dev/null
+++ b/devel/libleaftag/pkg-plist
@@ -0,0 +1,11 @@
+include/libleaftag/db.h
+include/libleaftag/leaftag.h
+include/libleaftag/object.h
+include/libleaftag/source.h
+include/libleaftag/tag.h
+lib/libleaftag.a
+lib/libleaftag.la
+lib/libleaftag.so
+lib/libleaftag.so.0
+libdata/pkgconfig/libleaftag.pc
+@dirrm include/libleaftag