aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-01 15:31:33 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-01 15:31:33 +0000
commit93b8f14b85002092175020a9eb55761d91a8a613 (patch)
treefac54b2858ac8bddffee2c7a42b876e0ae09a801
parent28f497a7e40d442851196408f3474c56e2f08a02 (diff)
downloadports-93b8f14b85002092175020a9eb55761d91a8a613.tar.gz
ports-93b8f14b85002092175020a9eb55761d91a8a613.zip
Notes
-rw-r--r--www/amyc/Makefile8
-rw-r--r--www/aria/Makefile3
-rw-r--r--www/asp2php/Makefile8
-rw-r--r--www/bluefish/Makefile3
-rw-r--r--www/cheetah/Makefile3
-rw-r--r--www/comclear/Makefile8
-rw-r--r--www/dillo-i18n/Makefile3
-rw-r--r--www/dillo/Makefile3
-rw-r--r--www/dillo2/Makefile3
-rw-r--r--www/erwn/Makefile3
-rw-r--r--www/nscache/Makefile9
-rw-r--r--www/skipstone/Makefile3
-rw-r--r--www/ump/Makefile8
-rw-r--r--www/viewml/Makefile3
-rw-r--r--www/w3m/Makefile3
15 files changed, 45 insertions, 26 deletions
diff --git a/www/amyc/Makefile b/www/amyc/Makefile
index f2eb23e4aacc..26408e575cd9 100644
--- a/www/amyc/Makefile
+++ b/www/amyc/Makefile
@@ -21,13 +21,15 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
-WANT_GTK= yes
+USE_GNOMENG= yes
+WANT_GNOME= yes
.include <bsd.port.pre.mk>
-.if defined(HAVE_GTK)
+.if ${HAVE_GNOME:Mgtk12}!=""
PLIST_SUB= WITH_GTK=""
-USE_GTK= yes
+USE_GNOME+= gtk12
+PKGNAMESUFFIX= -gtk
.else
PLIST_SUB= WITH_GTK="@comment "
.endif
diff --git a/www/aria/Makefile b/www/aria/Makefile
index 2111d7e6cd70..3f09b02cad01 100644
--- a/www/aria/Makefile
+++ b/www/aria/Makefile
@@ -16,7 +16,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.t/test/}
MAINTAINER= nakai@FreeBSD.org
USE_BZIP2= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
USE_OPENSSL= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
diff --git a/www/asp2php/Makefile b/www/asp2php/Makefile
index 16c61c5d9ed0..5ac89f6844af 100644
--- a/www/asp2php/Makefile
+++ b/www/asp2php/Makefile
@@ -14,14 +14,16 @@ MAINTAINER= erwin@lansing.dk
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/a//}/src
-WANT_GTK= yes
+USE_GNOMENG= yes
+WANT_GNOME= yes
MAKE_ENV= FLAGS="${CFLAGS}"
USE_REINPLACE= yes
.include <bsd.port.pre.mk>
-.if defined(HAVE_GTK)
-USE_GTK= yes
+.if ${HAVE_GNOME:Mgtk12}!=""
+USE_GNOME+= gtk12
+PKGNAMESUFFIX= -gtk
ALL_TARGET= default gui
PLIST_SUB+= WANT_GTK=""
.else
diff --git a/www/bluefish/Makefile b/www/bluefish/Makefile
index b0c90a7ae294..825e4e318670 100644
--- a/www/bluefish/Makefile
+++ b/www/bluefish/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= weblint:${PORTSDIR}/www/weblint
USE_GMAKE= yes
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_IMLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= imlib
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-install-location="${X11BASE}/lib/bluefish"
diff --git a/www/cheetah/Makefile b/www/cheetah/Makefile
index 5a581490c90d..7d8711e2df8a 100644
--- a/www/cheetah/Makefile
+++ b/www/cheetah/Makefile
@@ -19,7 +19,8 @@ LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
GNU_CONFIGURE= yes
USE_X_PREFIX= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
USE_GMAKE= yes
.include <bsd.port.mk>
diff --git a/www/comclear/Makefile b/www/comclear/Makefile
index 49600617b86a..1fef30ad9d20 100644
--- a/www/comclear/Makefile
+++ b/www/comclear/Makefile
@@ -13,14 +13,16 @@ MASTER_SITES= http://www.neuro-tech.net/files/
MAINTAINER= roam@FreeBSD.org
-WANT_GTK= yes
+USE_GNOMENG= yes
+WANT_GNOME= yes
USE_GMAKE= yes
USE_AUTOMAKE= yes
.include <bsd.port.pre.mk>
-.if defined(HAVE_GTK)
-USE_GTK= yes
+.if ${HAVE_GNOME:Mgtk12}!=""
+USE_GNOME+= gtk12
+PKGNAMESUFFIX= -gtk
.endif
# Do not install docs by default, see the ifdef'd post-install below.
diff --git a/www/dillo-i18n/Makefile b/www/dillo-i18n/Makefile
index 8e31412dcaf6..ac652934945b 100644
--- a/www/dillo-i18n/Makefile
+++ b/www/dillo-i18n/Makefile
@@ -17,7 +17,8 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
intl.4:${PORTSDIR}/devel/gettext
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --includedir="${LOCALBASE}/include" \
--libdir="${LOCALBASE}/lib" \
diff --git a/www/dillo/Makefile b/www/dillo/Makefile
index 8e31412dcaf6..ac652934945b 100644
--- a/www/dillo/Makefile
+++ b/www/dillo/Makefile
@@ -17,7 +17,8 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
intl.4:${PORTSDIR}/devel/gettext
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --includedir="${LOCALBASE}/include" \
--libdir="${LOCALBASE}/lib" \
diff --git a/www/dillo2/Makefile b/www/dillo2/Makefile
index 8e31412dcaf6..ac652934945b 100644
--- a/www/dillo2/Makefile
+++ b/www/dillo2/Makefile
@@ -17,7 +17,8 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
intl.4:${PORTSDIR}/devel/gettext
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --includedir="${LOCALBASE}/include" \
--libdir="${LOCALBASE}/lib" \
diff --git a/www/erwn/Makefile b/www/erwn/Makefile
index 93fdb4a08b66..34d75815fcb6 100644
--- a/www/erwn/Makefile
+++ b/www/erwn/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= jim@FreeBSD.org
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
post-install:
.if !defined(NOPORTDOCS)
diff --git a/www/nscache/Makefile b/www/nscache/Makefile
index a72f8a8e8c98..8c4aa8a41c83 100644
--- a/www/nscache/Makefile
+++ b/www/nscache/Makefile
@@ -16,18 +16,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= kris@FreeBSD.org
USE_X_PREFIX= yes
-USE_GTK= yes
+USE_GNOMENG= yes
WANT_GNOME= yes
USE_AUTOMAKE= yes
AUTOMAKE_ARGS= --include-deps
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-gtk-config=${GTK_CONFIG}
-
+
.include <bsd.port.pre.mk>
-
+
.if defined(HAVE_GNOME)
-USE_GNOME= yes
+USE_GNOME+= gtk12
+PKGNAMESUFFIX= -gtk
.else
CONFIGURE_ARGS+= --disable-gnome
.endif
diff --git a/www/skipstone/Makefile b/www/skipstone/Makefile
index a77a50823773..83002c92165f 100644
--- a/www/skipstone/Makefile
+++ b/www/skipstone/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= ${X11BASE}/lib/mozilla-embedded/libgtkembedmoz.so:${PORTSDIR}/www/m
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-mozilla-includes=${X11BASE}/include/mozilla --with-mozilla-libs=${X11BASE}/lib/mozilla-embedded
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
USE_GMAKE= yes
USE_REINPLACE= yes
USE_X_PREFIX= yes
diff --git a/www/ump/Makefile b/www/ump/Makefile
index 5e05b7fb0c8d..262ace36edf6 100644
--- a/www/ump/Makefile
+++ b/www/ump/Makefile
@@ -33,7 +33,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-ump
USE_GMAKE= yes
USE_XLIB= yes
-WANT_ESOUND= yes
+USE_GNOMENG= yes
+WANT_GNOME= yes
# CONFIGURE_ARGS+= --enable-motif
EXTRA_PATCHES= ${.CURDIR}/../../audio/timidity++/files/*
PKGDIR= ${.CURDIR}
@@ -45,8 +46,9 @@ WRKSRC= ${WRKDIR}/TiMidity++-${TIMIDITY_VERSION}
.include <bsd.port.pre.mk>
-.if defined(HAVE_ESOUND)
-USE_ESOUND= yes
+.if ${HAVE_GNOME:Mesound}!=""
+USE_GNOME= esound
+PKGNAMESUFFIX= -esound
CONFIGURE_ARGS+= --enable-audio=oss,esd
.else
CONFIGURE_ARGS+= --enable-audio=oss
diff --git a/www/viewml/Makefile b/www/viewml/Makefile
index 68cecbd3e6f9..fa59e94e74c5 100644
--- a/www/viewml/Makefile
+++ b/www/viewml/Makefile
@@ -21,7 +21,8 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_IMLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= imlib
USE_BISON= yes
CFLAGS+= -fpermissive -include /usr/include/sys/types.h \
-DPREFIX=\\\"${PREFIX}\\\"
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index f06c42ad087a..7a48b790292b 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -82,7 +82,8 @@ MAKE_FLAGS+= DEFS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
.endif
.if defined(INLINE_IMAGE)
-USE_IMLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= imlib
DOCS+= README.img
DOCS_JP+= README.img