aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2007-03-07 19:45:41 +0000
committerLars Thegler <lth@FreeBSD.org>2007-03-07 19:45:41 +0000
commit985997dac28c518aff5d9857dae6ebb31fbc116f (patch)
tree1e9ceaa279c1270f3800b068e01bcaa650b21885
parent0732ce77a4afe22f5c2cb17f7300759f90eee40b (diff)
downloadports-985997dac28c518aff5d9857dae6ebb31fbc116f.tar.gz
ports-985997dac28c518aff5d9857dae6ebb31fbc116f.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Script/Makefile22
-rw-r--r--devel/p5-Test-Script/distinfo3
-rw-r--r--devel/p5-Test-Script/pkg-descr6
-rw-r--r--devel/p5-Test-Script/pkg-plist5
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d96c17640f9b..cddb11fc93f9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1501,6 +1501,7 @@
SUBDIR += p5-Test-Pod-Coverage
SUBDIR += p5-Test-RandomResults
SUBDIR += p5-Test-Reporter
+ SUBDIR += p5-Test-Script
SUBDIR += p5-Test-Simple
SUBDIR += p5-Test-Singleton
SUBDIR += p5-Test-Strict
diff --git a/devel/p5-Test-Script/Makefile b/devel/p5-Test-Script/Makefile
new file mode 100644
index 000000000000..ef554947ed2b
--- /dev/null
+++ b/devel/p5-Test-Script/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: devel/p5-Test-Script
+# Date created: Wed Mar 7 20:14:32 CET 2007
+# Whom: lth@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Script
+PORTVERSION= 1.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Test::Script - Cross-platform basic tests for scripts
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Script.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Script/distinfo b/devel/p5-Test-Script/distinfo
new file mode 100644
index 000000000000..9ff5d159d6df
--- /dev/null
+++ b/devel/p5-Test-Script/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Script-1.02.tar.gz) = affeb47b8c7b9f1eb6ff346daa85784d
+SHA256 (Test-Script-1.02.tar.gz) = 36bc14bee54987e4c02fa828c8e90b5d9244ee8fe14aee5a88f2ec3132538b02
+SIZE (Test-Script-1.02.tar.gz) = 21125
diff --git a/devel/p5-Test-Script/pkg-descr b/devel/p5-Test-Script/pkg-descr
new file mode 100644
index 000000000000..d14e7e49465a
--- /dev/null
+++ b/devel/p5-Test-Script/pkg-descr
@@ -0,0 +1,6 @@
+Test::Script - Cross-platform basic tests for scripts
+
+The intent of this module is to provide a series of basic tests for
+scripts in the bin directory of your Perl distribution.
+
+WWW: http://search.cpan.org/dist/Test-Script/
diff --git a/devel/p5-Test-Script/pkg-plist b/devel/p5-Test-Script/pkg-plist
new file mode 100644
index 000000000000..4ce829a9bce4
--- /dev/null
+++ b/devel/p5-Test-Script/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Test/Script.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Script/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Script
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test