aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-07-12 09:06:38 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-07-12 09:06:38 +0000
commit9d929d660456290eeb8959790378388273d531d8 (patch)
treeab1912b31b41688b996dc3115e71cfe01b8a3a8d
parentebfb9c8210f49bc484e221207d11d3ec3353ca43 (diff)
Now we use USE_FORTRAN=yes to use FORTRAN compiler.
Notes
Notes: svn path=/head/; revision=195464
-rw-r--r--math/lapack95/Makefile5
-rw-r--r--math/linpack/Makefile5
2 files changed, 2 insertions, 8 deletions
diff --git a/math/lapack95/Makefile b/math/lapack95/Makefile
index baed389a761c..af38e8fc799e 100644
--- a/math/lapack95/Makefile
+++ b/math/lapack95/Makefile
@@ -38,10 +38,7 @@ BLAS= -lblas
LAPACK= -llapack
.endif
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
WRKSRC= ${WRKDIR}/LAPACK95
FORTRAN_FIXED=
FORTRAN_FREE=# -free
diff --git a/math/linpack/Makefile b/math/linpack/Makefile
index b26b28c5cf9b..612d07cf922c 100644
--- a/math/linpack/Makefile
+++ b/math/linpack/Makefile
@@ -20,10 +20,7 @@ LIB_DEPENDS= blas.2:${PORTSDIR}/math/blas
.include <bsd.port.pre.mk>
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
USE_LDCONFIG= yes
DIST_SUBDIR= ${PORTNAME}