aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBradley T. Hughes <bhughes@FreeBSD.org>2019-09-17 19:06:01 +0000
committerBradley T. Hughes <bhughes@FreeBSD.org>2019-09-17 19:06:01 +0000
commitb4643f40a4948540e85b4e77daab76e558b28622 (patch)
tree79fb0e9199ed48be788c3be1ea2b24691599a387
parent0c7c04fa3768e973468c041a3997b51dd5f9eb76 (diff)
downloadports-b4643f40a4948540e85b4e77daab76e558b28622.tar.gz
ports-b4643f40a4948540e85b4e77daab76e558b28622.zip
MFH: r506491 r507478 r509122 r509481
www/node: Update 12.4.0 -> 12.6.0 https://nodejs.org/en/blog/release/v12.5.0/ https://nodejs.org/en/blog/release/v12.6.0/ Sponsored by: Miles AS www/node: Update 12.6.0_1 -> 12.7.0 https://nodejs.org/en/blog/release/v12.7.0/ www/node: Update 12.7.0 -> 12.8.0 https://nodejs.org/en/blog/release/v12.8.0/ The bundled OpenSSL configuration now includes BSD-x86, which this port can now use. The build for i386 is still using the no-asm variant for the time being. Assembler errors in BSD-x86/asm-avx2 need to be investigated to be able to enable asm with the bundled OpenSSL. While here, regenerate all remaining patches with `make makepatch`. Sponsored by: Miles AS www/node: Update 12.8.0 -> 12.8.1 This is a security release. All Node.js users should consult the security release summary at https://nodejs.org/en/blog/vulnerability/aug-2019-security-releases/ for details on patched vulnerabilities. Security: c97a940b-c392-11e9-bb38-000d3ab229d6 Sponsored by: Miles AS Approved by: ports-secteam (joneum)
Notes
Notes: svn path=/branches/2019Q3/; revision=512231
-rw-r--r--www/node/Makefile8
-rw-r--r--www/node/distinfo6
-rw-r--r--www/node/files/patch-deps_openssl_config_archs_linux-elf_asm_openssl-cl.gypi17
-rw-r--r--www/node/files/patch-deps_openssl_config_archs_linux-elf_asm_openssl.gypi17
-rw-r--r--www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl-cl.gypi14
-rw-r--r--www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl.gypi14
-rw-r--r--www/node/files/patch-deps_openssl_config_bn__conf__asm.h13
-rw-r--r--www/node/files/patch-deps_openssl_config_bn__conf__no-asm.h13
-rw-r--r--www/node/files/patch-deps_openssl_config_dso__conf__asm.h13
-rw-r--r--www/node/files/patch-deps_openssl_config_dso__conf__no-asm.h13
-rw-r--r--www/node/files/patch-deps_openssl_config_opensslconf__asm.h13
-rw-r--r--www/node/files/patch-deps_openssl_config_opensslconf__no-asm.h13
-rw-r--r--www/node/files/patch-deps_openssl_openssl-cl__no__asm.gypi6
-rw-r--r--www/node/files/patch-deps_openssl_openssl__no__asm.gypi6
-rw-r--r--www/node/files/patch-deps_v8_src_arm_cpu-arm.cc4
-rw-r--r--www/node/files/patch-deps_v8_src_base_platform_platform-freebsd.cc7
-rw-r--r--www/node/files/patch-deps_v8_src_libsampler_sampler.cc4
-rw-r--r--www/node/files/patch-node.gypi4
-rw-r--r--www/node/pkg-plist25
19 files changed, 56 insertions, 154 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index 0591fec0ff68..e3ffaa949043 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= node
-PORTVERSION= 12.4.0
+PORTVERSION= 12.8.1
DISTVERSIONPREFIX= v
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
@@ -66,8 +66,8 @@ MAKE_ENV+= CC.host=${CC} CFLAGS.host="${CFLAGS}" \
LINK.host=${CXX} LDFLAGS.host="${LDFLAGS}"
BUILD_DEPENDS+= c-ares>=1.15.0:dns/c-ares\
- libuv>=1.29.1:devel/libuv \
- libnghttp2>=1.38.0:www/libnghttp2
+ libuv>=1.30.1:devel/libuv \
+ libnghttp2>=1.39.2:www/libnghttp2
LIB_DEPENDS+= libcares.so:dns/c-ares\
libuv.so:devel/libuv \
libnghttp2.so:www/libnghttp2
@@ -78,7 +78,7 @@ LIB_DEPENDS+= libcares.so:dns/c-ares\
BROKEN_SSL+= base
.endif
-.if ${PORT_OPTIONS:MBUNDLED_SSL} && ${ARCH} != amd64 && ${ARCH} != i386
+.if ${PORT_OPTIONS:MBUNDLED_SSL} && ${ARCH} != amd64
CONFIGURE_ARGS+=--openssl-no-asm
.endif
diff --git a/www/node/distinfo b/www/node/distinfo
index 43f2389d4a7f..3034ad14ac0b 100644
--- a/www/node/distinfo
+++ b/www/node/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1559661163
-SHA256 (node-v12.4.0.tar.gz) = cf39befb8ea486363cac6f297d8f451fd0d5dd8ad21dca51e9c2ea86b242baa0
-SIZE (node-v12.4.0.tar.gz) = 49167965
+TIMESTAMP = 1565994523
+SHA256 (node-v12.8.1.tar.gz) = fbd4de6657f6301cdcd0c60a0e5a413c490670d8c21b501c380b96cc3b9b5b95
+SIZE (node-v12.8.1.tar.gz) = 50231954
diff --git a/www/node/files/patch-deps_openssl_config_archs_linux-elf_asm_openssl-cl.gypi b/www/node/files/patch-deps_openssl_config_archs_linux-elf_asm_openssl-cl.gypi
deleted file mode 100644
index 2396fdf6baa9..000000000000
--- a/www/node/files/patch-deps_openssl_config_archs_linux-elf_asm_openssl-cl.gypi
+++ /dev/null
@@ -1,17 +0,0 @@
---- deps/openssl/config/archs/linux-elf/asm/openssl-cl.gypi.orig 2019-01-30 20:43:11 UTC
-+++ deps/openssl/config/archs/linux-elf/asm/openssl-cl.gypi
-@@ -26,12 +26,11 @@
- ],
- 'openssl_cflags_linux-elf': [
- '-Wa,--noexecstack',
-- '-Wall -O3 -fomit-frame-pointer',
-+ '-Wall -O3',
- '-pthread',
-- '-Wall -O3 -fomit-frame-pointer',
- ],
- 'openssl_ex_libs_linux-elf': [
-- '-ldl -pthread',
-+ '',
- ],
- 'openssl_cli_srcs_linux-elf': [
- 'openssl/apps/asn1pars.c',
diff --git a/www/node/files/patch-deps_openssl_config_archs_linux-elf_asm_openssl.gypi b/www/node/files/patch-deps_openssl_config_archs_linux-elf_asm_openssl.gypi
deleted file mode 100644
index d2972e9bf7d9..000000000000
--- a/www/node/files/patch-deps_openssl_config_archs_linux-elf_asm_openssl.gypi
+++ /dev/null
@@ -1,17 +0,0 @@
---- deps/openssl/config/archs/linux-elf/asm/openssl.gypi.orig 2019-01-30 20:43:11 UTC
-+++ deps/openssl/config/archs/linux-elf/asm/openssl.gypi
-@@ -722,12 +722,11 @@
- ],
- 'openssl_cflags_linux-elf': [
- '-Wa,--noexecstack',
-- '-Wall -O3 -fomit-frame-pointer',
-+ '-Wall -O3',
- '-pthread',
-- '-Wall -O3 -fomit-frame-pointer',
- ],
- 'openssl_ex_libs_linux-elf': [
-- '-ldl -pthread',
-+ '',
- ],
- },
- 'include_dirs': [
diff --git a/www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl-cl.gypi b/www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl-cl.gypi
index 1074352eb424..aae558fe58db 100644
--- a/www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl-cl.gypi
+++ b/www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl-cl.gypi
@@ -1,17 +1,11 @@
---- deps/openssl/config/archs/linux-elf/no-asm/openssl-cl.gypi.orig 2019-01-30 20:43:11 UTC
+--- deps/openssl/config/archs/linux-elf/no-asm/openssl-cl.gypi.orig 2019-08-06 20:46:23 UTC
+++ deps/openssl/config/archs/linux-elf/no-asm/openssl-cl.gypi
-@@ -7,12 +7,11 @@
- 'OPENSSL_PIC',
- ],
- 'openssl_cflags_linux-elf': [
-- '-Wall -O3 -fomit-frame-pointer',
-+ '-Wall -O3',
- '-pthread',
-- '-Wall -O3 -fomit-frame-pointer',
+@@ -12,7 +12,7 @@
+ '-Wall -O3 -fomit-frame-pointer',
],
'openssl_ex_libs_linux-elf': [
- '-ldl -pthread',
-+ '',
++ '-pthread',
],
'openssl_cli_srcs_linux-elf': [
'openssl/apps/asn1pars.c',
diff --git a/www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl.gypi b/www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl.gypi
index 62913decd7c7..552266b703f0 100644
--- a/www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl.gypi
+++ b/www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl.gypi
@@ -1,17 +1,11 @@
---- deps/openssl/config/archs/linux-elf/no-asm/openssl.gypi.orig 2019-02-06 21:04:54 UTC
+--- deps/openssl/config/archs/linux-elf/no-asm/openssl.gypi.orig 2019-08-06 20:46:23 UTC
+++ deps/openssl/config/archs/linux-elf/no-asm/openssl.gypi
-@@ -691,12 +691,11 @@
- 'OPENSSL_PIC',
- ],
- 'openssl_cflags_linux-elf': [
-- '-Wall -O3 -fomit-frame-pointer',
-+ '-Wall -O3',
- '-pthread',
-- '-Wall -O3 -fomit-frame-pointer',
+@@ -696,7 +696,7 @@
+ '-Wall -O3 -fomit-frame-pointer',
],
'openssl_ex_libs_linux-elf': [
- '-ldl -pthread',
-+ '',
++ '-pthread',
],
},
'include_dirs': [
diff --git a/www/node/files/patch-deps_openssl_config_bn__conf__asm.h b/www/node/files/patch-deps_openssl_config_bn__conf__asm.h
deleted file mode 100644
index 0d2a636e2676..000000000000
--- a/www/node/files/patch-deps_openssl_config_bn__conf__asm.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- deps/openssl/config/bn_conf_asm.h.orig 2018-05-11 12:01:43 UTC
-+++ deps/openssl/config/bn_conf_asm.h
-@@ -21,8 +21,8 @@
- # include "./archs/VC-WIN32/asm/crypto/include/internal/bn_conf.h"
- #elif defined(_WIN32) && defined(_M_X64)
- # include "./archs/VC-WIN64A/asm/crypto/include/internal/bn_conf.h"
--#elif (defined(__FreeBSD__) || defined(__OpenBSD__)) && defined(__i386__)
--# include "./archs/BSD-x86/asm/crypto/include/internal/bn_conf.h"
-+//#elif (defined(__FreeBSD__) || defined(__OpenBSD__)) && defined(__i386__)
-+//# include "./archs/BSD-x86/asm/crypto/include/internal/bn_conf.h"
- #elif (defined(__FreeBSD__) || defined(__OpenBSD__)) && defined(__x86_64__)
- # include "./archs/BSD-x86_64/asm/crypto/include/internal/bn_conf.h"
- #elif defined(__sun) && defined(__i386__)
diff --git a/www/node/files/patch-deps_openssl_config_bn__conf__no-asm.h b/www/node/files/patch-deps_openssl_config_bn__conf__no-asm.h
deleted file mode 100644
index f7e51945d2b6..000000000000
--- a/www/node/files/patch-deps_openssl_config_bn__conf__no-asm.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- deps/openssl/config/bn_conf_no-asm.h.orig 2019-04-11 12:07:35 UTC
-+++ deps/openssl/config/bn_conf_no-asm.h
-@@ -23,8 +23,8 @@
- # include "./archs/VC-WIN64A/no-asm/crypto/include/internal/bn_conf.h"
- #elif defined(_WIN32) && defined(_M_ARM64)
- # include "./archs/VC-WIN64-ARM/no-asm/crypto/include/internal/bn_conf.h"
--#elif (defined(__FreeBSD__) || defined(__OpenBSD__)) && defined(__i386__)
--# include "./archs/BSD-x86/no-asm/crypto/include/internal/bn_conf.h"
-+//#elif (defined(__FreeBSD__) || defined(__OpenBSD__)) && defined(__i386__)
-+//# include "./archs/BSD-x86/no-asm/crypto/include/internal/bn_conf.h"
- #elif (defined(__FreeBSD__) || defined(__OpenBSD__)) && defined(__x86_64__)
- # include "./archs/BSD-x86_64/no-asm/crypto/include/internal/bn_conf.h"
- #elif defined(__sun) && defined(__i386__)
diff --git a/www/node/files/patch-deps_openssl_config_dso__conf__asm.h b/www/node/files/patch-deps_openssl_config_dso__conf__asm.h
deleted file mode 100644
index d5d0e9d9b4ea..000000000000
--- a/www/node/files/patch-deps_openssl_config_dso__conf__asm.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- deps/openssl/config/dso_conf_asm.h.orig 2018-05-11 12:02:07 UTC
-+++ deps/openssl/config/dso_conf_asm.h
-@@ -21,8 +21,8 @@
- # include "./archs/VC-WIN32/asm/crypto/include/internal/dso_conf.h"
- #elif defined(_WIN32) && defined(_M_X64)
- # include "./archs/VC-WIN64A/asm/crypto/include/internal/dso_conf.h"
--#elif (defined(__FreeBSD__) || defined(__OpenBSD__)) && defined(__i386__)
--# include "./archs/BSD-x86/asm/crypto/include/internal/dso_conf.h"
-+//#elif (defined(__FreeBSD__) || defined(__OpenBSD__)) && defined(__i386__)
-+//# include "./archs/BSD-x86/asm/crypto/include/internal/dso_conf.h"
- #elif (defined(__FreeBSD__) || defined(__OpenBSD__)) && defined(__x86_64__)
- # include "./archs/BSD-x86_64/asm/crypto/include/internal/dso_conf.h"
- #elif defined(__sun) && defined(__i386__)
diff --git a/www/node/files/patch-deps_openssl_config_dso__conf__no-asm.h b/www/node/files/patch-deps_openssl_config_dso__conf__no-asm.h
deleted file mode 100644
index 3b9037b9be4f..000000000000
--- a/www/node/files/patch-deps_openssl_config_dso__conf__no-asm.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- deps/openssl/config/dso_conf_no-asm.h.orig 2019-04-11 12:07:35 UTC
-+++ deps/openssl/config/dso_conf_no-asm.h
-@@ -23,8 +23,8 @@
- # include "./archs/VC-WIN64A/no-asm/crypto/include/internal/dso_conf.h"
- #elif defined(_WIN32) && defined(_M_ARM64)
- # include "./archs/VC-WIN64-ARM/no-asm/crypto/include/internal/dso_conf.h"
--#elif (defined(__FreeBSD__) || defined(__OpenBSD__)) && defined(__i386__)
--# include "./archs/BSD-x86/no-asm/crypto/include/internal/dso_conf.h"
-+//#elif (defined(__FreeBSD__) || defined(__OpenBSD__)) && defined(__i386__)
-+//# include "./archs/BSD-x86/no-asm/crypto/include/internal/dso_conf.h"
- #elif (defined(__FreeBSD__) || defined(__OpenBSD__)) && defined(__x86_64__)
- # include "./archs/BSD-x86_64/no-asm/crypto/include/internal/dso_conf.h"
- #elif defined(__sun) && defined(__i386__)
diff --git a/www/node/files/patch-deps_openssl_config_opensslconf__asm.h b/www/node/files/patch-deps_openssl_config_opensslconf__asm.h
deleted file mode 100644
index 814bd24dc300..000000000000
--- a/www/node/files/patch-deps_openssl_config_opensslconf__asm.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- deps/openssl/config/opensslconf_asm.h.orig 2018-05-11 11:27:00 UTC
-+++ deps/openssl/config/opensslconf_asm.h
-@@ -108,8 +108,8 @@
- # include "./archs/VC-WIN32/asm/include/openssl/opensslconf.h"
- #elif defined(_WIN32) && defined(_M_X64)
- # include "./archs/VC-WIN64A/asm/include/openssl/opensslconf.h"
--#elif (defined(__FreeBSD__) || defined(__OpenBSD__)) && defined(__i386__)
--# include "./archs/BSD-x86/asm/include/openssl/opensslconf.h"
-+//#elif (defined(__FreeBSD__) || defined(__OpenBSD__)) && defined(__i386__)
-+//# include "./archs/BSD-x86/asm/include/openssl/opensslconf.h"
- #elif (defined(__FreeBSD__) || defined(__OpenBSD__)) && defined(__x86_64__)
- # include "./archs/BSD-x86_64/asm/include/openssl/opensslconf.h"
- #elif defined(__sun) && defined(__i386__)
diff --git a/www/node/files/patch-deps_openssl_config_opensslconf__no-asm.h b/www/node/files/patch-deps_openssl_config_opensslconf__no-asm.h
deleted file mode 100644
index 1c2f31455b79..000000000000
--- a/www/node/files/patch-deps_openssl_config_opensslconf__no-asm.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- deps/openssl/config/opensslconf_no-asm.h.orig 2019-04-11 12:07:35 UTC
-+++ deps/openssl/config/opensslconf_no-asm.h
-@@ -18,8 +18,8 @@
- # include "./archs/VC-WIN64A/no-asm/include/openssl/opensslconf.h"
- #elif defined(_WIN32) && defined(_M_ARM64)
- # include "./archs/VC-WIN64-ARM/no-asm/include/openssl/opensslconf.h"
--#elif (defined(__FreeBSD__) || defined(__OpenBSD__)) && defined(__i386__)
--# include "./archs/BSD-x86/no-asm/include/openssl/opensslconf.h"
-+//#elif (defined(__FreeBSD__) || defined(__OpenBSD__)) && defined(__i386__)
-+//# include "./archs/BSD-x86/no-asm/include/openssl/opensslconf.h"
- #elif (defined(__FreeBSD__) || defined(__OpenBSD__)) && defined(__x86_64__)
- # include "./archs/BSD-x86_64/no-asm/include/openssl/opensslconf.h"
- #elif defined(__sun) && defined(__i386__)
diff --git a/www/node/files/patch-deps_openssl_openssl-cl__no__asm.gypi b/www/node/files/patch-deps_openssl_openssl-cl__no__asm.gypi
index 0f3e18221a63..05e4929605d2 100644
--- a/www/node/files/patch-deps_openssl_openssl-cl__no__asm.gypi
+++ b/www/node/files/patch-deps_openssl_openssl-cl__no__asm.gypi
@@ -1,4 +1,4 @@
---- deps/openssl/openssl-cl_no_asm.gypi.orig 2019-04-23 12:30:43 UTC
+--- deps/openssl/openssl-cl_no_asm.gypi.orig 2019-08-06 20:46:23 UTC
+++ deps/openssl/openssl-cl_no_asm.gypi
@@ -1,4 +1,5 @@
{
@@ -6,8 +6,8 @@
'conditions': [
['target_arch=="ppc" and OS=="aix"', {
'includes': ['config/archs/aix-gcc/no-asm/openssl-cl.gypi'],
-@@ -43,7 +44,7 @@
- 'includes': ['config/archs/linux-x86_64/no-asm/openssl-cl.gypi'],
+@@ -45,7 +46,7 @@
+ 'includes': ['config/archs/linux64-mips64/no-asm/openssl-cl.gypi'],
}, {
# Other architectures don't use assembly
- 'includes': ['config/archs/linux-x86_64/no-asm/openssl-cl.gypi'],
diff --git a/www/node/files/patch-deps_openssl_openssl__no__asm.gypi b/www/node/files/patch-deps_openssl_openssl__no__asm.gypi
index 29736bd9038e..ec3448f01954 100644
--- a/www/node/files/patch-deps_openssl_openssl__no__asm.gypi
+++ b/www/node/files/patch-deps_openssl_openssl__no__asm.gypi
@@ -1,7 +1,7 @@
---- deps/openssl/openssl_no_asm.gypi.orig 2019-04-23 12:30:43 UTC
+--- deps/openssl/openssl_no_asm.gypi.orig 2019-08-06 20:46:23 UTC
+++ deps/openssl/openssl_no_asm.gypi
-@@ -44,7 +44,7 @@
- 'includes': ['config/archs/linux-x86_64/no-asm/openssl.gypi'],
+@@ -46,7 +46,7 @@
+ 'includes': ['config/archs/linux64-mips64/no-asm/openssl.gypi'],
}, {
# Other architectures don't use assembly
- 'includes': ['config/archs/linux-x86_64/no-asm/openssl.gypi'],
diff --git a/www/node/files/patch-deps_v8_src_arm_cpu-arm.cc b/www/node/files/patch-deps_v8_src_arm_cpu-arm.cc
index da9aa442827e..65d3004ab102 100644
--- a/www/node/files/patch-deps_v8_src_arm_cpu-arm.cc
+++ b/www/node/files/patch-deps_v8_src_arm_cpu-arm.cc
@@ -1,4 +1,4 @@
---- deps/v8/src/arm/cpu-arm.cc.orig 2019-04-23 12:30:43 UTC
+--- deps/v8/src/arm/cpu-arm.cc.orig 2019-08-06 20:46:23 UTC
+++ deps/v8/src/arm/cpu-arm.cc
@@ -7,6 +7,9 @@
#ifdef __QNXNTO__
@@ -10,7 +10,7 @@
#else
#include <sys/syscall.h> // for cache flushing.
#endif
-@@ -23,6 +26,9 @@ void CpuFeatures::FlushICache(void* start, size_t size
+@@ -26,6 +29,9 @@ __attribute__((noinline)) void CpuFeatures::FlushICach
#if !defined(USE_SIMULATOR)
#if V8_OS_QNX
msync(start, size, MS_SYNC | MS_INVALIDATE_ICACHE);
diff --git a/www/node/files/patch-deps_v8_src_base_platform_platform-freebsd.cc b/www/node/files/patch-deps_v8_src_base_platform_platform-freebsd.cc
index 388f92143aaf..b405a606383e 100644
--- a/www/node/files/patch-deps_v8_src_base_platform_platform-freebsd.cc
+++ b/www/node/files/patch-deps_v8_src_base_platform_platform-freebsd.cc
@@ -1,6 +1,6 @@
---- deps/v8/src/base/platform/platform-freebsd.cc.orig 2019-01-30 20:43:13 UTC
+--- deps/v8/src/base/platform/platform-freebsd.cc.orig 2019-08-06 20:46:24 UTC
+++ deps/v8/src/base/platform/platform-freebsd.cc
-@@ -86,5 +86,47 @@ std::vector<OS::SharedLibraryAddress> OS::GetSharedLib
+@@ -86,6 +86,48 @@ std::vector<OS::SharedLibraryAddress> OS::GetSharedLib
void OS::SignalCodeMovingGC() {}
@@ -46,5 +46,6 @@
+
+#endif // def __arm__
+
+ void OS::AdjustSchedulingParams() {}
+
} // namespace base
- } // namespace v8
diff --git a/www/node/files/patch-deps_v8_src_libsampler_sampler.cc b/www/node/files/patch-deps_v8_src_libsampler_sampler.cc
index 1f61ee4d2b1b..afbb11c9dab0 100644
--- a/www/node/files/patch-deps_v8_src_libsampler_sampler.cc
+++ b/www/node/files/patch-deps_v8_src_libsampler_sampler.cc
@@ -1,6 +1,6 @@
---- deps/v8/src/libsampler/sampler.cc.orig 2019-04-23 12:30:43 UTC
+--- deps/v8/src/libsampler/sampler.cc.orig 2019-08-06 20:46:24 UTC
+++ deps/v8/src/libsampler/sampler.cc
-@@ -466,9 +466,13 @@ void SignalHandler::FillRegisterState(void* context, R
+@@ -470,9 +470,13 @@ void SignalHandler::FillRegisterState(void* context, R
state->sp = reinterpret_cast<void*>(mcontext.mc_rsp);
state->fp = reinterpret_cast<void*>(mcontext.mc_rbp);
#elif V8_HOST_ARCH_ARM
diff --git a/www/node/files/patch-node.gypi b/www/node/files/patch-node.gypi
index e27f34049ec9..8c570b2dc76e 100644
--- a/www/node/files/patch-node.gypi
+++ b/www/node/files/patch-node.gypi
@@ -1,6 +1,6 @@
---- node.gypi.orig 2019-04-23 12:30:45 UTC
+--- node.gypi.orig 2019-08-06 20:46:25 UTC
+++ node.gypi
-@@ -315,6 +315,9 @@
+@@ -307,6 +307,9 @@
['openssl_fips != "" or openssl_is_fips=="true"', {
'defines': [ 'NODE_FIPS_MODE' ],
}],
diff --git a/www/node/pkg-plist b/www/node/pkg-plist
index c9b75338efd0..02a7a2502965 100644
--- a/www/node/pkg-plist
+++ b/www/node/pkg-plist
@@ -12,6 +12,21 @@ include/node/node_api_types.h
include/node/node_buffer.h
include/node/node_object_wrap.h
include/node/node_version.h
+%%BUNDLED_SSL%%include/node/openssl/archs/BSD-x86/asm/crypto/buildinf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/BSD-x86/asm/crypto/include/internal/bn_conf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/BSD-x86/asm/crypto/include/internal/dso_conf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/BSD-x86/asm/include/openssl/opensslconf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/BSD-x86/asm/include/progs.h
+%%BUNDLED_SSL%%include/node/openssl/archs/BSD-x86/asm_avx2/crypto/buildinf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/BSD-x86/asm_avx2/crypto/include/internal/bn_conf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/BSD-x86/asm_avx2/crypto/include/internal/dso_conf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/BSD-x86/asm_avx2/include/openssl/opensslconf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/BSD-x86/asm_avx2/include/progs.h
+%%BUNDLED_SSL%%include/node/openssl/archs/BSD-x86/no-asm/crypto/buildinf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/BSD-x86/no-asm/crypto/include/internal/bn_conf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/BSD-x86/no-asm/crypto/include/internal/dso_conf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/BSD-x86/no-asm/include/openssl/opensslconf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/BSD-x86/no-asm/include/progs.h
%%BUNDLED_SSL%%include/node/openssl/archs/BSD-x86_64/asm/crypto/buildinf.h
%%BUNDLED_SSL%%include/node/openssl/archs/BSD-x86_64/asm/crypto/include/internal/bn_conf.h
%%BUNDLED_SSL%%include/node/openssl/archs/BSD-x86_64/asm/crypto/include/internal/dso_conf.h
@@ -167,6 +182,16 @@ include/node/node_version.h
%%BUNDLED_SSL%%include/node/openssl/archs/linux-elf/no-asm/crypto/include/internal/dso_conf.h
%%BUNDLED_SSL%%include/node/openssl/archs/linux-elf/no-asm/include/openssl/opensslconf.h
%%BUNDLED_SSL%%include/node/openssl/archs/linux-elf/no-asm/include/progs.h
+%%BUNDLED_SSL%%include/node/openssl/archs/linux64-mips64/asm/crypto/buildinf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/linux64-mips64/asm/crypto/include/internal/bn_conf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/linux64-mips64/asm/crypto/include/internal/dso_conf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/linux64-mips64/asm/include/openssl/opensslconf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/linux64-mips64/asm/include/progs.h
+%%BUNDLED_SSL%%include/node/openssl/archs/linux64-mips64/no-asm/crypto/buildinf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/linux64-mips64/no-asm/crypto/include/internal/bn_conf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/linux64-mips64/no-asm/crypto/include/internal/dso_conf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/linux64-mips64/no-asm/include/openssl/opensslconf.h
+%%BUNDLED_SSL%%include/node/openssl/archs/linux64-mips64/no-asm/include/progs.h
%%BUNDLED_SSL%%include/node/openssl/archs/linux-ppc/asm/crypto/buildinf.h
%%BUNDLED_SSL%%include/node/openssl/archs/linux-ppc/asm/crypto/include/internal/bn_conf.h
%%BUNDLED_SSL%%include/node/openssl/archs/linux-ppc/asm/crypto/include/internal/dso_conf.h