aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2004-02-19 20:23:49 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2004-02-19 20:23:49 +0000
commitb8bd1b983fb12afc0b01878acf9a38e29cd9d607 (patch)
tree744df0aadc701bb8b0df2fae4c931c87c0486bd9
parentf2719275dee7a5cdaa1aa0879dc0247972c84822 (diff)
downloadports-b8bd1b983fb12afc0b01878acf9a38e29cd9d607.tar.gz
ports-b8bd1b983fb12afc0b01878acf9a38e29cd9d607.zip
Notes
-rw-r--r--devel/libuta/Makefile12
-rw-r--r--devel/wftk/Makefile12
2 files changed, 12 insertions, 12 deletions
diff --git a/devel/libuta/Makefile b/devel/libuta/Makefile
index debc9fa32db1..afe03413983c 100644
--- a/devel/libuta/Makefile
+++ b/devel/libuta/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libuta
PORTVERSION= 0.4.4
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -35,10 +36,6 @@ SDL11_FILES= configure uta/color.h uta/event.h uta/keysym.h uta/mutex.h \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502102
-FORBIDDEN= "Links against conflicting thread libraries"
-.endif
-
.if exists(${LOCALBASE}/lib/libSDL_mixer.so.2)
WITH_SDL_MIXER= yes
.endif
@@ -53,7 +50,10 @@ post-patch:
.endfor
pre-configure:
- @${REINPLACE_CMD} -e 's|<freetype/freetype.h>|<freetype1/freetype/freetype.h>|g' \
- ${WRKSRC}/configure ${WRKSRC}/uta/font.h
+ @${REINPLACE_CMD} -e '\
+ s|<freetype/freetype.h>|<freetype1/freetype/freetype.h>|g; \
+ s|-lpthread||g; \
+ s|-lc_r|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure ${WRKSRC}/uta/font.h
.include <bsd.port.post.mk>
diff --git a/devel/wftk/Makefile b/devel/wftk/Makefile
index debc9fa32db1..afe03413983c 100644
--- a/devel/wftk/Makefile
+++ b/devel/wftk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libuta
PORTVERSION= 0.4.4
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -35,10 +36,6 @@ SDL11_FILES= configure uta/color.h uta/event.h uta/keysym.h uta/mutex.h \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502102
-FORBIDDEN= "Links against conflicting thread libraries"
-.endif
-
.if exists(${LOCALBASE}/lib/libSDL_mixer.so.2)
WITH_SDL_MIXER= yes
.endif
@@ -53,7 +50,10 @@ post-patch:
.endfor
pre-configure:
- @${REINPLACE_CMD} -e 's|<freetype/freetype.h>|<freetype1/freetype/freetype.h>|g' \
- ${WRKSRC}/configure ${WRKSRC}/uta/font.h
+ @${REINPLACE_CMD} -e '\
+ s|<freetype/freetype.h>|<freetype1/freetype/freetype.h>|g; \
+ s|-lpthread||g; \
+ s|-lc_r|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure ${WRKSRC}/uta/font.h
.include <bsd.port.post.mk>