aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-09-01 08:49:19 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-09-01 08:49:19 +0000
commitc4f73722c4aa1c78a1a23b87c7f5e64847e8a4f2 (patch)
treee094379ef6b174d20f1060e9b33bb65178c42cb0
parent06dd0042094b2b87e403814a5a6f16ba0f41b1f2 (diff)
downloadports-c4f73722c4aa1c78a1a23b87c7f5e64847e8a4f2.tar.gz
ports-c4f73722c4aa1c78a1a23b87c7f5e64847e8a4f2.zip
Notes
-rw-r--r--games/palomino/Makefile8
-rw-r--r--graphics/libgfx/Makefile8
-rw-r--r--mail/surblhost/Makefile8
-rw-r--r--sysutils/searchmonkey/Makefile8
-rw-r--r--sysutils/xsearch/Makefile8
5 files changed, 35 insertions, 5 deletions
diff --git a/games/palomino/Makefile b/games/palomino/Makefile
index e02163b2ff51..cb1911e607d7 100644
--- a/games/palomino/Makefile
+++ b/games/palomino/Makefile
@@ -36,4 +36,10 @@ do-install:
@${INSTALL_DATA} ${INSTALL_WRKSRC}/src/game_pony.py \
${WRKSRC}/palomino/engine/src/eng.py ${DATADIR}/pony/out/
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/libgfx/Makefile b/graphics/libgfx/Makefile
index 85f0d4468c01..a2068e9a6bda 100644
--- a/graphics/libgfx/Makefile
+++ b/graphics/libgfx/Makefile
@@ -33,4 +33,10 @@ do-install:
@${CP} -R ${WRKSRC}/include/gfx ${PREFIX}/include/
@${INSTALL_DATA} ${WRKSRC}/src/${PORTNAME}.a ${PREFIX}/lib/
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/surblhost/Makefile b/mail/surblhost/Makefile
index 561077f932c7..9648ffb8782e 100644
--- a/mail/surblhost/Makefile
+++ b/mail/surblhost/Makefile
@@ -18,4 +18,10 @@ GNU_CONFIGURE= yes
PLIST_FILES= bin/${PORTNAME}
MAN1= ${PORTNAME}.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/searchmonkey/Makefile b/sysutils/searchmonkey/Makefile
index e91d5432d521..471a420a9f73 100644
--- a/sysutils/searchmonkey/Makefile
+++ b/sysutils/searchmonkey/Makefile
@@ -25,4 +25,10 @@ PLIST_DIRS= %%DATADIR%%/pixmaps %%DATADIR%%
CFLAGS= -I${LOCALBASE}/include
LDFLAGS=-L${LOCALBASE}/lib
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/xsearch/Makefile b/sysutils/xsearch/Makefile
index e91d5432d521..471a420a9f73 100644
--- a/sysutils/xsearch/Makefile
+++ b/sysutils/xsearch/Makefile
@@ -25,4 +25,10 @@ PLIST_DIRS= %%DATADIR%%/pixmaps %%DATADIR%%
CFLAGS= -I${LOCALBASE}/include
LDFLAGS=-L${LOCALBASE}/lib
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>