aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-10 23:19:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-10 23:19:44 +0000
commitd8936b135609ca8f048d5368f393095df32d992b (patch)
tree62134f60e7db8ee2bc1ac01f902928d9475ff24a
parent6658c05243f4950e6cf4af3c53c221667c2e9ce5 (diff)
downloadports-d8936b135609ca8f048d5368f393095df32d992b.tar.gz
ports-d8936b135609ca8f048d5368f393095df32d992b.zip
Notes
-rw-r--r--graphics/gocr/Makefile22
-rw-r--r--graphics/gocr/distinfo6
-rw-r--r--graphics/gocr/files/patch-src_progress.h11
3 files changed, 12 insertions, 27 deletions
diff --git a/graphics/gocr/Makefile b/graphics/gocr/Makefile
index e449a44d7594..9e367dcb24f1 100644
--- a/graphics/gocr/Makefile
+++ b/graphics/gocr/Makefile
@@ -6,37 +6,33 @@
#
PORTNAME= gocr
-PORTVERSION= 0.44
-PORTREVISION= 1
+PORTVERSION= 0.45
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= jocr
+MASTER_SITES= SF/jocr
MAINTAINER= ports@FreeBSD.org
-COMMENT= GOCR/JOCR is an OCR (Optical Character Recognition) program
+COMMENT= An OCR (Optical Character Recognition) program
LIB_DEPENDS= netpbm.1:${PORTSDIR}/graphics/netpbm
+USE_GNOME= gnometarget
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-netpbm=${LOCALBASE}
MAKE_ARGS= prefix=${PREFIX} exec_prefix=${PREFIX} DESTDIR=${DESTDIR}
+MAN1= gocr.1
+PORTDOCS= examples.txt gocr.html unicode.txt
+PLIST_FILES= bin/gocr include/gocr.h lib/libPgm2asc.a
+
.if !defined(WITHOUT_X11)
-RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
+USE_TK_WRAPPER= yes
PLIST_FILES+= bin/gocr.tcl
.endif
-MAN1= gocr.1
-
-PORTDOCS= examples.txt gocr.html unicode.txt
-PLIST_FILES+= bin/gocr include/gocr.h lib/libPgm2asc.a
-
post-patch:
.if defined(WITHOUT_X11)
@${REINPLACE_CMD} -e '/gocr.tcl/d' ${WRKSRC}/src/Makefile.in
-.else
- @${REINPLACE_CMD} -e 's/exec wish/exec wish8.4/' ${WRKSRC}/bin/gocr.tcl
.endif
post-install:
diff --git a/graphics/gocr/distinfo b/graphics/gocr/distinfo
index 3fd7c8ef0fc1..73f0b57bbd29 100644
--- a/graphics/gocr/distinfo
+++ b/graphics/gocr/distinfo
@@ -1,3 +1,3 @@
-MD5 (gocr-0.44.tar.gz) = 8657cb057d7836ed171b5705d5e082c8
-SHA256 (gocr-0.44.tar.gz) = 20d7724db4d0a724ade2b36a5e95f329a0e1c46c972f08c123b67c33173b6b4f
-SIZE (gocr-0.44.tar.gz) = 827497
+MD5 (gocr-0.45.tar.gz) = 134d459f64656b201ca66eebafa108f0
+SHA256 (gocr-0.45.tar.gz) = d1846fe037b5d509373c92c0bc7dd4e6e5c290962e30e03fea5766326ec4b7f4
+SIZE (gocr-0.45.tar.gz) = 362952
diff --git a/graphics/gocr/files/patch-src_progress.h b/graphics/gocr/files/patch-src_progress.h
deleted file mode 100644
index 36be6555bc01..000000000000
--- a/graphics/gocr/files/patch-src_progress.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/progress.h.orig Sat Dec 16 16:12:16 2006
-+++ src/progress.h Sat Dec 16 16:12:46 2006
-@@ -6,6 +6,8 @@
- #ifndef GOCR_PROGRESS_H
- #define GOCR_PROGRESS_H "Oct06"
-
-+#include <time.h>
-+
- /* initialization of progress output, fname="<fileID>","<filename>","-" */
- int ini_progress(char *fname);
-