aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-02-25 12:18:06 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-02-25 12:18:06 +0000
commitd9e43cc0c29b9872a9df4666a431da9f42773dbc (patch)
tree50b0537767c2d5d587bfeaeb6ded08882b2607b1
parent9a77af3bc3f8e76350fe4efaae7e26e16d3360c5 (diff)
downloadports-d9e43cc0c29b9872a9df4666a431da9f42773dbc.tar.gz
ports-d9e43cc0c29b9872a9df4666a431da9f42773dbc.zip
Notes
-rw-r--r--mail/py-spambayes/Makefile19
-rw-r--r--mail/py-spambayes/distinfo4
-rw-r--r--mail/py-spambayes/files/patch-spambayes_Dibbler.py6
-rw-r--r--mail/py-spambayes/pkg-descr22
4 files changed, 16 insertions, 35 deletions
diff --git a/mail/py-spambayes/Makefile b/mail/py-spambayes/Makefile
index 6e46b7b177ee..f291eec87d28 100644
--- a/mail/py-spambayes/Makefile
+++ b/mail/py-spambayes/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= spambayes
-PORTVERSION= 1.1b1
-PORTREVISION= 1
+PORTVERSION= 1.1b2
CATEGORIES= mail python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,12 +16,14 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bsddb>0:${PORTSDIR}/databases/py-bsddb \
${PYTHON_PKGNAMEPREFIX}dns>=2.0:${PORTSDIR}/dns/py-dns \
${PYTHON_PKGNAMEPREFIX}lockfile>=0.2:${PORTSDIR}/devel/py-lockfile
-USES= python:2
+USES= python:-2.7
USE_PYTHON= distutils autoplist
-NO_ARCH= yes
-
USE_RC_SUBR= pyspamd
+OPTIONS_DEFINE= DOCS
+
+NO_ARCH= yes
+
LOCALSTATDIR?= /var/db/spambayes
DBDIR?= ${LOCALSTATDIR}/dbs
CACHEDIR?= ${LOCALSTATDIR}/cache
@@ -44,18 +45,10 @@ PORTDOCS= CHANGELOG.txt \
utilities/ \
contrib/
-OPTIONS_DEFINE= DOCS
-
post-extract:
@${CHMOD} -Rf u+w ${WRKSRC}
post-patch:
- @${FIND} ${WRKSRC} -type f | \
- ${XARGS} -n 10 -x \
- ${REINPLACE_CMD} -E \
- -e 's|/usr/bin/env python|${PYTHONBASE}/bin/${PYTHON_VERSION}|'
- @${FIND} ${WRKSRC}/utilities ${WRKSRC}/contrib ${WRKSRC}/spambayes\
- -type f -name *.bak | ${XARGS} ${RM}
@${REINPLACE_CMD} -e \
'/persistent_storage_file/s|hammie.db|${DBDIR}/hammie.db|' \
-e \
diff --git a/mail/py-spambayes/distinfo b/mail/py-spambayes/distinfo
index 8ff0de75b722..c0dd13856454 100644
--- a/mail/py-spambayes/distinfo
+++ b/mail/py-spambayes/distinfo
@@ -1,2 +1,2 @@
-SHA256 (spambayes-1.1b1.tar.gz) = 4dc4aef5b0b3c3a02d8d36391d3ebde6ab3078e4aa39f0611b226f03993c9c36
-SIZE (spambayes-1.1b1.tar.gz) = 1015721
+SHA256 (spambayes-1.1b2.tar.gz) = 8d186d1e7a67de88941f27e0cfcfb4e88fffd7706f51e9181a5bcdaa1b6f8294
+SIZE (spambayes-1.1b2.tar.gz) = 1001993
diff --git a/mail/py-spambayes/files/patch-spambayes_Dibbler.py b/mail/py-spambayes/files/patch-spambayes_Dibbler.py
index a2ab6a17175d..6c8781d4ece1 100644
--- a/mail/py-spambayes/files/patch-spambayes_Dibbler.py
+++ b/mail/py-spambayes/files/patch-spambayes_Dibbler.py
@@ -1,6 +1,6 @@
---- spambayes/Dibbler.py~ 2009-07-10 21:43:59.000000000 +0200
-+++ spambayes/Dibbler.py 2009-07-10 21:44:37.655326444 +0200
-@@ -218,7 +218,7 @@
+--- spambayes/Dibbler.py.orig 2013-02-06 11:28:18 UTC
++++ spambayes/Dibbler.py
+@@ -215,7 +215,7 @@ class BrighterAsyncChat(asynchat.async_c
# self.initiate_send() raises an exception, causing self.close()
# to be called. If we didn't check, we could end up in an infinite
# loop.
diff --git a/mail/py-spambayes/pkg-descr b/mail/py-spambayes/pkg-descr
index 2495c793cc1d..e67689dd5358 100644
--- a/mail/py-spambayes/pkg-descr
+++ b/mail/py-spambayes/pkg-descr
@@ -1,19 +1,7 @@
-[ excerpt with modifications from developer's site ]
-
-The SpamBayes project is working on developing a Bayesian anti-spam
-filter.
-
-SpamBayes will attempt to classify incoming email messages as 'spam',
-'ham' (good, non-spam email) or 'unsure'. This means you can have
-spam or unsure messages automatically filed away in a different
-mail folder, where it won't interrupt your email reading.
-
-First, SpamBayes must be trained by each user to identify spam and
-ham. Essentially, you show SpamBayes a pile of email that you like
-(ham) and a pile you don't like (spam). SpamBayes will then analyze
-the piles for clues as to what makes the spam and ham different.
-For example; different words, differences in the mailer headers and
-content style. The system then uses these clues to examine new
-messages.
+SpamBayes is a tool used to segregate unwanted mail (spam) from the mail you
+want (ham). Before SpamBayes can be your spam filter of choice you need to
+train it on representative samples of email you receive. After it's been
+trained, you use SpamBayes to classify new mail according to its spamminess
+and hamminess qualities.
WWW: http://spambayes.sourceforge.net/