aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-06-13 16:59:35 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-06-13 16:59:35 +0000
commitdb631aea64f780133beeb1a52397321699be9252 (patch)
treebf8c0c3afdab3e95643aaa5b2638980dab84eb0d
parent7d4f4da4319785ffb7d3bb33f6392c86d672f3fb (diff)
downloadports-db631aea64f780133beeb1a52397321699be9252.tar.gz
ports-db631aea64f780133beeb1a52397321699be9252.zip
Notes
-rw-r--r--devel/android-tools-fastboot/Makefile2
-rw-r--r--devel/android-tools-fastboot/files/usb_freebsd.c4
2 files changed, 5 insertions, 1 deletions
diff --git a/devel/android-tools-fastboot/Makefile b/devel/android-tools-fastboot/Makefile
index 791742f3c8f9..1cb074b6f177 100644
--- a/devel/android-tools-fastboot/Makefile
+++ b/devel/android-tools-fastboot/Makefile
@@ -3,7 +3,7 @@
PORTNAME= android-tools-fastboot
DISTVERSIONPREFIX= android-
DISTVERSION= 5.1.1_r4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel
MASTER_SITES= https://anonscm.debian.org/cgit/android-tools/android-tools.git/plain/debian/:bashcomp,manpage
DISTFILES= bash_completion.d/fastboot?id=2b8cfec:bashcomp \
diff --git a/devel/android-tools-fastboot/files/usb_freebsd.c b/devel/android-tools-fastboot/files/usb_freebsd.c
index 45f11c62309d..09b68aee7e9d 100644
--- a/devel/android-tools-fastboot/files/usb_freebsd.c
+++ b/devel/android-tools-fastboot/files/usb_freebsd.c
@@ -72,6 +72,10 @@ probe(struct usb_handle *h, ifc_match_func callback)
info.dev_class = ddesc.bDeviceClass;
info.dev_subclass = ddesc.bDeviceSubClass;
info.dev_protocol = ddesc.bDeviceProtocol;
+ info.writable = 1;
+
+ snprintf(info.device_path, sizeof(info.device_path), "ugen%d.%d",
+ libusb_get_bus_number(h->dev), libusb_get_device_address(h->dev));
if (ddesc.iSerialNumber != 0) {
libusb_get_string_descriptor_ascii(h->handle, ddesc.iSerialNumber,