aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-09-25 18:15:32 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-09-25 18:15:32 +0000
commite820361113edf2ee8189d4c9573e72c09fbcbb02 (patch)
treef14e644cfae02170f6b499448151c81a3b1723df
parente7b15636936690af4d13b2cce7bc180bd31453f5 (diff)
downloadports-e820361113edf2ee8189d4c9573e72c09fbcbb02.tar.gz
ports-e820361113edf2ee8189d4c9573e72c09fbcbb02.zip
MFH: r512802
devel/RStudio: unbreak PR: 236603 Obtained from: upstream Approved by: ports-secteam blanket
Notes
Notes: svn path=/branches/2019Q3/; revision=512803
-rw-r--r--devel/RStudio/Makefile5
-rw-r--r--devel/RStudio/distinfo2
-rw-r--r--devel/RStudio/files/patch-boost-1.7062
3 files changed, 5 insertions, 64 deletions
diff --git a/devel/RStudio/Makefile b/devel/RStudio/Makefile
index 5c72ecb8df13..f6cdcf398d8a 100644
--- a/devel/RStudio/Makefile
+++ b/devel/RStudio/Makefile
@@ -15,14 +15,15 @@ DISTFILES= core-dictionaries.zip:dictionaries \
gwt-${GWT_VERSION}.zip:buildtools \
mathjax-26.zip:buildtools
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= 33c2c42d40ad.patch:-p1
+
MAINTAINER= yuri@FreeBSD.org
COMMENT= Integrated development environment (IDE) for R
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= fails to build with boost 1.70, see bug 236603
-
BUILD_DEPENDS= ant:devel/apache-ant \
${LOCALBASE}/include/sys/sysinfo.h:devel/libsysinfo \
pandoc:textproc/hs-pandoc
diff --git a/devel/RStudio/distinfo b/devel/RStudio/distinfo
index 100e9daba3ea..41ce401851dc 100644
--- a/devel/RStudio/distinfo
+++ b/devel/RStudio/distinfo
@@ -17,3 +17,5 @@ SHA256 (rstudio-rsconnect-03c379b_GH0.tar.gz) = d24b6ee49f32f650f6d10bbfc7b2f61a
SIZE (rstudio-rsconnect-03c379b_GH0.tar.gz) = 220711
SHA256 (trestletech-plumber-v0.4.6_GH0.tar.gz) = 7bcbfdf5a8a2e3a051d2c673ac5ac51a483ed888afe73116cba7741dbb5f63a6
SIZE (trestletech-plumber-v0.4.6_GH0.tar.gz) = 83332
+SHA256 (33c2c42d40ad.patch) = d252111e28a7de8602b4df1f66b36dded260061f094b504895e5c789f8681091
+SIZE (33c2c42d40ad.patch) = 4875
diff --git a/devel/RStudio/files/patch-boost-1.70 b/devel/RStudio/files/patch-boost-1.70
deleted file mode 100644
index bc9730682536..000000000000
--- a/devel/RStudio/files/patch-boost-1.70
+++ /dev/null
@@ -1,62 +0,0 @@
-https://github.com/zaphoyd/websocketpp/issues/794
-
---- src/cpp/ext/websocketpp/transport/asio/connection.hpp.orig 2019-03-05 23:41:04 UTC
-+++ src/cpp/ext/websocketpp/transport/asio/connection.hpp
-@@ -296,7 +296,7 @@ class connection : public config::socket_type::socket_
- */
- timer_ptr set_timer(long duration, timer_handler callback) {
- timer_ptr new_timer = lib::make_shared<boost::asio::deadline_timer>(
-- lib::ref(*m_io_service),
-+ *m_io_service,
- boost::posix_time::milliseconds(duration)
- );
-
-@@ -423,7 +423,7 @@ class connection : public config::socket_type::socket_
-
- if (config::enable_multithreading) {
- m_strand = lib::make_shared<boost::asio::io_service::strand>(
-- lib::ref(*io_service));
-+ *io_service);
-
- m_async_read_handler = m_strand->wrap(lib::bind(
- &type::handle_async_read, get_shared(),lib::placeholders::_1,
---- src/cpp/ext/websocketpp/transport/asio/endpoint.hpp.orig 2019-03-05 23:41:04 UTC
-+++ src/cpp/ext/websocketpp/transport/asio/endpoint.hpp
-@@ -184,7 +184,7 @@ class endpoint : public config::socket_type { (public)
- m_io_service = ptr;
- m_external_io_service = true;
- m_acceptor = lib::make_shared<boost::asio::ip::tcp::acceptor>(
-- lib::ref(*m_io_service));
-+ *m_io_service);
-
- m_state = READY;
- ec = lib::error_code();
-@@ -610,7 +610,7 @@ class endpoint : public config::socket_type { (public)
- */
- void start_perpetual() {
- m_work = lib::make_shared<boost::asio::io_service::work>(
-- lib::ref(*m_io_service)
-+ *m_io_service
- );
- }
-
-@@ -776,7 +776,7 @@ class endpoint : public config::socket_type { (public)
- // Create a resolver
- if (!m_resolver) {
- m_resolver = lib::make_shared<boost::asio::ip::tcp::resolver>(
-- lib::ref(*m_io_service));
-+ *m_io_service);
- }
-
- std::string proxy = tcon->get_proxy();
---- src/cpp/ext/websocketpp/transport/asio/security/none.hpp.orig 2019-03-05 23:41:04 UTC
-+++ src/cpp/ext/websocketpp/transport/asio/security/none.hpp
-@@ -167,7 +167,7 @@ class connection : public lib::enable_shared_from_this
- }
-
- m_socket = lib::make_shared<boost::asio::ip::tcp::socket>(
-- lib::ref(*service));
-+ *service);
-
- m_state = READY;
-