aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2008-03-04 22:57:41 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2008-03-04 22:57:41 +0000
commitf1afd642c6bf19960d2a83978b64e122a9a41245 (patch)
treefe951c037de3e8a2d79d098672cf8f289b6c9def
parentb2117034c8d8f4f7e40fea048c2db9b57b151cf8 (diff)
downloadports-f1afd642c6bf19960d2a83978b64e122a9a41245.tar.gz
ports-f1afd642c6bf19960d2a83978b64e122a9a41245.zip
Notes
-rw-r--r--security/gnupg/Makefile26
-rw-r--r--security/gnupg/distinfo12
-rw-r--r--security/gnupg/pkg-plist37
3 files changed, 53 insertions, 22 deletions
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index 4a633d7615ef..19cfddd295bb 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnupg
-PORTVERSION= 2.0.4
-PORTREVISION= 1
+PORTVERSION= 2.0.8
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= gnupg
@@ -17,7 +16,8 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= The GNU Privacy Guard
-BUILD_DEPENDS= libassuan>=1.0.1:${PORTSDIR}/security/libassuan
+BUILD_DEPENDS= libassuan>=1.0.4:${PORTSDIR}/security/libassuan \
+ libksba>=1.0.2:${PORTSDIR}/security/libksba
LIB_DEPENDS= gcrypt.15:${PORTSDIR}/security/libgcrypt \
gpg-error:${PORTSDIR}/security/libgpg-error \
ksba.17:${PORTSDIR}/security/libksba \
@@ -31,19 +31,21 @@ GNU_CONFIGURE= YES
USE_ICONV= YES
USE_LDCONFIG= YES
USE_GETTEXT= YES
-CONFIGURE_TARGET=# empty
-CONFIGURE_ARGS+= --enable-nls
+.if defined(NOPORTDOCS)
+CONFIGURE_ARGS+= --disable-doc
+.else
MAN1= gpg2.1 gpgsm.1 gpgv2.1 gpg-agent.1 scdaemon.1 watchgnupg.1 \
gpgconf.1 gpg-preset-passphrase.1 gpg-connect-agent.1 \
gpgparsemail.1 symcryptrun.1 gpgsm-gencert.sh.1
MAN8= addgnupghome.8 applygnupgdefaults.8
INFO= gnupg
+.endif
OPTIONS= LDAP "LDAP keyserver interface" off \
SCDAEMON "Enable Smartcard daemon (with libusb)" off \
CURL "Use the real curl library (worked around if no)" on \
- GPGSM "Enable GPGSM (require LDAP)" on
-#OPTIONS+= NLS "National Language Support" off
+ GPGSM "Enable GPGSM (require LDAP)" off \
+ NLS "National Language Support" off
.include <bsd.port.pre.mk>
@@ -66,13 +68,13 @@ CONFIGURE_ARGS+=--disable-ldap
PLIST_SUB+= LDAP="@comment "
.endif
-#.if defined(WITH_NLS)
+.if defined(WITH_NLS) && !defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
-#.else
-#CONFIGURE_ARGS+=--disable-nls
-#PLIST_SUB+= NLS="@comment "
-#.endif
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
.if defined(WITH_SCDAEMON)
CONFIGURE_ARGS+=--enable-scdaemon
diff --git a/security/gnupg/distinfo b/security/gnupg/distinfo
index 45b2adfa782e..58a45f6e25fd 100644
--- a/security/gnupg/distinfo
+++ b/security/gnupg/distinfo
@@ -1,6 +1,6 @@
-MD5 (gnupg-2.0.4.tar.bz2) = e16efce067ba132f933792a3ec7f180e
-SHA256 (gnupg-2.0.4.tar.bz2) = 3872d7280e5a12a947509c73b70c3024521c29ff4427c8fb4caa17dde2f4248c
-SIZE (gnupg-2.0.4.tar.bz2) = 3575021
-MD5 (gnupg-2.0.4.tar.bz2.sig) = 5c92699afb465541b510d989617c9aa9
-SHA256 (gnupg-2.0.4.tar.bz2.sig) = 0ceb6be2036f2699643b4c2e7e7ba165b1bfd362f3fd362e5252d7cb90b6dc9d
-SIZE (gnupg-2.0.4.tar.bz2.sig) = 158
+MD5 (gnupg-2.0.8.tar.bz2) = fc4377ca67e1bf687eeaf22e79c0b9d1
+SHA256 (gnupg-2.0.8.tar.bz2) = 16f310afe4740a26475c7273f585861a4bdefecbde27c214cc30c0db45d26913
+SIZE (gnupg-2.0.8.tar.bz2) = 3654523
+MD5 (gnupg-2.0.8.tar.bz2.sig) = 5f4fefbca2568910e3628b4d8ea3d485
+SHA256 (gnupg-2.0.8.tar.bz2.sig) = e68772c8d16a80311c5380ef024c52ad140f2fc3cf43c778a2e2d3bf2eea24d5
+SIZE (gnupg-2.0.8.tar.bz2.sig) = 158
diff --git a/security/gnupg/pkg-plist b/security/gnupg/pkg-plist
index 9de759618485..bf679b780453 100644
--- a/security/gnupg/pkg-plist
+++ b/security/gnupg/pkg-plist
@@ -10,6 +10,7 @@ bin/gpgv2
%%GPGSM%%bin/kbxutil
%%SCDAEMON%%bin/scdaemon
bin/watchgnupg
+libexec/gpg-check-pattern
%%SCDAEMON%%libexec/gnupg-pcsc-wrapper
libexec/gpg-preset-passphrase
libexec/gpg-protect-tool
@@ -19,11 +20,39 @@ libexec/gpg2keys_hkp
%%LDAP%%libexec/gpg2keys_ldap
sbin/addgnupghome
sbin/applygnupgdefaults
-share/gnupg/FAQ
-share/gnupg/com-certs.pem
-share/gnupg/faq.html
+%%PORTDOCS%%share/gnupg/FAQ
+%%PORTDOCS%%share/gnupg/com-certs.pem
+%%PORTDOCS%%share/gnupg/faq.html
share/gnupg/gpg-conf.skel
-share/gnupg/qualified.txt
+%%PORTDOCS%%share/gnupg/help.be.txt
+%%PORTDOCS%%share/gnupg/help.ca.txt
+%%PORTDOCS%%share/gnupg/help.cs.txt
+%%PORTDOCS%%share/gnupg/help.da.txt
+%%PORTDOCS%%share/gnupg/help.de.txt
+%%PORTDOCS%%share/gnupg/help.el.txt
+%%PORTDOCS%%share/gnupg/help.eo.txt
+%%PORTDOCS%%share/gnupg/help.es.txt
+%%PORTDOCS%%share/gnupg/help.et.txt
+%%PORTDOCS%%share/gnupg/help.fi.txt
+%%PORTDOCS%%share/gnupg/help.fr.txt
+%%PORTDOCS%%share/gnupg/help.gl.txt
+%%PORTDOCS%%share/gnupg/help.hu.txt
+%%PORTDOCS%%share/gnupg/help.id.txt
+%%PORTDOCS%%share/gnupg/help.it.txt
+%%PORTDOCS%%share/gnupg/help.ja.txt
+%%PORTDOCS%%share/gnupg/help.nb.txt
+%%PORTDOCS%%share/gnupg/help.pl.txt
+%%PORTDOCS%%share/gnupg/help.pt.txt
+%%PORTDOCS%%share/gnupg/help.pt_BR.txt
+%%PORTDOCS%%share/gnupg/help.ro.txt
+%%PORTDOCS%%share/gnupg/help.ru.txt
+%%PORTDOCS%%share/gnupg/help.sk.txt
+%%PORTDOCS%%share/gnupg/help.sv.txt
+%%PORTDOCS%%share/gnupg/help.tr.txt
+%%PORTDOCS%%share/gnupg/help.txt
+%%PORTDOCS%%share/gnupg/help.zh_CN.txt
+%%PORTDOCS%%share/gnupg/help.zh_TW.txt
+%%PORTDOCS%%share/gnupg/qualified.txt
%%NLS%%share/locale/da/LC_MESSAGES/gnupg2.mo
%%NLS%%share/locale/de/LC_MESSAGES/gnupg2.mo
%%NLS%%share/locale/eo/LC_MESSAGES/gnupg2.mo