aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-11-21 15:30:37 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-11-21 15:30:37 +0000
commitf2b63e6ac7eaa91e30b290a6671fcbf4cc96c29b (patch)
tree937439937bb7a1abdf92632546d469f8a0d076c2
parentbd18aceda7b342e86f280a8291ba2bd90bd606c2 (diff)
downloadports-f2b63e6ac7eaa91e30b290a6671fcbf4cc96c29b.tar.gz
ports-f2b63e6ac7eaa91e30b290a6671fcbf4cc96c29b.zip
Notes
-rw-r--r--www/cocoon/Makefile4
-rw-r--r--www/cocoon/Makefile.options7
-rw-r--r--www/cocoon/Makefile.test-options50
-rw-r--r--www/cocoon/distinfo4
-rw-r--r--www/cocoon/files/cocoonctl9
-rw-r--r--www/cocoon/files/pkg-deinstall12
-rw-r--r--www/cocoon/pkg-message35
7 files changed, 102 insertions, 19 deletions
diff --git a/www/cocoon/Makefile b/www/cocoon/Makefile
index 55b77ee06b17..f33a477e9557 100644
--- a/www/cocoon/Makefile
+++ b/www/cocoon/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cocoon
-PORTVERSION= 2.1.7
+PORTVERSION= 2.1.8
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -142,7 +142,7 @@ post-install:
@${SED} ${SUBSTITUTIONS} ${MASTERDIR}/pkg-message > ${PKGMESSAGE}
@${ECHO_CMD}
@${ECHO_CMD} "********************************************************************************"
- @${CAT} ${PKGMESSAGE} | fmt -w 80
+ @${FMT} -w80 ${PKGMESSAGE}
@${ECHO_CMD} "********************************************************************************"
@${ECHO_CMD}
diff --git a/www/cocoon/Makefile.options b/www/cocoon/Makefile.options
index 65a981367edd..7d0c167af4b3 100644
--- a/www/cocoon/Makefile.options
+++ b/www/cocoon/Makefile.options
@@ -17,6 +17,7 @@ OPTIONS+= JFOR 'Enable the jfor block' on
OPTIONS+= JSP 'Enable the jsp block' on
OPTIONS+= LINKREWRITER 'Enable the linkrewriter block' on
OPTIONS+= LUCENE 'Enable the lucene block' on
+OPTIONS+= MIDI 'Enable the midi block' on
OPTIONS+= NAMING 'Enable the naming block' on
OPTIONS+= OJB 'Enable the ojb block' on
OPTIONS+= PARANOID 'Enable the paranoid block' on
@@ -33,19 +34,21 @@ OPTIONS+= PHP 'Enable the php block' off
OPTIONS+= PORTAL_FW 'Enable the portal-fw block' off
OPTIONS+= SWF 'Enable the swf block' off
OPTIONS+= WOODY 'Enable the woody block' off
+OPTIONS+= AJAX 'Enable the ajax block' on
OPTIONS+= APPLES 'Enable the apples block' on
OPTIONS+= ASCIIART 'Enable the asciiart block' on
OPTIONS+= AXIS 'Enable the axis block' on
+OPTIONS+= CAPTCHA 'Enable the captcha block' on
OPTIONS+= CRON 'Enable the cron block' on
OPTIONS+= DELI 'Enable the deli block' on
OPTIONS+= EVENTCACHE 'Enable the eventcache block' on
OPTIONS+= FACES 'Enable the faces block' on
OPTIONS+= FORMS 'Enable the forms block' on
OPTIONS+= JAVAFLOW 'Enable the javaflow block' on
+OPTIONS+= JCR 'Enable the jcr block' on
OPTIONS+= JMS 'Enable the jms block' on
OPTIONS+= LINOTYPE 'Enable the linotype block' on
OPTIONS+= MAIL 'Enable the mail block' on
-OPTIONS+= MIDI 'Enable the midi block' on
OPTIONS+= PETSTORE 'Enable the petstore block' on
OPTIONS+= PROXY 'Enable the proxy block' on
OPTIONS+= QDOX 'Enable the qdox block' on
@@ -57,4 +60,6 @@ OPTIONS+= SLOP 'Enable the slop block' on
OPTIONS+= STX 'Enable the stx block' on
OPTIONS+= TAGLIB 'Enable the taglib block' on
OPTIONS+= TOUR 'Enable the tour block' on
+OPTIONS+= VALIDATION 'Enable the validation block' on
OPTIONS+= WEBDAV 'Enable the webdav block' on
+OPTIONS+= XSLTAL 'Enable the xsltal block' on
diff --git a/www/cocoon/Makefile.test-options b/www/cocoon/Makefile.test-options
index 1a669d12c3dd..91b27738bf28 100644
--- a/www/cocoon/Makefile.test-options
+++ b/www/cocoon/Makefile.test-options
@@ -38,6 +38,7 @@ BLOCKS+= html
.if defined(WITH_ITEXT)
BLOCKS+= itext
+BLOCKS+= xsp
.endif
.if defined(WITH_JFOR)
@@ -57,12 +58,17 @@ BLOCKS+= xsp
BLOCKS+= lucene
.endif
+.if defined(WITH_MIDI)
+BLOCKS+= midi
+.endif
+
.if defined(WITH_NAMING)
BLOCKS+= naming
.endif
.if defined(WITH_OJB)
BLOCKS+= ojb
+BLOCKS+= ajax
BLOCKS+= databases
BLOCKS+= forms
BLOCKS+= hsqldb
@@ -79,9 +85,13 @@ BLOCKS+= poi
.if defined(WITH_PORTAL)
BLOCKS+= portal
+BLOCKS+= ajax
BLOCKS+= authentication-fw
BLOCKS+= cron
+BLOCKS+= databases
BLOCKS+= forms
+BLOCKS+= hsqldb
+BLOCKS+= ojb
BLOCKS+= session-fw
BLOCKS+= xsp
.endif
@@ -138,8 +148,13 @@ BLOCKS+= woody
BLOCKS+= xsp
.endif
+.if defined(WITH_AJAX)
+BLOCKS+= ajax
+.endif
+
.if defined(WITH_APPLES)
BLOCKS+= apples
+BLOCKS+= ajax
BLOCKS+= forms
.endif
@@ -151,6 +166,10 @@ BLOCKS+= asciiart
BLOCKS+= axis
.endif
+.if defined(WITH_CAPTCHA)
+BLOCKS+= captcha
+.endif
+
.if defined(WITH_CRON)
BLOCKS+= cron
.endif
@@ -161,6 +180,7 @@ BLOCKS+= deli
.if defined(WITH_EVENTCACHE)
BLOCKS+= eventcache
+BLOCKS+= cron
BLOCKS+= databases
BLOCKS+= hsqldb
BLOCKS+= jms
@@ -169,9 +189,13 @@ BLOCKS+= xsp
.if defined(WITH_FACES)
BLOCKS+= faces
+BLOCKS+= ajax
BLOCKS+= authentication-fw
BLOCKS+= cron
+BLOCKS+= databases
BLOCKS+= forms
+BLOCKS+= hsqldb
+BLOCKS+= ojb
BLOCKS+= portal
BLOCKS+= session-fw
BLOCKS+= taglib
@@ -180,10 +204,12 @@ BLOCKS+= xsp
.if defined(WITH_FORMS)
BLOCKS+= forms
+BLOCKS+= ajax
.endif
.if defined(WITH_JAVAFLOW)
BLOCKS+= javaflow
+BLOCKS+= ajax
BLOCKS+= databases
BLOCKS+= forms
BLOCKS+= hsqldb
@@ -191,8 +217,13 @@ BLOCKS+= ojb
BLOCKS+= xsp
.endif
+.if defined(WITH_JCR)
+BLOCKS+= jcr
+.endif
+
.if defined(WITH_JMS)
BLOCKS+= jms
+BLOCKS+= cron
BLOCKS+= databases
BLOCKS+= hsqldb
BLOCKS+= xsp
@@ -207,12 +238,9 @@ BLOCKS+= mail
BLOCKS+= asciiart
.endif
-.if defined(WITH_MIDI)
-BLOCKS+= midi
-.endif
-
.if defined(WITH_PETSTORE)
BLOCKS+= petstore
+BLOCKS+= ajax
BLOCKS+= databases
BLOCKS+= forms
BLOCKS+= hsqldb
@@ -230,6 +258,7 @@ BLOCKS+= qdox
.if defined(WITH_QUERYBEAN)
BLOCKS+= querybean
+BLOCKS+= ajax
BLOCKS+= databases
BLOCKS+= forms
BLOCKS+= hsqldb
@@ -240,6 +269,7 @@ BLOCKS+= xsp
.if defined(WITH_REPOSITORY)
BLOCKS+= repository
+BLOCKS+= cron
BLOCKS+= databases
BLOCKS+= eventcache
BLOCKS+= hsqldb
@@ -253,6 +283,7 @@ BLOCKS+= serializers
.if defined(WITH_SLIDE)
BLOCKS+= slide
+BLOCKS+= cron
BLOCKS+= databases
BLOCKS+= eventcache
BLOCKS+= hsqldb
@@ -275,13 +306,20 @@ BLOCKS+= taglib
.if defined(WITH_TOUR)
BLOCKS+= tour
+BLOCKS+= ajax
BLOCKS+= batik
BLOCKS+= fop
BLOCKS+= forms
+BLOCKS+= slop
+.endif
+
+.if defined(WITH_VALIDATION)
+BLOCKS+= validation
.endif
.if defined(WITH_WEBDAV)
BLOCKS+= webdav
+BLOCKS+= cron
BLOCKS+= databases
BLOCKS+= eventcache
BLOCKS+= hsqldb
@@ -290,3 +328,7 @@ BLOCKS+= repository
BLOCKS+= xsp
.endif
+.if defined(WITH_XSLTAL)
+BLOCKS+= xsltal
+.endif
+
diff --git a/www/cocoon/distinfo b/www/cocoon/distinfo
index c51c2e47172b..7baeeb2e50d5 100644
--- a/www/cocoon/distinfo
+++ b/www/cocoon/distinfo
@@ -1,2 +1,2 @@
-MD5 (cocoon-2.1.7-src.tar.gz) = 423209dad3650e4f4fb1d76bd64a4747
-SIZE (cocoon-2.1.7-src.tar.gz) = 41950734
+MD5 (cocoon-2.1.8-src.tar.gz) = 98ecb00c42ed41525cb6f098eacf76e5
+SIZE (cocoon-2.1.8-src.tar.gz) = 44885682
diff --git a/www/cocoon/files/cocoonctl b/www/cocoon/files/cocoonctl
index b1aad58b9002..bfc05ad28fe3 100644
--- a/www/cocoon/files/cocoonctl
+++ b/www/cocoon/files/cocoonctl
@@ -141,19 +141,20 @@ if __name__ == '__main__':
APP_HOME = "%%APP_HOME%%"
PID_FILE = "%%PID_FILE%%"
COMMAND = "%%PREFIX%%/sbin/%%APP_NAME%%.sh"
+ os.environ["JAVA_OPTIONS"] = " ".join(sys.argv[1:-1])
ARGS = [COMMAND, "servlet"]
- if len(sys.argv) != 2:
+ if len(sys.argv) < 2:
usage()
sys.exit(1)
- if sys.argv[1] == "start":
+ if sys.argv[-1] == "start":
start()
- elif sys.argv[1] == "stop":
+ elif sys.argv[-1] == "stop":
stop()
- elif sys.argv[1] == "restart":
+ elif sys.argv[-1] == "restart":
stop()
start()
diff --git a/www/cocoon/files/pkg-deinstall b/www/cocoon/files/pkg-deinstall
index b540c3647127..fcfbbb0d33c2 100644
--- a/www/cocoon/files/pkg-deinstall
+++ b/www/cocoon/files/pkg-deinstall
@@ -43,11 +43,13 @@ if [ "$2" = "DEINSTALL" ]; then
fi
fi
- echo -n ">> Removing log file (${LOG_FILE})..."
- if rm ${LOG_FILE} > /dev/null 2> /dev/null ; then
- echo " [ DONE ]"
- else
- echo " [ FAILED ]"
+ if [ -e ${LOG_FILE} ] ; then
+ echo -n ">> Removing log file (${LOG_FILE})..."
+ if rm ${LOG_FILE} > /dev/null 2> /dev/null ; then
+ echo " [ DONE ]"
+ else
+ echo " [ FAILED ]"
+ fi
fi
fi
diff --git a/www/cocoon/pkg-message b/www/cocoon/pkg-message
index cf783f8360ea..9c639a676013 100644
--- a/www/cocoon/pkg-message
+++ b/www/cocoon/pkg-message
@@ -3,10 +3,43 @@ Cocoon is now installed in %%APP_HOME%%.
In order to be able to run Cocoon, please add the following line to
/etc/rc.conf:
-%%APP_NAME%%_enable="YES"
+ %%APP_NAME%%_enable="YES"
If you wish to start cocoon right now, invoke the startup script with
`%%PREFIX%%/etc/rc.d/%%APP_NAME%%.sh start'
and point your web browser to the default home page at
http://localhost:%%PORT%%/ where you may read the documentation and test the
samples.
+
+For this control script to run seamlessly, it is recommended to increase the
+maximum length of commands displayed by ps(1). Please append the following
+setting to /etc/sysctl.conf:
+
+ # Do not truncate command line arguments in ps(1) listing
+ kern.ps_arg_cache_limit=10000
+
+This setting will take effect at next reboot, however it is possible to have
+immediate effect with the following command as root:
+
+ # sysctl kern.ps_arg_cache_limit=10000
+
+If you wish to skip this setting, please note that the `stop', `restart' and
+`status' will not function properly with %%APP_NAME%%.sh.
+
+
+Enjoy!
+
+--------------------------------------------------------------------------------
+ADVANCED USAGE
+
+If you need to pass special options to Java, please set the
+%%APP_NAME%%_flags option in /etc/rc.conf, see examples below:
+
+ # Prevent Java from opening an X11 display
+ %%APP_NAME%%_flags="-Djava.awt.headless=true"
+
+ # Increase memory limit of the Java virtual machine
+ %%APP_NAME%%_flags="-Xms32m -Xmx256m"
+
+ # Run Java virtual machine with remote debugging turned on on port 8000
+ %%APP_NAME%%_flags="-Xdebug -Xnoagent -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=8000"